浏览代码

lighttpd: update to 1.4.37

Signed-off-by: W. Michael Petullo <mike@flyn.org>
W. Michael Petullo 9 年前
父节点
当前提交
01b087c043

+ 2
- 2
net/lighttpd/Makefile 查看文件

@@ -8,12 +8,12 @@
8 8
 include $(TOPDIR)/rules.mk
9 9
 
10 10
 PKG_NAME:=lighttpd
11
-PKG_VERSION:=1.4.36
11
+PKG_VERSION:=1.4.37
12 12
 PKG_RELEASE:=1
13 13
 
14 14
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.xz
15 15
 PKG_SOURCE_URL:=http://download.lighttpd.net/lighttpd/releases-1.4.x
16
-PKG_MD5SUM:=1843daffcb018aa528f6d15d43544654
16
+PKG_MD5SUM:=ca40168f54b46ee29475868ced8507d6
17 17
 
18 18
 PKG_LICENSE:=BSD-3c
19 19
 PKG_LICENSE_FILES:=COPYING

+ 0
- 26
net/lighttpd/patches/001-fix-out-of-filedescriptors-when-uploading-large-file.patch 查看文件

@@ -1,26 +0,0 @@
1
-From: =?UTF-8?q?Stefan=20B=C3=BChler?= <stbuehler@web.de>
2
-Date: Thu, 13 Aug 2015 18:44:27 +0000
3
-Subject: [PATCH] fix out-of-filedescriptors when uploading "large" files
4
- (fixes #2660, thx rmilecki)
5
-MIME-Version: 1.0
6
-Content-Type: text/plain; charset=UTF-8
7
-Content-Transfer-Encoding: 8bit
8
-
9
-From: Stefan Bühler <stbuehler@web.de>
10
-
11
-git-svn-id: svn://svn.lighttpd.net/lighttpd/branches/lighttpd-1.4.x@3009 152afb58-edef-0310-8abb-c4023f1b3aa9
12
----
13
- src/chunk.c | 2 +-
14
- 1 file changed, 1 insertion(+), 1 deletion(-)
15
-
16
---- a/src/chunk.c
17
-+++ b/src/chunk.c
18
-@@ -432,7 +432,7 @@ static int chunkqueue_append_to_tempfile
19
- 	 * */
20
- 
21
- 	if (NULL != dest->last
22
--		&& FILE_CHUNK != dest->last->type
23
-+		&& FILE_CHUNK == dest->last->type
24
- 		&& dest->last->file.is_temp
25
- 		&& -1 != dest->last->file.fd
26
- 		&& 0 == dest->last->offset) {