Browse Source

open-plc-utils: upgrade to latest git revision and fix compilation

Buildbots are reporting the following error:
../mme/ARPCPrint.c: In function 'ARPCPrint':
../mme/ARPCPrint.c:123:2: error: incompatible type for argument 3 of 'vfprintf'
  vfprintf (fp, (char *)(&data->LIST [LE16TOH (data->STROFFSET)]), (void *)(&data->LIST [LE16TOH (data->ARGOFFSET)]));
  ^
In file included from /store/buildbot/slave/mxs/build/staging_dir/toolchain-arm_arm926ej-s_gcc-4.8-linaro_musl-1.1.11_eabi/include/fortify/stdio.h:20:0,
                 from ../mme/ARPCPrint.c:68:
/store/buildbot/slave/mxs/build/staging_dir/toolchain-arm_arm926ej-s_gcc-4.8-linaro_musl-1.1.11_eabi/include/stdio.h:108:5: note: expected '__isoc_va_list' but argument is of type 'void *'

Fix this by definition __UCLIBC__ to enable a workaround for this
issue.

While at, switch to HTTPS URL for cloning the git repo.

Signed-off-by: Michael Heimpold <mhei@heimpold.de>
Michael Heimpold 9 years ago
parent
commit
0353388819
1 changed files with 6 additions and 2 deletions
  1. 6
    2
      utils/open-plc-utils/Makefile

+ 6
- 2
utils/open-plc-utils/Makefile View File

@@ -8,11 +8,11 @@
8 8
 include $(TOPDIR)/rules.mk
9 9
 
10 10
 PKG_NAME:=open-plc-utils
11
-PKG_VERSION:=2015-07-06
11
+PKG_VERSION:=2015-09-21
12 12
 PKG_RELEASE:=$(PKG_SOURCE_VERSION)
13 13
 
14 14
 PKG_SOURCE_PROTO:=git
15
-PKG_SOURCE_URL:=git://github.com/qca/open-plc-utils.git
15
+PKG_SOURCE_URL:=https://github.com/qca/open-plc-utils.git
16 16
 PKG_SOURCE_SUBDIR:=$(PKG_NAME)-$(PKG_VERSION)
17 17
 PKG_SOURCE_VERSION:=885a1b7e2e663b5ab8797db6d40a0318131fdf18
18 18
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION)-$(PKG_SOURCE_VERSION).tar.gz
@@ -75,6 +75,10 @@ OPEN_PLC_UTILS_APPS:=efbu efeu efru efsu edru edsu nics \
75 75
 
76 76
 $(foreach a,$(OPEN_PLC_UTILS_APPS),$(eval $(call GenPlugin,$(a))))
77 77
 
78
+ifdef CONFIG_USE_MUSL
79
+  TARGET_CFLAGS += -D__UCLIBC__
80
+endif
81
+
78 82
 define Build/Compile
79 83
 	$(MAKE) -C $(PKG_BUILD_DIR) \
80 84
 		EXTRA_CFLAGS="$(TARGET_CPPFLAGS) $(TARGET_CFLAGS)" \