Browse Source

ocserv: corrected session expiration in sec-mod

Signed-off-by: Nikos Mavrogiannopoulos <nmav@gnutls.org>
Nikos Mavrogiannopoulos 10 years ago
parent
commit
03a638e002
2 changed files with 23 additions and 1 deletions
  1. 1
    1
      net/ocserv/Makefile
  2. 22
    0
      net/ocserv/patches/001-correct-session-expiration.patch

+ 1
- 1
net/ocserv/Makefile View File

@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
9 9
 
10 10
 PKG_NAME:=ocserv
11 11
 PKG_VERSION:=0.10.3
12
-PKG_RELEASE:=1
12
+PKG_RELEASE:=2
13 13
 
14 14
 PKG_BUILD_DIR :=$(BUILD_DIR)/$(PKG_NAME)-$(PKG_VERSION)
15 15
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.xz

+ 22
- 0
net/ocserv/patches/001-correct-session-expiration.patch View File

@@ -0,0 +1,22 @@
1
+diff --git a/src/sec-mod-auth.c b/src/sec-mod-auth.c
2
+index 4ee6f57..2fc02b5 100644
3
+--- a/src/sec-mod-auth.c
4
++++ b/src/sec-mod-auth.c
5
+@@ -500,7 +500,7 @@ int handle_sec_auth_session_close(int cfd, sec_mod_st *sec, const SecAuthSession
6
+ 		                (pack_func) cli_stats_msg__pack);
7
+ 	}
8
+ 
9
+-	if (e->status != PS_AUTH_COMPLETED) {
10
++	if (e->status < PS_AUTH_COMPLETED) {
11
+ 		seclog(sec, LOG_DEBUG, "session close received in unauthenticated client %s "SESSION_STR"!", e->auth_info.username, e->auth_info.psid);
12
+ 		return send_msg(e, cfd, SM_CMD_AUTH_CLI_STATS, &rep,
13
+ 		                (pack_size_func) cli_stats_msg__get_packed_size,
14
+@@ -604,7 +604,7 @@ int handle_sec_auth_stats_cmd(sec_mod_st * sec, const CliStatsMsg * req)
15
+ 		e->stats.uptime = req->uptime;
16
+ 
17
+ 	if (req->has_invalidate_cookie && req->invalidate_cookie != 0) {
18
+-		seclog(sec, LOG_INFO, "invalidating session user '%s' "SESSION_STR,
19
++		seclog(sec, LOG_INFO, "invalidating session of user '%s' "SESSION_STR,
20
+ 			e->auth_info.username, e->auth_info.psid);
21
+ 		e->status = PS_AUTH_USER_TERM;
22
+ 	}