Bläddra i källkod

[SQM/luci-app-sqm] Fix SQM GUI help messages.

Make clear that configuration options guarded by checkboxes are only
effective as long as those boxes are checked.

The sqm gui has giarded some advanced configuration options behind exposing
checkboxes, meaning these optiopn's values were only used as long
as those boxes were checked. This commit just improves the description of
the checkboxes to included this useage instruction...

Signed-off-by: Sebastian Moeller <moeller0@gmx.de>
Sebastian Moeller 9 år sedan
förälder
incheckning
0418469955
2 ändrade filer med 4 tillägg och 4 borttagningar
  1. 1
    1
      net/luci-app-sqm/Makefile
  2. 3
    3
      net/luci-app-sqm/files/sqm-cbi.lua

+ 1
- 1
net/luci-app-sqm/Makefile Visa fil

@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
9 9
 
10 10
 PKG_NAME:=luci-app-sqm
11 11
 PKG_VERSION:=3
12
-PKG_RELEASE:=3
12
+PKG_RELEASE:=4
13 13
 PKG_LICENSE:=GPLv2
14 14
 LUCI_DIR:=/usr/lib/lua/luci
15 15
 

+ 3
- 3
net/luci-app-sqm/files/sqm-cbi.lua Visa fil

@@ -110,7 +110,7 @@ sc.default = "simple.qos"
110 110
 sc.rmempty = false
111 111
 sc.description = qos_desc
112 112
 
113
-ad = s:taboption("tab_qdisc", Flag, "qdisc_advanced", translate("Show and Use Advanced Configuration"))
113
+ad = s:taboption("tab_qdisc", Flag, "qdisc_advanced", translate("Show and Use Advanced Configuration. Advanced options will only be used as long as this box is checked."))
114 114
 ad.default = false
115 115
 ad.rmempty = true
116 116
 
@@ -142,7 +142,7 @@ eecn.default = "NOECN"
142 142
 eecn.rmempty = true
143 143
 eecn:depends("qdisc_advanced", "1")
144 144
 
145
-ad2 = s:taboption("tab_qdisc", Flag, "qdisc_really_really_advanced", translate("Show and Use Dangerous Configuration"))
145
+ad2 = s:taboption("tab_qdisc", Flag, "qdisc_really_really_advanced", translate("Show and Use Dangerous Configuration. Dangerous options will only be used as long as this box is checked."))
146 146
 ad2.default = false
147 147
 ad2.rmempty = true
148 148
 ad2:depends("qdisc_advanced", "1")
@@ -199,7 +199,7 @@ po:depends("linklayer", "ethernet")
199 199
 po:depends("linklayer", "atm")
200 200
 
201 201
 
202
-adll = s:taboption("tab_linklayer", Flag, "linklayer_advanced", translate("Show Advanced Linklayer Options, (only needed if MTU > 1500)"))
202
+adll = s:taboption("tab_linklayer", Flag, "linklayer_advanced", translate("Show Advanced Linklayer Options, (only needed if MTU > 1500). Advanced options will only be used as long as this box is checked."))
203 203
 adll.rmempty = true
204 204
 adll:depends("linklayer", "ethernet")
205 205
 -- adll:depends("linklayer", "adsl")