|
@@ -1,5 +1,5 @@
|
1
|
1
|
#
|
2
|
|
-# Copyright (C) 2007-2014 OpenWrt.org
|
|
2
|
+# Copyright (C) 2007-2015 OpenWrt.org
|
3
|
3
|
#
|
4
|
4
|
# This is free software, licensed under the GNU General Public License v2.
|
5
|
5
|
# See /LICENSE for more information.
|
|
@@ -8,14 +8,14 @@
|
8
|
8
|
include $(TOPDIR)/rules.mk
|
9
|
9
|
|
10
|
10
|
PKG_NAME:=seafile-server
|
11
|
|
-PKG_VERSION:=3.1.7
|
|
11
|
+PKG_VERSION:=4.0.6
|
12
|
12
|
PKG_RELEASE=$(PKG_SOURCE_VERSION)
|
13
|
13
|
PKG_LICENSE:=GPL-3.0
|
14
|
14
|
|
15
|
15
|
PKG_SOURCE_PROTO:=git
|
16
|
16
|
PKG_SOURCE_URL:=https://github.com/haiwen/seafile.git
|
17
|
17
|
PKG_SOURCE_SUBDIR:=$(PKG_NAME)-$(PKG_VERSION)
|
18
|
|
-PKG_SOURCE_VERSION:=69658fca88f258276be92447b1b4462b64a1c6b9
|
|
18
|
+PKG_SOURCE_VERSION:=adf9a875a960c1471bf6c93fce397c576e985bb3
|
19
|
19
|
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION)-$(PKG_SOURCE_VERSION).tar.gz
|
20
|
20
|
PKG_FIXUP:=autoreconf
|
21
|
21
|
PKG_INSTALL:=1
|
|
@@ -29,9 +29,11 @@ define Package/seafile-server
|
29
|
29
|
TITLE:=Seafile server
|
30
|
30
|
MAINTAINER:=Gergely Kiss <mail.gery@gmail.com>
|
31
|
31
|
URL:=http://seafile.com/
|
32
|
|
- DEPENDS:=+shadow-useradd +libarchive +libopenssl +glib2 +seafile-ccnet +libsearpc +sqlite3-cli +python-mysql \
|
33
|
|
- +jansson +libevent2 +libevent2-openssl +zlib +libzdb +libsqlite3 +libmysqlclient +libevhtp \
|
34
|
|
- +libpthread +libuuid +seafile-seahub +bash +sudo +procps +procps-pkill $(ICONV_DEPENDS)
|
|
32
|
+ DEPENDS:=+shadow-useradd +libarchive +libopenssl +glib2 +libsearpc +seafile-ccnet +seafile-seahub \
|
|
33
|
+ +sqlite3-cli +python-mysql +jansson +libevent2 +libevent2-openssl +zlib +libzdb +libsqlite3 \
|
|
34
|
+ +libmysqlclient +libevhtp +libpthread +libuuid \
|
|
35
|
+ +bash +sudo +procps +procps-pkill $(ICONV_DEPENDS)
|
|
36
|
+ EXTRA_DEPENDS:=seafile-ccnet (=4.0.6-1e1aeae83cc33356ebd5f064f4a4c148186b814d), seafile-seahub (=4.0.6-739b32b02c4803448d5cb75b3e22ec0073930aed)
|
35
|
37
|
endef
|
36
|
38
|
|
37
|
39
|
define Package/seafile-server/description
|
|
@@ -99,9 +101,17 @@ then
|
99
|
101
|
echo "*** ERROR: Configuration failed. Please fix the issues if any and re-run the script using the command below:"
|
100
|
102
|
echo "*** \"/etc/init.d/seafile setup\""
|
101
|
103
|
fi
|
102
|
|
-echo
|
103
|
|
-echo "*** NOTE: you need to create an admin account before using Seafile."
|
104
|
|
-echo "*** Please run \"/etc/init.d/seafile create_admin\" to do so."
|
|
104
|
+
|
|
105
|
+ echo
|
|
106
|
+ echo "*** NOTE: you need to create an admin account before using Seafile."
|
|
107
|
+ echo "*** Please run \"/etc/init.d/seafile create_admin\" to do so."
|
|
108
|
+else
|
|
109
|
+ echo "*** WARNING: it seems you are upgrading from an older version."
|
|
110
|
+ echo "*** If so, please run the appropriate upgrade script before using the new version of Seafile."
|
|
111
|
+ echo "*** Upgrade scripts are located at \"/usr/share/seafile/seafile-server/upgrade\""
|
|
112
|
+ echo
|
|
113
|
+ echo "*** For more information, please read http://manual.seafile.com/deploy/upgrade.html"
|
|
114
|
+ exit
|
105
|
115
|
fi
|
106
|
116
|
|
107
|
117
|
/etc/init.d/seafile enable
|