Quellcode durchsuchen

php5: pecl: move phpize into prepare stage

This allows pecl modules to rely on PKG_FIXUP:=autoreconf.

Signed-off-by: Michael Heimpold <mhei@heimpold.de>
Michael Heimpold vor 9 Jahren
Ursprung
Commit
064391a1d8
1 geänderte Dateien mit 3 neuen und 4 gelöschten Zeilen
  1. 3
    4
      lang/php5/pecl.mk

+ 3
- 4
lang/php5/pecl.mk Datei anzeigen

@@ -1,5 +1,5 @@
1 1
 #
2
-# Copyright (C) 2011-2014 OpenWrt.org
2
+# Copyright (C) 2011-2015 OpenWrt.org
3 3
 #
4 4
 # This is free software, licensed under the GNU General Public License v2.
5 5
 # See /LICENSE for more information.
@@ -10,13 +10,12 @@ define Package/php5-pecl/Default
10 10
   SECTION:=lang
11 11
   CATEGORY:=Languages
12 12
   URL:=http://pecl.php.net/
13
-  MAINTAINER:=Michael Heimpold <mhei@heimpold.de>
14 13
   DEPENDS:=php5
15 14
 endef
16 15
 
17
-define Build/Configure
16
+define Build/Prepare
17
+	$(Build/Prepare/Default)
18 18
 	( cd $(PKG_BUILD_DIR); $(STAGING_DIR_HOST)/usr/bin/phpize )
19
-	$(Build/Configure/Default)
20 19
 endef
21 20
 
22 21
 CONFIGURE_ARGS+= \