Browse Source

mjpg-streamer: Upgrade to r182-experimental, add patches to remove debug, build additional plugins and minor fixes.

Signed-off-by: Ted Hess <thess@kitschensync.net>
Ted Hess 10 years ago
parent
commit
071481e626

+ 3
- 4
multimedia/mjpg-streamer/Makefile View File

@@ -8,17 +8,16 @@
8 8
 include $(TOPDIR)/rules.mk
9 9
 
10 10
 PKG_NAME:=mjpg-streamer
11
-PKG_REV:=181
11
+PKG_REV:=182
12 12
 PKG_VERSION:=r$(PKG_REV)
13
-PKG_RELEASE:=2
13
+PKG_RELEASE:=1
14 14
 PKG_MAINTAINER:=Roger D <rogerdammit@gmail.com>
15 15
 
16 16
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
17
-PKG_SOURCE_URL:=https://svn.code.sf.net/p/mjpg-streamer/code/mjpg-streamer
17
+PKG_SOURCE_URL:=https://svn.code.sf.net/p/mjpg-streamer/code/mjpg-streamer-experimental
18 18
 PKG_SOURCE_SUBDIR:=$(PKG_NAME)-$(PKG_VERSION)
19 19
 PKG_SOURCE_VERSION:=$(PKG_REV)
20 20
 PKG_SOURCE_PROTO:=svn
21
-PKG_MD5SUM:=b2bc22665733319e647ace236e283684
22 21
 
23 22
 PKG_LICENSE:=GPL-2.0
24 23
 PKG_LICENSE_FILE:=LICENSE

+ 17
- 0
multimedia/mjpg-streamer/patches/010-enable_additional_plugins.patch View File

@@ -0,0 +1,17 @@
1
+--- a/Makefile
2
++++ b/Makefile
3
+@@ -33,12 +33,12 @@ APP_BINARY = mjpg_streamer
4
+ 
5
+ # define the names and targets of the plugins
6
+ PLUGINS = input_uvc.so
7
+-#PLUGINS += output_file.so
8
++PLUGINS += output_file.so
9
+ #PLUGINS += output_udp.so
10
+ PLUGINS += output_http.so
11
+ PLUGINS += input_testpicture.so
12
+ #PLUGINS += output_autofocus.so
13
+-#PLUGINS += input_file.so
14
++PLUGINS += input_file.so
15
+ # PLUGINS += input_pylon.so
16
+ # PLUGINS += input_megatec.so
17
+ # PLUGINS += output_mars2020.so

+ 33
- 0
multimedia/mjpg-streamer/patches/020-remove_gcc_debug_options.patch View File

@@ -0,0 +1,33 @@
1
+--- a/plugins/input_uvc/Makefile
2
++++ b/plugins/input_uvc/Makefile
3
+@@ -13,7 +13,7 @@ OTHER_HEADERS = ../../mjpg_streamer.h ..
4
+ 
5
+ CFLAGS += -O1  -DLINUX -D_GNU_SOURCE -Wall -shared -fPIC
6
+ 
7
+-CFLAGS += -g -DDEBUG
8
++#CFLAGS += -g -DDEBUG
9
+ 
10
+ ifeq ($(USE_LIBV4L2),true)
11
+ LFLAGS += -lv4l2
12
+--- a/plugins/output_file/Makefile
13
++++ b/plugins/output_file/Makefile
14
+@@ -12,7 +12,7 @@ CC = gcc
15
+ OTHER_HEADERS = ../../mjpg_streamer.h ../../utils.h ../output.h ../input.h
16
+ 
17
+ CFLAGS += -O2 -DLINUX -D_GNU_SOURCE -Wall -shared -fPIC
18
+-CFLAGS += -DDEBUG -g
19
++#CFLAGS += -DDEBUG -g
20
+ LFLAGS += -lpthread -ldl
21
+ 
22
+ all: output_file.so
23
+--- a/plugins/output_udp/Makefile
24
++++ b/plugins/output_udp/Makefile
25
+@@ -14,7 +14,7 @@ CC = gcc
26
+ OTHER_HEADERS = ../../mjpg_streamer.h ../../utils.h ../output.h ../input.h
27
+ 
28
+ CFLAGS += -O2 -DLINUX -D_GNU_SOURCE -Wall -shared -fPIC
29
+-CFLAGS += -DDEBUG
30
++#CFLAGS += -DDEBUG
31
+ LFLAGS += -lpthread -ldl
32
+ 
33
+ all: output_udp.so

+ 11
- 0
multimedia/mjpg-streamer/patches/030-allow_16_char_device_names.patch View File

@@ -0,0 +1,11 @@
1
+--- a/plugins/input_uvc/v4l2uvc.c
2
++++ b/plugins/input_uvc/v4l2uvc.c
3
+@@ -69,7 +69,7 @@ int init_videoIn(struct vdIn *vd, char *
4
+     vd->videodevice = (char *) calloc(1, 16 * sizeof(char));
5
+     vd->status = (char *) calloc(1, 100 * sizeof(char));
6
+     vd->pictName = (char *) calloc(1, 80 * sizeof(char));
7
+-    snprintf(vd->videodevice, 12, "%s", device);
8
++    snprintf(vd->videodevice, 16, "%s", device);
9
+     vd->toggleAvi = 0;
10
+     vd->getPict = 0;
11
+     vd->signalquit = 1;