Browse Source

net/bind: Re-import package net/bind from oldpackages.

Noah Meyerhans 10 years ago
parent
commit
0719636b05

+ 199
- 0
net/bind/Makefile View File

@@ -0,0 +1,199 @@
1
+#
2
+# Copyright (C) 2006-2012 OpenWrt.org
3
+#
4
+# This is free software, licensed under the GNU General Public License v2.
5
+# See /LICENSE for more information.
6
+#
7
+
8
+include $(TOPDIR)/rules.mk
9
+
10
+PKG_NAME:=bind
11
+PKG_VERSION:=9.9.4
12
+PKG_RELEASE:=1
13
+
14
+PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
15
+PKG_SOURCE_URL:= \
16
+	ftp://ftp.isc.org/isc/bind9/$(PKG_VERSION) \
17
+	http://www.mirrorservice.org/sites/ftp.isc.org/isc/bind9/$(PKG_VERSION)
18
+PKG_MD5SUM:=f69757adc86776daed8e5acb0ee7c0ca
19
+
20
+PKG_FIXUP:=autoreconf
21
+PKG_REMOVE_FILES:=aclocal.m4 libtool.m4
22
+
23
+PKG_INSTALL:=1
24
+
25
+include $(INCLUDE_DIR)/package.mk
26
+
27
+define Package/bind/Default
28
+  SECTION:=net
29
+  CATEGORY:=Network
30
+  DEPENDS:=+bind-libs
31
+  TITLE:=bind
32
+  URL:=https://www.isc.org/software/bind
33
+  SUBMENU:=IP Addresses and Names
34
+endef
35
+
36
+define Package/bind-libs
37
+  SECTION:=libs
38
+  CATEGORY:=Libraries
39
+  DEPENDS:=+libopenssl
40
+  TITLE:=bind shared libraries
41
+  URL:=https://www.isc.org/software/bind
42
+endef
43
+
44
+define Package/bind-server
45
+  $(call Package/bind/Default)
46
+  TITLE+= DNS server
47
+endef
48
+
49
+define Package/bind-client
50
+  $(call Package/bind/Default)
51
+  TITLE+= dynamic DNS client
52
+endef
53
+
54
+define Package/bind-tools
55
+  $(call Package/bind/Default)
56
+  TITLE+= administration tools (all)
57
+endef
58
+
59
+define Package/bind-rndc
60
+  $(call Package/bind/Default)
61
+  TITLE+= administration tools (rndc and rndc-confgen only)
62
+endef
63
+
64
+define Package/bind-check
65
+  $(call Package/bind/Default)
66
+  TITLE+= administration tools (named-checkconf and named-checkzone only)
67
+endef
68
+
69
+define Package/bind-dnssec
70
+  $(call Package/bind/Default)
71
+  TITLE+= administration tools (dnssec-keygen and dnssec-signzone only)
72
+endef
73
+
74
+define Package/bind-host
75
+  $(call Package/bind/Default)
76
+  TITLE+= simple DNS client
77
+endef
78
+
79
+define Package/bind-dig
80
+  $(call Package/bind/Default)
81
+  TITLE+= DNS excavation tool
82
+endef
83
+
84
+export BUILD_CC="$(TARGET_CC)"
85
+
86
+CONFIGURE_ARGS += \
87
+	--enable-shared \
88
+	--enable-static \
89
+	--with-randomdev="/dev/urandom" \
90
+	--disable-threads \
91
+	--disable-linux-caps \
92
+	--with-openssl="$(STAGING_DIR)/usr" \
93
+	--with-libtool \
94
+	--with-libxml2=no \
95
+	--enable-epoll=yes \
96
+	--with-gost=no \
97
+	--with-gssapi=no \
98
+	--with-ecdsa=no \
99
+	--with-readline=no
100
+
101
+CONFIGURE_VARS += \
102
+	BUILD_CC="$(TARGET_CC)" \
103
+
104
+define Build/Compile
105
+	$(MAKE) -C $(PKG_BUILD_DIR)/lib/dns \
106
+		BUILD_CC="$(HOSTCC)" \
107
+		CC="$(HOSTCC)" \
108
+		CFLAGS="-O2" \
109
+		LIBS="" \
110
+		gen
111
+	$(call Build/Compile/Default)
112
+endef
113
+
114
+define Package/bind-libs/install
115
+	$(INSTALL_DIR) $(1)/usr/lib
116
+	$(CP) $(PKG_INSTALL_DIR)/usr/lib/*.so* $(1)/usr/lib
117
+endef
118
+
119
+define Package/bind-server/install
120
+	$(INSTALL_DIR) $(1)/usr/sbin
121
+	$(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/sbin/named $(1)/usr/sbin/
122
+	$(INSTALL_DIR) $(1)/etc/bind
123
+	$(CP) \
124
+		./files/bind/db.0 \
125
+		./files/bind/db.127 \
126
+		./files/bind/db.255 \
127
+		./files/bind/db.local \
128
+		./files/bind/db.root \
129
+		$(1)/etc/bind/
130
+	$(CP) ./files/bind/named.conf.example $(1)/etc/bind/named.conf
131
+	$(INSTALL_DIR) $(1)/etc/init.d
132
+	$(INSTALL_BIN) ./files/named.init $(1)/etc/init.d/named
133
+	find $(1)/etc/bind/ -name ".svn" | xargs rm -rf
134
+endef
135
+
136
+define Package/bind-server/conffiles
137
+/etc/bind/db.0
138
+/etc/bind/db.127
139
+/etc/bind/db.255
140
+/etc/bind/db.local
141
+/etc/bind/db.root
142
+/etc/bind/named.conf
143
+endef
144
+
145
+define Package/bind-client/install
146
+	$(INSTALL_DIR) $(1)/usr/bin
147
+	$(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/bin/nsupdate $(1)/usr/bin/
148
+endef
149
+
150
+define Package/bind-tools/install
151
+	$(INSTALL_DIR) $(1)/usr/bin
152
+	$(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/bin/dig $(1)/usr/bin/
153
+	$(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/bin/host $(1)/usr/bin/
154
+	$(INSTALL_DIR) $(1)/usr/sbin
155
+	$(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/sbin/dnssec-keygen $(1)/usr/sbin/
156
+	$(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/sbin/dnssec-signzone $(1)/usr/sbin/
157
+	$(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/sbin/named-checkconf $(1)/usr/sbin/
158
+	$(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/sbin/named-checkzone $(1)/usr/sbin/
159
+	$(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/sbin/rndc $(1)/usr/sbin/
160
+	$(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/sbin/rndc-confgen $(1)/usr/sbin/
161
+endef
162
+
163
+define Package/bind-rndc/install
164
+	$(INSTALL_DIR) $(1)/usr/sbin
165
+	$(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/sbin/rndc $(1)/usr/sbin/
166
+	$(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/sbin/rndc-confgen $(1)/usr/sbin/
167
+endef
168
+
169
+define Package/bind-check/install
170
+	$(INSTALL_DIR) $(1)/usr/sbin
171
+	$(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/sbin/named-checkconf $(1)/usr/sbin/
172
+	$(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/sbin/named-checkzone $(1)/usr/sbin/
173
+endef
174
+
175
+define Package/bind-dnssec/install
176
+	$(INSTALL_DIR) $(1)/usr/sbin
177
+	$(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/sbin/dnssec-keygen $(1)/usr/sbin/
178
+	$(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/sbin/dnssec-signzone $(1)/usr/sbin/
179
+endef
180
+
181
+define Package/bind-host/install
182
+	$(INSTALL_DIR) $(1)/usr/bin
183
+	$(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/bin/host $(1)/usr/bin/
184
+endef
185
+
186
+define Package/bind-dig/install
187
+	$(INSTALL_DIR) $(1)/usr/bin
188
+	$(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/bin/dig $(1)/usr/bin/
189
+endef
190
+
191
+$(eval $(call BuildPackage,bind-libs))
192
+$(eval $(call BuildPackage,bind-server))
193
+$(eval $(call BuildPackage,bind-client))
194
+$(eval $(call BuildPackage,bind-tools))
195
+$(eval $(call BuildPackage,bind-rndc))
196
+$(eval $(call BuildPackage,bind-check))
197
+$(eval $(call BuildPackage,bind-dnssec))
198
+$(eval $(call BuildPackage,bind-host))
199
+$(eval $(call BuildPackage,bind-dig))

+ 12
- 0
net/bind/files/bind/db.0 View File

@@ -0,0 +1,12 @@
1
+;
2
+; BIND reverse data file for broadcast zone
3
+;
4
+$TTL	604800
5
+@	IN	SOA	localhost. root.localhost. (
6
+			      1		; Serial
7
+			 604800		; Refresh
8
+			  86400		; Retry
9
+			2419200		; Expire
10
+			 604800 )	; Negative Cache TTL
11
+;
12
+@	IN	NS	localhost.

+ 13
- 0
net/bind/files/bind/db.127 View File

@@ -0,0 +1,13 @@
1
+;
2
+; BIND reverse data file for local loopback interface
3
+;
4
+$TTL	604800
5
+@	IN	SOA	localhost. root.localhost. (
6
+			      1		; Serial
7
+			 604800		; Refresh
8
+			  86400		; Retry
9
+			2419200		; Expire
10
+			 604800 )	; Negative Cache TTL
11
+;
12
+@	IN	NS	localhost.
13
+1.0.0	IN	PTR	localhost.

+ 12
- 0
net/bind/files/bind/db.255 View File

@@ -0,0 +1,12 @@
1
+;
2
+; BIND reverse data file for broadcast zone
3
+;
4
+$TTL	604800
5
+@	IN	SOA	localhost. root.localhost. (
6
+			      1		; Serial
7
+			 604800		; Refresh
8
+			  86400		; Retry
9
+			2419200		; Expire
10
+			 604800 )	; Negative Cache TTL
11
+;
12
+@	IN	NS	localhost.

+ 13
- 0
net/bind/files/bind/db.local View File

@@ -0,0 +1,13 @@
1
+;
2
+; BIND data file for local loopback interface
3
+;
4
+$TTL	604800
5
+@	IN	SOA	localhost. root.localhost. (
6
+			      1		; Serial
7
+			 604800		; Refresh
8
+			  86400		; Retry
9
+			2419200		; Expire
10
+			 604800 )	; Negative Cache TTL
11
+;
12
+@	IN	NS	localhost.
13
+@	IN	A	127.0.0.1

+ 45
- 0
net/bind/files/bind/db.root View File

@@ -0,0 +1,45 @@
1
+
2
+; <<>> DiG 9.2.3 <<>> ns . @a.root-servers.net.
3
+;; global options:  printcmd
4
+;; Got answer:
5
+;; ->>HEADER<<- opcode: QUERY, status: NOERROR, id: 18944
6
+;; flags: qr aa rd; QUERY: 1, ANSWER: 13, AUTHORITY: 0, ADDITIONAL: 13
7
+
8
+;; QUESTION SECTION:
9
+;.				IN	NS
10
+
11
+;; ANSWER SECTION:
12
+.			518400	IN	NS	A.ROOT-SERVERS.NET.
13
+.			518400	IN	NS	B.ROOT-SERVERS.NET.
14
+.			518400	IN	NS	C.ROOT-SERVERS.NET.
15
+.			518400	IN	NS	D.ROOT-SERVERS.NET.
16
+.			518400	IN	NS	E.ROOT-SERVERS.NET.
17
+.			518400	IN	NS	F.ROOT-SERVERS.NET.
18
+.			518400	IN	NS	G.ROOT-SERVERS.NET.
19
+.			518400	IN	NS	H.ROOT-SERVERS.NET.
20
+.			518400	IN	NS	I.ROOT-SERVERS.NET.
21
+.			518400	IN	NS	J.ROOT-SERVERS.NET.
22
+.			518400	IN	NS	K.ROOT-SERVERS.NET.
23
+.			518400	IN	NS	L.ROOT-SERVERS.NET.
24
+.			518400	IN	NS	M.ROOT-SERVERS.NET.
25
+
26
+;; ADDITIONAL SECTION:
27
+A.ROOT-SERVERS.NET.	3600000	IN	A	198.41.0.4
28
+B.ROOT-SERVERS.NET.	3600000	IN	A	192.228.79.201
29
+C.ROOT-SERVERS.NET.	3600000	IN	A	192.33.4.12
30
+D.ROOT-SERVERS.NET.	3600000	IN	A	128.8.10.90
31
+E.ROOT-SERVERS.NET.	3600000	IN	A	192.203.230.10
32
+F.ROOT-SERVERS.NET.	3600000	IN	A	192.5.5.241
33
+G.ROOT-SERVERS.NET.	3600000	IN	A	192.112.36.4
34
+H.ROOT-SERVERS.NET.	3600000	IN	A	128.63.2.53
35
+I.ROOT-SERVERS.NET.	3600000	IN	A	192.36.148.17
36
+J.ROOT-SERVERS.NET.	3600000	IN	A	192.58.128.30
37
+K.ROOT-SERVERS.NET.	3600000	IN	A	193.0.14.129
38
+L.ROOT-SERVERS.NET.	3600000	IN	A	199.7.83.42
39
+M.ROOT-SERVERS.NET.	3600000	IN	A	202.12.27.33
40
+
41
+;; Query time: 81 msec
42
+;; SERVER: 198.41.0.4#53(a.root-servers.net.)
43
+;; WHEN: Sun Feb  1 11:27:14 2004
44
+;; MSG SIZE  rcvd: 436
45
+

+ 45
- 0
net/bind/files/bind/named.conf.example View File

@@ -0,0 +1,45 @@
1
+// This is the primary configuration file for the BIND DNS server named.
2
+
3
+options {
4
+	directory "/tmp";
5
+
6
+	// If your ISP provided one or more IP addresses for stable 
7
+	// nameservers, you probably want to use them as forwarders.  
8
+	// Uncomment the following block, and insert the addresses replacing 
9
+	// the all-0's placeholder.
10
+
11
+	// forwarders {
12
+	// 	0.0.0.0;
13
+	// };
14
+
15
+	auth-nxdomain no;    # conform to RFC1035
16
+};
17
+
18
+// prime the server with knowledge of the root servers
19
+zone "." {
20
+	type hint;
21
+	file "/etc/bind/db.root";
22
+};
23
+
24
+// be authoritative for the localhost forward and reverse zones, and for
25
+// broadcast zones as per RFC 1912
26
+
27
+zone "localhost" {
28
+	type master;
29
+	file "/etc/bind/db.local";
30
+};
31
+
32
+zone "127.in-addr.arpa" {
33
+	type master;
34
+	file "/etc/bind/db.127";
35
+};
36
+
37
+zone "0.in-addr.arpa" {
38
+	type master;
39
+	file "/etc/bind/db.0";
40
+};
41
+
42
+zone "255.in-addr.arpa" {
43
+	type master;
44
+	file "/etc/bind/db.255";
45
+};

+ 40
- 0
net/bind/files/named.init View File

@@ -0,0 +1,40 @@
1
+#!/bin/sh /etc/rc.common
2
+START=50
3
+
4
+config_file=/etc/bind/named.conf
5
+pid_file=/var/run/named/named.pid
6
+
7
+start() {
8
+  if [ -e $pid_file ]
9
+  then
10
+     echo "  named already running with PID `cat $pid_file`"
11
+     return 1
12
+  fi
13
+  echo Starting isc-bind
14
+
15
+  /usr/sbin/named -c $config_file
16
+
17
+  if [ $? -ne 0 ]
18
+  then
19
+    echo "  isc-bind failed to start"
20
+  fi
21
+}
22
+
23
+stop() {
24
+  echo "Stopping isc-bind"
25
+  if [ -e $pid_file ]
26
+  then
27
+    kill `cat $pid_file`
28
+
29
+    if [ $? -ne 0 ]
30
+    then
31
+      echo "  PID " `cat $pid_file` not found
32
+      echo "  Is the named server running?"
33
+    fi
34
+
35
+    rm -f $pid_file
36
+
37
+    else
38
+    echo "  $pid_file not found"
39
+  fi
40
+}

+ 26
- 0
net/bind/patches/001-no-tests.patch View File

@@ -0,0 +1,26 @@
1
+Index: bind-9.9.4/bin/Makefile.in
2
+===================================================================
3
+--- bind-9.9.4.orig/bin/Makefile.in
4
++++ bind-9.9.4/bin/Makefile.in
5
+@@ -19,7 +19,7 @@ srcdir =	@srcdir@
6
+ VPATH =		@srcdir@
7
+ top_srcdir =	@top_srcdir@
8
+ 
9
+-SUBDIRS =	named rndc dig dnssec tools tests nsupdate \
10
++SUBDIRS =	named rndc dig dnssec tools nsupdate \
11
+ 		check confgen @PYTHON_TOOLS@ @PKCS11_TOOLS@
12
+ TARGETS =
13
+ 
14
+Index: bind-9.9.4/lib/Makefile.in
15
+===================================================================
16
+--- bind-9.9.4.orig/lib/Makefile.in
17
++++ bind-9.9.4/lib/Makefile.in
18
+@@ -23,7 +23,7 @@ top_srcdir =	@top_srcdir@
19
+ # Attempt to disable parallel processing.
20
+ .NOTPARALLEL:
21
+ .NO_PARALLEL:
22
+-SUBDIRS =	isc isccc dns isccfg bind9 lwres tests
23
++SUBDIRS =	isc isccc dns isccfg bind9 lwres
24
+ TARGETS =
25
+ 
26
+ @BIND9_MAKE_RULES@