Browse Source

lttng-tools: import from old packages feed

 - update to latest version (v2.6.0)
 - add license info
 - add myself as maintainer

Signed-off-by: Nicolas Thill <nico@openwrt.org>
Nicolas Thill 10 years ago
parent
commit
0796ff4e36
1 changed files with 58 additions and 0 deletions
  1. 58
    0
      devel/lttng-tools/Makefile

+ 58
- 0
devel/lttng-tools/Makefile View File

@@ -0,0 +1,58 @@
1
+#
2
+# Copyright (C) 2013-2015 OpenWrt.org
3
+#
4
+# This is free software, licensed under the GNU General Public License v2.
5
+# See /LICENSE for more information.
6
+#
7
+
8
+include $(TOPDIR)/rules.mk
9
+
10
+PKG_NAME:=lttng-tools
11
+PKG_VERSION:=2.6.0
12
+PKG_RELEASE:=1
13
+
14
+PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
15
+PKG_SOURCE_URL:=https://lttng.org/files/$(PKG_NAME)/
16
+PKG_MD5SUM:=0478f60395f9564b4a19f45ce7b7f3df
17
+
18
+PKG_LICENSE:=LGPL-2.1 GPL-2.0
19
+PKG_LICENSE_FILES:=COPYING
20
+PKG_MAINTAINER:=Nicolas Thill <nico@openwrt.org>
21
+
22
+PKG_FIXUP:=autoreconf
23
+PKG_USE_MIPS16:=0
24
+PKG_BUILD_PARALLEL:=1
25
+PKG_INSTALL:=1
26
+
27
+include $(INCLUDE_DIR)/package.mk
28
+
29
+define Package/lttng-tools
30
+  SECTION:=devel
31
+  CATEGORY:=Development
32
+  TITLE:=Linux Trace Toolkit: next generation (tools)
33
+  URL:=https://lttng.org/
34
+  DEPENDS:= +lttng-ust +libpopt +libxml2
35
+endef
36
+
37
+TARGET_LDFLAGS += -lurcu-bp
38
+
39
+MAKE_FLAGS += V="$(V)"
40
+
41
+define Build/InstallDev
42
+	$(INSTALL_DIR) $(1)/usr/include
43
+	$(CP) $(PKG_INSTALL_DIR)/usr/include/lttng $(1)/usr/include/
44
+	$(INSTALL_DIR) $(1)/usr/lib
45
+	$(CP) $(PKG_INSTALL_DIR)/usr/lib/liblttng-ctl*.{a,so*} $(1)/usr/lib/
46
+	$(INSTALL_DIR) $(1)/usr/lib/pkgconfig
47
+	$(CP) $(PKG_INSTALL_DIR)/usr/lib/pkgconfig/lttng-ctl.pc $(1)/usr/lib/pkgconfig/
48
+endef
49
+
50
+define Package/lttng-tools/install
51
+	$(INSTALL_DIR) $(1)/usr/lib
52
+	$(CP) $(PKG_INSTALL_DIR)/usr/lib/liblttng-ctl*.so.* $(1)/usr/lib/
53
+	$(CP) $(PKG_INSTALL_DIR)/usr/lib/lttng $(1)/usr/lib/
54
+	$(INSTALL_DIR) $(1)/usr/bin
55
+	$(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/bin/lttng* $(1)/usr/bin/
56
+endef
57
+
58
+$(eval $(call BuildPackage,lttng-tools))