|
@@ -0,0 +1,92 @@
|
|
1
|
+#
|
|
2
|
+# Copyright (C) 2006-2015 OpenWrt.org
|
|
3
|
+#
|
|
4
|
+# This is free software, licensed under the GNU General Public License v2.
|
|
5
|
+# See /LICENSE for more information.
|
|
6
|
+#
|
|
7
|
+
|
|
8
|
+include $(TOPDIR)/rules.mk
|
|
9
|
+
|
|
10
|
+PKG_NAME:=grilo-plugins
|
|
11
|
+PKG_VERSION:=0.2.16
|
|
12
|
+PKG_RELEASE:=1
|
|
13
|
+
|
|
14
|
+PKG_MAINTAINER:=W. Michael Petullo <mike@flyn.org>
|
|
15
|
+
|
|
16
|
+PKG_LICENSE:=LGPLv2.1
|
|
17
|
+PKG_LICENSE_FILES:=COPYING
|
|
18
|
+
|
|
19
|
+PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.xz
|
|
20
|
+PKG_SOURCE_URL:=https://download.gnome.org/sources/grilo-plugins/0.2/
|
|
21
|
+PKG_MD5SUM:=62ecaad877b485a950259eef1ef38c18
|
|
22
|
+
|
|
23
|
+PKG_BUILD_DEPENDS:=glib2 grilo
|
|
24
|
+
|
|
25
|
+PKG_INSTALL:=1
|
|
26
|
+
|
|
27
|
+include $(INCLUDE_DIR)/package.mk
|
|
28
|
+include $(INCLUDE_DIR)/nls.mk
|
|
29
|
+
|
|
30
|
+define Package/grilo-plugins/Default
|
|
31
|
+ SECTION:=multimedia
|
|
32
|
+ CATEGORY:=Multimedia
|
|
33
|
+ TITLE:=grilo-plugins
|
|
34
|
+ URL:=https://wiki.gnome.org/Projects/Grilo
|
|
35
|
+endef
|
|
36
|
+
|
|
37
|
+define Package/grilo-plugins
|
|
38
|
+ $(call Package/grilo-plugins/Default)
|
|
39
|
+ MENU:=1
|
|
40
|
+ DEPENDS:=+grilo $(ICONV_DEPENDS) $(INTL_DEPENDS)
|
|
41
|
+ TITLE:=Plugins for the Grilo framework
|
|
42
|
+endef
|
|
43
|
+
|
|
44
|
+define Package/grilo/decription
|
|
45
|
+ Grilo is a framework that provides access to different sources of
|
|
46
|
+ multimedia content, using a pluggable system. This package contains
|
|
47
|
+ plugins to get information from a number of sources.
|
|
48
|
+endef
|
|
49
|
+
|
|
50
|
+CONFIGURE_ARGS += \
|
|
51
|
+ --enable-static \
|
|
52
|
+ --without-libiconv-prefix \
|
|
53
|
+ --without-libintl-prefix \
|
|
54
|
+ --without-x \
|
|
55
|
+
|
|
56
|
+define Package/grilo-plugins/install
|
|
57
|
+ $(INSTALL_DIR) $(1)/usr/lib/grilo-0.2
|
|
58
|
+endef
|
|
59
|
+
|
|
60
|
+define BuildPlugin
|
|
61
|
+ define Package/grilo-plugins-$(1)
|
|
62
|
+ $(call Package/grilo-plugins/Default)
|
|
63
|
+ DEPENDS:=grilo-plugins
|
|
64
|
+ ifneq ($(4),)
|
|
65
|
+ DEPENDS+= $(4)
|
|
66
|
+ endif
|
|
67
|
+ TITLE:=$(2) plugin
|
|
68
|
+ endef
|
|
69
|
+
|
|
70
|
+ define Package/grilo-plugins-$(1)/install
|
|
71
|
+ $(INSTALL_DIR) $$(1)/usr/lib/grilo-0.2
|
|
72
|
+ for p in $(3); do \
|
|
73
|
+ $(CP) $(PKG_INSTALL_DIR)/usr/lib/grilo-0.2/libgrl$$$$$$$${p}.so $$(1)/usr/lib/grilo-0.2; \
|
|
74
|
+ $(CP) $(PKG_INSTALL_DIR)/usr/lib/grilo-0.2/grl-$$$$$$$${p}.xml $$(1)/usr/lib/grilo-0.2; \
|
|
75
|
+ done
|
|
76
|
+ endef
|
|
77
|
+
|
|
78
|
+ $$(eval $$(call BuildPackage,grilo-plugins-$(1)))
|
|
79
|
+endef
|
|
80
|
+
|
|
81
|
+$(eval $(call BuildPackage,grilo-plugins))
|
|
82
|
+
|
|
83
|
+$(eval $(call BuildPlugin,dleyna,DLNA sharing,dleyna,,30))
|
|
84
|
+$(eval $(call BuildPlugin,dmap,DAAP and DPAP sharing,daap dpap,libdmapsharing,30))
|
|
85
|
+$(eval $(call BuildPlugin,gravatar,Gravatar provider,gravatar,,30))
|
|
86
|
+$(eval $(call BuildPlugin,jamendo,Jamendo sharing,jamendo,,30))
|
|
87
|
+$(eval $(call BuildPlugin,lastfm-albumart,Last.FM album art provider,lastfm-albumart,,30))
|
|
88
|
+$(eval $(call BuildPlugin,magnatune,Magnatune sharing,magnatune,,30))
|
|
89
|
+$(eval $(call BuildPlugin,metadata-store,Extra metadata store,metadata-store,,30))
|
|
90
|
+$(eval $(call BuildPlugin,opensubtitles,Openi subtitles provider,opensubtitles,,30))
|
|
91
|
+$(eval $(call BuildPlugin,raitv,Rai.tv sharing,raitv,,30))
|
|
92
|
+$(eval $(call BuildPlugin,shoutcast,SHOUTcast sharing,shoutcast,,30))
|