瀏覽代碼

liboping: import from oldpackages, add myself as maintainer, add license information

Signed-off-by: Jo-Philipp Wich <jow@openwrt.org>
Jo-Philipp Wich 10 年之前
父節點
當前提交
092733f241
共有 2 個檔案被更改,包括 95 行新增0 行删除
  1. 84
    0
      libs/liboping/Makefile
  2. 11
    0
      libs/liboping/patches/01-no-werror.patch

+ 84
- 0
libs/liboping/Makefile 查看文件

@@ -0,0 +1,84 @@
1
+#
2
+# Copyright (C) 2009-2014 OpenWrt.org
3
+#
4
+# This is free software, licensed under the GNU General Public License v2.
5
+# See /LICENSE for more information.
6
+#
7
+
8
+include $(TOPDIR)/rules.mk
9
+
10
+PKG_NAME:=liboping
11
+PKG_VERSION:=1.6.2
12
+PKG_RELEASE:=1
13
+PKG_MAINTAINER:=Jo-Philipp Wich <jow@openwrt.org>
14
+PKG_LICENSE:=GPL-2.0
15
+
16
+PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
17
+PKG_SOURCE_URL:=http://verplant.org/liboping/files
18
+PKG_MD5SUM:=64a6f31310093d2517cfe7f05aa011e0
19
+
20
+PKG_FIXUP:=autoreconf
21
+
22
+PKG_INSTALL:=1
23
+
24
+include $(INCLUDE_DIR)/package.mk
25
+
26
+define Package/liboping/Default
27
+  URL:=http://verplant.org/liboping/
28
+endef
29
+
30
+define Package/liboping
31
+$(call Package/liboping/Default)
32
+  SECTION:=libs
33
+  CATEGORY:=Libraries
34
+  TITLE:=C library to generate ICMP echo requests.
35
+endef
36
+
37
+define Package/oping
38
+$(call Package/liboping/Default)
39
+  SECTION:=net
40
+  CATEGORY:=Network
41
+  TITLE:=Send ICMP echo request to network hosts
42
+  DEPENDS+= +liboping
43
+endef
44
+
45
+define Package/noping
46
+$(call Package/liboping/Default)
47
+  SECTION:=net
48
+  CATEGORY:=Network
49
+  TITLE:=Ncurses application to send ICMP echo request to network hosts
50
+  DEPENDS+= +liboping +libncurses
51
+endef
52
+
53
+TARGET_CFLAGS += $(FPIC)
54
+
55
+CONFIGURE_ARGS += \
56
+	--without-perl-bindings \
57
+	--enable-shared \
58
+	--enable-static
59
+
60
+define Build/InstallDev
61
+	$(INSTALL_DIR) $(1)/usr/include
62
+	$(CP) $(PKG_INSTALL_DIR)/usr/include/oping.h $(1)/usr/include/
63
+	$(INSTALL_DIR) $(1)/usr/lib
64
+	$(CP) $(PKG_INSTALL_DIR)/usr/lib/liboping.{a,so*} $(1)/usr/lib/
65
+endef
66
+
67
+define Package/liboping/install
68
+	$(INSTALL_DIR) $(1)/usr/lib
69
+	$(CP) $(PKG_INSTALL_DIR)/usr/lib/liboping.so.* $(1)/usr/lib/
70
+endef
71
+
72
+define Package/oping/install
73
+	$(INSTALL_DIR) $(1)/usr/bin
74
+	$(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/bin/oping $(1)/usr/bin/
75
+endef
76
+
77
+define Package/noping/install
78
+	$(INSTALL_DIR) $(1)/usr/bin
79
+	$(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/bin/noping $(1)/usr/bin/
80
+endef
81
+
82
+$(eval $(call BuildPackage,liboping))
83
+$(eval $(call BuildPackage,oping))
84
+$(eval $(call BuildPackage,noping))

+ 11
- 0
libs/liboping/patches/01-no-werror.patch 查看文件

@@ -0,0 +1,11 @@
1
+--- a/src/Makefile.am
2
++++ b/src/Makefile.am
3
+@@ -3,7 +3,7 @@ AUTOMAKE_OPTIONS = foreign no-dependenci
4
+ SUBDIRS = mans
5
+ 
6
+ if COMPILER_IS_GCC
7
+-AM_CFLAGS = -Wall -Werror
8
++AM_CFLAGS = -Wall
9
+ endif
10
+ 
11
+ include_HEADERS = oping.h