Browse Source

libwebsockets: don't use github conflicting tag archives (#1051)

Signed-off-by: Nicolas Thill <nico@openwrt.org>
Nicolas Thill 9 years ago
parent
commit
09a07e9f21
1 changed files with 9 additions and 4 deletions
  1. 9
    4
      libs/libwebsockets/Makefile

+ 9
- 4
libs/libwebsockets/Makefile View File

@@ -1,19 +1,24 @@
1 1
 #
2
-# Copyright (C) 2014 OpenWrt.org
2
+# Copyright (C) 2014-2015 OpenWrt.org
3 3
 #
4 4
 # This is free software, licensed under the GNU General Public License v2.
5 5
 # See /LICENSE for more information.
6
+#
6 7
 
7 8
 include $(TOPDIR)/rules.mk
8 9
 
9 10
 PKG_NAME:=libwebsockets
10
-
11 11
 PKG_VERSION:=1.3-chrome37-firefox30
12 12
 PKG_RELEASE:=1
13
-PKG_SOURCE:=v$(PKG_VERSION).tar.gz
14
-PKG_SOURCE_URL:=https://github.com/warmcat/$(PKG_NAME)/archive/
13
+
14
+PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.xz
15
+PKG_SOURCE_PROTO:=git
15 16
 PKG_SOURCE_SUBDIR:=$(PKG_NAME)-$(PKG_VERSION)
17
+PKG_SOURCE_URL:=https://github.com/warmcat/libwebsockets.git
18
+PKG_SOURCE_VERSION:=v$(PKG_VERSION)
19
+
16 20
 PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(BUILD_VARIANT)/$(PKG_SOURCE_SUBDIR)
21
+
17 22
 PKG_LICENSE:=LGPL-2.1+exception
18 23
 PKG_LICENSE_FILES:=LICENSE
19 24