浏览代码

python: enforce the existence of files in the filespecs

Seems that this allows some goofs, because some files
silently do not get copied and the build succeeds, even though
it shouldn't.

Signed-off-by: Alexandru Ardelean <ardeleanalex@gmail.com>
Alexandru Ardelean 10 年前
父节点
当前提交
09c02844e4
共有 1 个文件被更改,包括 4 次插入0 次删除
  1. 4
    0
      lang/python/files/python-package.mk

+ 4
- 0
lang/python/files/python-package.mk 查看文件

@@ -37,6 +37,10 @@ define PyPackage
37 37
 		IFS='|'; \
38 38
 		while read fop fspec fperm; do \
39 39
 		  if [ "$$$$$$$$fop" = "+" ]; then \
40
+			if [ ! -e "$(PKG_INSTALL_DIR)$$$$$$$$fspec" ]; then \
41
+			  echo "File not found '$(PKG_INSTALL_DIR)$$$$$$$$fspec'"; \
42
+			  exit 1; \
43
+			fi; \
40 44
 			dpath=`dirname "$$$$$$$$fspec"`; \
41 45
 			if [ -n "$$$$$$$$fperm" ]; then \
42 46
 			  dperm="-m$$$$$$$$fperm"; \