Ver código fonte

msmtp: prevent use of IDN support on uClibc

Signed-off-by: Nicolas Thill <nico@openwrt.org>
Nicolas Thill 9 anos atrás
pai
commit
0a05c1340c
1 arquivos alterados com 5 adições e 1 exclusões
  1. 5
    1
      mail/msmtp/Makefile

+ 5
- 1
mail/msmtp/Makefile Ver arquivo

@@ -10,7 +10,7 @@ include $(TOPDIR)/rules.mk
10 10
 
11 11
 PKG_NAME:=msmtp
12 12
 PKG_VERSION:=1.6.1
13
-PKG_RELEASE:=2
13
+PKG_RELEASE:=3
14 14
 
15 15
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.xz
16 16
 PKG_SOURCE_URL:=@SF/msmtp
@@ -88,6 +88,10 @@ CONFIGURE_ARGS += \
88 88
 	--without-libsecret \
89 89
 	--without-macosx-keyring \
90 90
 
91
+ifneq ($(CONFIG_USE_UCLIBC),)
92
+  CONFIGURE_ARGS += --disable-gai-idn
93
+endif
94
+
91 95
 MAKE_FLAGS :=
92 96
 
93 97
 ifeq ($(BUILD_VARIANT),ssl)