Bläddra i källkod

bzip2: moved to base

Signed-off-by: Steven Barth <steven@midlink.org>
Steven Barth 9 år sedan
förälder
incheckning
0a2681c8e4
1 ändrade filer med 0 tillägg och 87 borttagningar
  1. 0
    87
      utils/bzip2/Makefile

+ 0
- 87
utils/bzip2/Makefile Visa fil

@@ -1,87 +0,0 @@
1
-#
2
-# Copyright (C) 2007-2008 OpenWrt.org
3
-#
4
-# This is free software, licensed under the GNU General Public License v2.
5
-# See /LICENSE for more information.
6
-#
7
-
8
-include $(TOPDIR)/rules.mk
9
-
10
-PKG_NAME:=bzip2
11
-PKG_VERSION:=1.0.6
12
-PKG_RELEASE:=2
13
-
14
-PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
15
-PKG_SOURCE_URL:=http://www.bzip.org/$(PKG_VERSION)
16
-PKG_MD5SUM:=00b516f4704d4a7cb50a1d97e6e8e15b
17
-PKG_MAINTAINER:=Steven Barth <cyrus@openwrt.org>
18
-
19
-PKG_LICENSE:=BZIP2
20
-PKG_LICENSE_FILES:=LICENSE
21
-
22
-include $(INCLUDE_DIR)/package.mk
23
-
24
-define Package/bzip2/Default
25
-  SUBMENU:=Compression
26
-  URL:=http://www.bzip.org/
27
-endef
28
-
29
-define Package/libbz2
30
-$(call Package/bzip2/Default)
31
-  SECTION:=libs
32
-  CATEGORY:=Libraries
33
-  DEPENDS:=
34
-  TITLE:=bzip2 library.
35
-endef
36
-
37
-define Package/libbz2/description
38
-	bzip2 is a freely available, patent free, high-quality
39
-	data compressor. This packages provides libbz2 library.
40
-endef
41
-
42
-define Package/bzip2
43
-$(call Package/bzip2/Default)
44
-  SECTION:=utils
45
-  CATEGORY:=Utilities
46
-  DEPENDS:=+libbz2
47
-  TITLE:=bzip2 is a compression utility.
48
-endef
49
-
50
-define Package/bzip2/description
51
-	bzip2 is a freely available, patent free, high-quality
52
-	data compressor. This package provides the binary.
53
-endef
54
-
55
-TARGET_CFLAGS += \
56
-	$(FPIC) \
57
-	$(TARGET_LDFLAGS)
58
-
59
-CONFIGURE_ARGS += --prefix=/usr
60
-
61
-MAKE_FLAGS += \
62
-	-f Makefile-libbz2_so \
63
-	CFLAGS="$(TARGET_CFLAGS)" \
64
-	all
65
-
66
-define Build/InstallDev
67
-	$(INSTALL_DIR) $(1)/usr/include
68
-	$(CP) $(PKG_BUILD_DIR)/bzlib.h $(1)/usr/include/
69
-	$(INSTALL_DIR) $(1)/usr/lib
70
-	$(CP) $(PKG_BUILD_DIR)/libbz2.so.$(PKG_VERSION) $(1)/usr/lib/
71
-	$(LN) libbz2.so.$(PKG_VERSION) $(1)/usr/lib/libbz2.so.1.0
72
-	$(LN) libbz2.so.$(PKG_VERSION) $(1)/usr/lib/libbz2.so
73
-endef
74
-
75
-define Package/libbz2/install
76
-	$(INSTALL_DIR) $(1)/usr/lib/
77
-	$(CP) $(PKG_BUILD_DIR)/libbz2.so.$(PKG_VERSION) $(1)/usr/lib/
78
-	$(LN) libbz2.so.$(PKG_VERSION) $(1)/usr/lib/libbz2.so.1.0
79
-endef
80
-
81
-define Package/bzip2/install
82
-	$(INSTALL_DIR) $(1)/usr/bin/
83
-	$(INSTALL_BIN) $(PKG_BUILD_DIR)/bzip2-shared $(1)/usr/bin/bzip2
84
-endef
85
-
86
-$(eval $(call BuildPackage,libbz2))
87
-$(eval $(call BuildPackage,bzip2))