Browse Source

utils/gnupg: add new package gnupg-utils

The current package gnupg does not allow to receive keys due to
disable-exec, disable-hkp configuration.

The patch removes these switches. To avoid unduely increasing the package
size the helper executables are put into a new package gnupg-utils.

The version is bumped to 1.4.20 to avoid an error when receiving keys.

Signed-off-by: Heinrich Schuchardt <xypron.glpk@gmx.de>
Heinrich Schuchardt 9 years ago
parent
commit
0a61d56eb3
1 changed files with 28 additions and 5 deletions
  1. 28
    5
      utils/gnupg/Makefile

+ 28
- 5
utils/gnupg/Makefile View File

@@ -8,13 +8,13 @@
8 8
 include $(TOPDIR)/rules.mk
9 9
 
10 10
 PKG_NAME:=gnupg
11
-PKG_VERSION:=1.4.19
11
+PKG_VERSION:=1.4.20
12 12
 PKG_RELEASE:=1
13 13
 
14 14
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
15 15
 PKG_SOURCE_URL:=ftp://ftp.franken.de/pub/crypt/mirror/ftp.gnupg.org/gcrypt/gnupg \
16 16
 	ftp://ftp.gnupg.org/gcrypt/gnupg
17
-PKG_MD5SUM:=3af4ab5b3113b3e28d3551ecf9600785
17
+PKG_MD5SUM:=b7af897a041c03c8ad1c7c466b54d10d
18 18
 
19 19
 PKG_LICENSE:=GPL-3.0
20 20
 PKG_LICENSE_FILES:=COPYING
@@ -24,7 +24,7 @@ PKG_INSTALL:=1
24 24
 
25 25
 include $(INCLUDE_DIR)/package.mk
26 26
 
27
-define Package/gnupg
27
+define Package/gnupg/Default
28 28
   SECTION:=utils
29 29
   CATEGORY:=Utilities
30 30
   DEPENDS:=+zlib +libncurses +libreadline
@@ -32,6 +32,17 @@ define Package/gnupg
32 32
   URL:=http://www.gnupg.org/
33 33
 endef
34 34
 
35
+define Package/gnupg
36
+  $(call Package/gnupg/Default)
37
+  MENU:=1
38
+endef
39
+
40
+define Package/gnupg-utils
41
+  $(call Package/gnupg/Default)
42
+  DEPENDS:=gnupg
43
+  TITLE:=Key management utilities for GnuPG
44
+endef
45
+
35 46
 define Package/gnupg/description
36 47
  GnuPG is GNU's tool for secure communication and data storage.
37 48
  It can be used to encrypt data and to create digital signatures.
@@ -42,6 +53,11 @@ define Package/gnupg/description
42 53
  with PGP2 because it uses IDEA (which is patented worldwide).
43 54
 endef
44 55
 
56
+define Package/gnupg-utils/description
57
+ Key management utilies for GnuPG.
58
+ This package is needed to import keys from a keyserver.
59
+endef
60
+
45 61
 CONFIGURE_ARGS += \
46 62
 	--disable-rpath \
47 63
 	--disable-asm \
@@ -49,9 +65,7 @@ CONFIGURE_ARGS += \
49 65
 	--disable-card-support \
50 66
 	--disable-agent-support \
51 67
 	--disable-bzip2 \
52
-	--disable-exec \
53 68
 	--disable-ldap \
54
-	--disable-hkp \
55 69
 	--disable-finger \
56 70
 	--disable-ftp \
57 71
 	--disable-dns-srv \
@@ -66,4 +80,13 @@ define Package/gnupg/install
66 80
 	$(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/bin/gpg $(1)/usr/bin/
67 81
 endef
68 82
 
83
+define Package/gnupg-utils/install
84
+	$(INSTALL_DIR) $(1)/usr/lib/gnupg
85
+	for file in gpgkeys_curl gpgkeys_hkp; do \
86
+		$(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/lib/gnupg/$$$$file \
87
+		  $(1)/usr/lib/gnupg/; \
88
+	done
89
+endef
90
+
69 91
 $(eval $(call BuildPackage,gnupg))
92
+$(eval $(call BuildPackage,gnupg-utils))