Browse Source

mailsend: split into 2 packages - with SSL and without SSL

Signed-off-by: Ted Hess <thess@kitschensync.net>
Ted Hess 10 years ago
parent
commit
0b2e43d07b
1 changed files with 26 additions and 13 deletions
  1. 26
    13
      mail/mailsend/Makefile

+ 26
- 13
mail/mailsend/Makefile View File

@@ -1,5 +1,5 @@
1 1
 #
2
-# Copyright (C) 2014 OpenWrt.org
2
+# Copyright (C) 2014-2015 OpenWrt.org
3 3
 #
4 4
 # This is free software, licensed under the GNU General Public License v2.
5 5
 # See /LICENSE for more information.
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
9 9
 
10 10
 PKG_NAME:=mailsend
11 11
 PKG_VERSION:=1.17b15
12
-PKG_RELEASE:=1
12
+PKG_RELEASE:=2
13 13
 
14 14
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
15 15
 PKG_SOURCE_URL:=https://github.com/muquit/mailsend/archive/$(PKG_VERSION)
@@ -20,32 +20,42 @@ PKG_MAINTAINER:=Ted Hess <thess@kitschensync.net>
20 20
 PKG_LICENSE:=BSD-3-Clause
21 21
 PKG_LICENSE_FILES:=COPYRIGHT
22 22
 
23
+PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(BUILD_VARIANT)/$(PKG_NAME)-$(PKG_VERSION)
24
+
23 25
 include $(INCLUDE_DIR)/package.mk
24 26
 
25
-define Package/mailsend
27
+define Package/mailsend/default
26 28
 	SECTION:=mail
27 29
 	CATEGORY:=Mail
28 30
 	TITLE:=A command-line mail sender
29
-	DEPENDS:=+MAILSEND_SSL:libopenssl
30 31
 	URL:=https://github.com/muquit/mailsend
31 32
 endef
32 33
 
33
-define Package/mailsend/config
34
-config MAILSEND_SSL
35
-        bool "SSL support"
36
-        depends on PACKAGE_mailsend
37
-        default n
38
-        help
39
-          Implements SSL support in mailsend (using libopenssl).
34
+define Package/mailsend-nossl
35
+	$(call Package/mailsend/default)
36
+	TITLE+= (without SSL)
37
+	VARIANT:=nossl
38
+endef
39
+
40
+define Package/mailsend
41
+	$(call Package/mailsend/default)
42
+	TITLE+= (with SSL)
43
+	DEPENDS:=+libopenssl
44
+	VARIANT:=ssl
40 45
 endef
41 46
 
42
-ifeq ($(CONFIG_MAILSEND_SSL),y)
47
+ifeq ($(BUILD_VARIANT),ssl)
43 48
   CONFIGURE_ARGS+= --with-openssl=$(STAGING_DIR)/usr
44 49
 endif
45 50
 
46 51
 define Package/mailsend/description
52
+  $(call Package/mailsend-nossl/description)
53
+  .
54
+  SSL supported is provided by OpenSSL.
55
+endef
56
+
57
+define Package/mailsend-nossl/description
47 58
   Mailsend is a simple command line program to send mail via SMTP protocol.
48
-  SSL is supported via OpenSSL (optional).
49 59
 endef
50 60
 
51 61
 define Build/Compile
@@ -57,4 +67,7 @@ define Package/mailsend/install
57 67
 	$(INSTALL_BIN) $(PKG_BUILD_DIR)/mailsend $(1)/usr/bin/
58 68
 endef
59 69
 
70
+Package/mailsend-nossl/install=$(Package/mailsend/install)
71
+
60 72
 $(eval $(call BuildPackage,mailsend))
73
+$(eval $(call BuildPackage,mailsend-nossl))