ソースを参照

lttng-ust: import from old packages feed

 - update to latest version (v2.6.0)
 - add license info
 - add myself as maintainer

Signed-off-by: Nicolas Thill <nico@openwrt.org>
Nicolas Thill 10 年 前
コミット
0bb5f29415
共有3 個のファイルを変更した80 個の追加0 個の削除を含む
  1. 51
    0
      libs/lttng-ust/Makefile
  2. 11
    0
      libs/lttng-ust/patches/001-no_docs_tests.patch
  3. 18
    0
      libs/lttng-ust/patches/002-examples.patch

+ 51
- 0
libs/lttng-ust/Makefile ファイルの表示

@@ -0,0 +1,51 @@
1
+#
2
+# Copyright (C) 2013-2015 OpenWrt.org
3
+#
4
+# This is free software, licensed under the GNU General Public License v2.
5
+# See /LICENSE for more information.
6
+#
7
+
8
+include $(TOPDIR)/rules.mk
9
+
10
+PKG_NAME:=lttng-ust
11
+PKG_VERSION:=2.6.0
12
+PKG_RELEASE:=1
13
+
14
+PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
15
+PKG_SOURCE_URL:=https://lttng.org/files/$(PKG_NAME)/
16
+PKG_MD5SUM:=74ad4826eac76c9dbf50fd3e46523191
17
+
18
+PKG_LICENSE:=LGPL-2.1 GPL-2.0
19
+PKG_LICENSE_FILES:=COPYING
20
+PKG_MAINTAINER:=Nicolas Thill <nico@openwrt.org>
21
+
22
+PKG_FIXUP:=autoreconf
23
+PKG_USE_MIPS16:=0
24
+PKG_BUILD_PARALLEL:=1
25
+PKG_INSTALL:=1
26
+
27
+include $(INCLUDE_DIR)/package.mk
28
+
29
+define Package/lttng-ust
30
+  SECTION:=libs
31
+  CATEGORY:=Libraries
32
+  TITLE:=Linux Trace Toolkit: next generation (library)
33
+  URL:=https://lttng.org/
34
+  DEPENDS:= +liburcu +libuuid +librt
35
+endef
36
+
37
+define Build/InstallDev
38
+	$(INSTALL_DIR) $(1)/usr/include
39
+	$(CP) $(PKG_INSTALL_DIR)/usr/include/lttng $(1)/usr/include/
40
+	$(INSTALL_DIR) $(1)/usr/lib
41
+	$(CP) $(PKG_INSTALL_DIR)/usr/lib/liblttng-ust*.{a,so*} $(1)/usr/lib/
42
+	$(INSTALL_DIR) $(1)/usr/lib/pkgconfig
43
+	$(CP) $(PKG_INSTALL_DIR)/usr/lib/pkgconfig/lttng-ust.pc $(1)/usr/lib/pkgconfig/
44
+endef
45
+
46
+define Package/lttng-ust/install
47
+	$(INSTALL_DIR) $(1)/usr/lib
48
+	$(CP) $(PKG_INSTALL_DIR)/usr/lib/liblttng*.so.* $(1)/usr/lib/
49
+endef
50
+
51
+$(eval $(call BuildPackage,lttng-ust))

+ 11
- 0
libs/lttng-ust/patches/001-no_docs_tests.patch ファイルの表示

@@ -0,0 +1,11 @@
1
+--- a/Makefile.am
2
++++ b/Makefile.am
3
+@@ -20,8 +20,6 @@ if BUILD_JAVA_AGENT
4
+ SUBDIRS += liblttng-ust-java-agent
5
+ endif
6
+ 
7
+-SUBDIRS += tests doc
8
+-
9
+ #temporarily disabled
10
+ # liblttng-ust-malloc
11
+ 

+ 18
- 0
libs/lttng-ust/patches/002-examples.patch ファイルの表示

@@ -0,0 +1,18 @@
1
+--- a/configure.ac
2
++++ b/configure.ac
3
+@@ -350,7 +350,14 @@ AC_ARG_WITH([lttng-system-rundir],
4
+ AC_DEFINE_UNQUOTED([LTTNG_SYSTEM_RUNDIR], ["$lttng_system_rundir"],
5
+ 	[LTTng system runtime directory])
6
+ 
7
+-AM_PATH_PYTHON([2.7],BUILD_GEN_TP_EXAMPLES=1,[:])
8
++AC_ARG_ENABLE([examples],
9
++	[AS_HELP_STRING([--enable-examples],[build examples [default=no]])],
10
++	[enable_examples=$enableval],
11
++	[enable_examples=no]
12
++)
13
++if test "x$enable_examples" = "xyes"; then
14
++  AM_PATH_PYTHON([2.7],BUILD_GEN_TP_EXAMPLES=1,[:])
15
++fi
16
+ AM_CONDITIONAL([BUILD_GEN_TP_EXAMPLES], [test $BUILD_GEN_TP_EXAMPLES], [Build examples requiring lttng-gen-tp])
17
+ 
18
+ AC_CONFIG_FILES([