|
@@ -0,0 +1,51 @@
|
|
1
|
+#
|
|
2
|
+# Copyright (C) 2013-2015 OpenWrt.org
|
|
3
|
+#
|
|
4
|
+# This is free software, licensed under the GNU General Public License v2.
|
|
5
|
+# See /LICENSE for more information.
|
|
6
|
+#
|
|
7
|
+
|
|
8
|
+include $(TOPDIR)/rules.mk
|
|
9
|
+
|
|
10
|
+PKG_NAME:=lttng-ust
|
|
11
|
+PKG_VERSION:=2.6.0
|
|
12
|
+PKG_RELEASE:=1
|
|
13
|
+
|
|
14
|
+PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
|
|
15
|
+PKG_SOURCE_URL:=https://lttng.org/files/$(PKG_NAME)/
|
|
16
|
+PKG_MD5SUM:=74ad4826eac76c9dbf50fd3e46523191
|
|
17
|
+
|
|
18
|
+PKG_LICENSE:=LGPL-2.1 GPL-2.0
|
|
19
|
+PKG_LICENSE_FILES:=COPYING
|
|
20
|
+PKG_MAINTAINER:=Nicolas Thill <nico@openwrt.org>
|
|
21
|
+
|
|
22
|
+PKG_FIXUP:=autoreconf
|
|
23
|
+PKG_USE_MIPS16:=0
|
|
24
|
+PKG_BUILD_PARALLEL:=1
|
|
25
|
+PKG_INSTALL:=1
|
|
26
|
+
|
|
27
|
+include $(INCLUDE_DIR)/package.mk
|
|
28
|
+
|
|
29
|
+define Package/lttng-ust
|
|
30
|
+ SECTION:=libs
|
|
31
|
+ CATEGORY:=Libraries
|
|
32
|
+ TITLE:=Linux Trace Toolkit: next generation (library)
|
|
33
|
+ URL:=https://lttng.org/
|
|
34
|
+ DEPENDS:= +liburcu +libuuid +librt
|
|
35
|
+endef
|
|
36
|
+
|
|
37
|
+define Build/InstallDev
|
|
38
|
+ $(INSTALL_DIR) $(1)/usr/include
|
|
39
|
+ $(CP) $(PKG_INSTALL_DIR)/usr/include/lttng $(1)/usr/include/
|
|
40
|
+ $(INSTALL_DIR) $(1)/usr/lib
|
|
41
|
+ $(CP) $(PKG_INSTALL_DIR)/usr/lib/liblttng-ust*.{a,so*} $(1)/usr/lib/
|
|
42
|
+ $(INSTALL_DIR) $(1)/usr/lib/pkgconfig
|
|
43
|
+ $(CP) $(PKG_INSTALL_DIR)/usr/lib/pkgconfig/lttng-ust.pc $(1)/usr/lib/pkgconfig/
|
|
44
|
+endef
|
|
45
|
+
|
|
46
|
+define Package/lttng-ust/install
|
|
47
|
+ $(INSTALL_DIR) $(1)/usr/lib
|
|
48
|
+ $(CP) $(PKG_INSTALL_DIR)/usr/lib/liblttng*.so.* $(1)/usr/lib/
|
|
49
|
+endef
|
|
50
|
+
|
|
51
|
+$(eval $(call BuildPackage,lttng-ust))
|