浏览代码

ortp: import from old packages feed

 - update to latest version (v0.23.0)
 - add license info
 - add myself as maintainer

Signed-off-by: Nicolas Thill <nico@openwrt.org>
Nicolas Thill 10 年前
父节点
当前提交
0c0bcb3d0a
共有 1 个文件被更改,包括 81 次插入0 次删除
  1. 81
    0
      libs/ortp/Makefile

+ 81
- 0
libs/ortp/Makefile 查看文件

@@ -0,0 +1,81 @@
1
+#
2
+# Copyright (C) 2010-2015 OpenWrt.org
3
+#
4
+# This is free software, licensed under the GNU General Public License v2.
5
+# See /LICENSE for more information.
6
+#
7
+
8
+include $(TOPDIR)/rules.mk
9
+
10
+PKG_NAME:=ortp
11
+PKG_VERSION:=0.23.0
12
+PKG_RELEASE:=1
13
+
14
+PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
15
+PKG_SOURCE_URL:= \
16
+	http://download.savannah.gnu.org/releases-noredirect/linphone/ortp/sources/ \
17
+	http://www.very-clever.com/download/nongnu/linphone/ortp/sources/
18
+PKG_MD5SUM:=2b0281600cb958d1c94e318a86b62fe3
19
+
20
+PKG_LICENSE:=LGPL-2.1
21
+PKG_LICENSE_FILES:=COPYING
22
+PKG_MAINTAINER:=Nicolas Thill <nico@openwrt.org>
23
+
24
+PKG_INSTALL:=1
25
+
26
+include $(INCLUDE_DIR)/package.mk
27
+
28
+define Package/libortp
29
+  SECTION:=libs
30
+  CATEGORY:=Libraries
31
+  TITLE:=Real-time Transport Protocol (RTP) library
32
+  URL:=http://www.linphone.org/technical-corner/ortp/overview
33
+  DEPENDS:= +libpthread +librt
34
+endef
35
+
36
+ifneq ($(CONFIG_avr32),)
37
+  TARGET_CFLAGS += -fsigned-char
38
+endif
39
+
40
+CONFIGURE_ARGS += \
41
+	--enable-shared \
42
+	--enable-static \
43
+	--disable-debug \
44
+	--enable-ipv6 \
45
+	--enable-perf \
46
+	--disable-ssl-hmac \
47
+	--disable-tests \
48
+	--without-srtp \
49
+
50
+CONFIGURE_VARS += \
51
+	ac_cv_header_srtp_srtp_h=no \
52
+	ac_cv_lib_srtp_srtp_init=no \
53
+	ac_cv_path_DOXYGEN= \
54
+
55
+define Build/InstallDev
56
+	$(INSTALL_DIR) $(1)/usr/include
57
+	( cd $(PKG_INSTALL_DIR); $(CP) \
58
+		./usr/include/ortp \
59
+		$(1)/usr/include/ \
60
+	)
61
+	$(INSTALL_DIR) $(1)/usr/lib
62
+	( cd $(PKG_INSTALL_DIR); $(CP) \
63
+		./usr/lib/libortp.{a,so*} \
64
+		$(1)/usr/lib/ \
65
+	)
66
+	$(INSTALL_DIR) $(1)/usr/lib/pkgconfig
67
+	( cd $(PKG_INSTALL_DIR); $(CP) \
68
+		./usr/lib/pkgconfig/ortp.pc \
69
+		$(1)/usr/lib/pkgconfig/ \
70
+	)
71
+endef
72
+
73
+define Package/libortp/install
74
+	$(INSTALL_DIR) $(1)/usr/lib
75
+	( cd $(PKG_INSTALL_DIR); $(CP) \
76
+		./usr/lib/libortp.so.* \
77
+		$(1)/usr/lib/ \
78
+	)
79
+endef
80
+
81
+$(eval $(call BuildPackage,libortp))