Browse Source

acl: use generic autoreconf fixup

Use the generic autoreconf facility to pickup proper variants of
autoconf, automake and libtool.

Remove the unneeded Build/Prepare override.

Signed-off-by: Jo-Philipp Wich <jow@openwrt.org>
Jo-Philipp Wich 10 years ago
parent
commit
0c0c590616
1 changed files with 4 additions and 6 deletions
  1. 4
    6
      utils/acl/Makefile

+ 4
- 6
utils/acl/Makefile View File

@@ -19,10 +19,13 @@ PKG_SOURCE_SUBDIR:=$(PKG_NAME)-$(PKG_VERSION)
19 19
 PKG_SOURCE_VERSION:=$(PKG_REV)
20 20
 PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(PKG_VERSION)
21 21
 PKG_MAINTAINER:=Maxim Storchak <m.storchak@gmail.com>
22
-PKG_INSTALL:=1
22
+
23 23
 PKG_LICENSE:=LGPL-2.1 GPL-2.0
24 24
 PKG_LICENSE_FILES:=doc/COPYING doc/COPYING.LGPL
25 25
 
26
+PKG_INSTALL:=1
27
+PKG_FIXUP:=autoreconf
28
+
26 29
 include $(INCLUDE_DIR)/package.mk
27 30
 
28 31
 define Package/acl/Default
@@ -66,11 +69,6 @@ endef
66 69
 
67 70
 CONFIGURE_ARGS += --enable-static --enable-shared
68 71
 
69
-define Build/Prepare
70
-	$(call Build/Prepare/Default)
71
-	(cd $(PKG_BUILD_DIR); ./autogen.sh;);
72
-endef
73
-
74 72
 define Package/acl/install
75 73
 	$(INSTALL_DIR) $(1)/usr/bin
76 74
 	$(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/bin/* $(1)/usr/bin/