瀏覽代碼

Merge pull request #425 from MikePetullo/bogofilter

bogofilter: new package for bogofilter spam filter
sbyx 10 年之前
父節點
當前提交
0dcfd07ba6
共有 1 個文件被更改,包括 53 次插入0 次删除
  1. 53
    0
      mail/bogofilter/Makefile

+ 53
- 0
mail/bogofilter/Makefile 查看文件

@@ -0,0 +1,53 @@
1
+#
2
+# Copyright (C) 2014 OpenWrt.org
3
+#
4
+# This is free software, licensed under the GNU General Public License v2.
5
+# See /LICENSE for more information.
6
+#
7
+
8
+include $(TOPDIR)/rules.mk
9
+
10
+PKG_NAME:=bogofilter
11
+PKG_VERSION:=1.2.4
12
+PKG_RELEASE:=1
13
+
14
+PKG_LICENSE:=GPLv2
15
+PKG_LICENSE_FILE:=COPYING
16
+
17
+PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
18
+PKG_SOURCE_URL:=@SF/bogofilter
19
+PKG_MD5SUM:=d0a5eebb3274b23ceabe766a6443a1c5
20
+
21
+PKG_INSTALL:=1
22
+
23
+include $(INCLUDE_DIR)/package.mk
24
+
25
+define Package/bogofilter
26
+  SECTION:=mail
27
+  CATEGORY:=Mail
28
+  DEPENDS:=+libdb47
29
+  TITLE:=bogofilter
30
+  MAINTAINER:=W. Michael Petullo <mike@flyn.org>
31
+  URL:=http://bogofilter.sourceforge.net/
32
+endef
33
+
34
+define Package/bogofilter/description
35
+	Bogofilter is a fast Bayesian spam filter
36
+endef
37
+
38
+CONFIGURE_ARGS += --disable-unicode
39
+
40
+define Package/bogofilter/install
41
+	$(INSTALL_DIR)  $(1)/etc/ \
42
+                        $(1)/usr/bin
43
+	$(INSTALL_CONF) $(PKG_BUILD_DIR)/bogofilter.cf.example $(1)/etc/bogofilter.cf
44
+	$(CP) $(PKG_INSTALL_DIR)/usr/bin/bf_compact $(1)/usr/bin/
45
+	$(CP) $(PKG_INSTALL_DIR)/usr/bin/bf_copy $(1)/usr/bin/
46
+	$(CP) $(PKG_INSTALL_DIR)/usr/bin/bf_tar $(1)/usr/bin/
47
+	$(CP) $(PKG_INSTALL_DIR)/usr/bin/bogofilter $(1)/usr/bin/
48
+	$(CP) $(PKG_INSTALL_DIR)/usr/bin/bogolexer $(1)/usr/bin/
49
+	$(CP) $(PKG_INSTALL_DIR)/usr/bin/bogotune $(1)/usr/bin/
50
+	$(CP) $(PKG_INSTALL_DIR)/usr/bin/bogoutil $(1)/usr/bin/
51
+endef
52
+
53
+$(eval $(call BuildPackage,bogofilter))