Переглянути джерело

Merge pull request #991 from thess/gst-work

gstreamer: Update to 1.4.5
Ted Hess 10 роки тому
джерело
коміт
0e6069854f

+ 3
- 3
multimedia/gst1-libav/Makefile Переглянути файл

@@ -1,5 +1,5 @@
1 1
 #
2
-# Copyright (C) 2006-2014 OpenWrt.org
2
+# Copyright (C) 2006-2015 OpenWrt.org
3 3
 #
4 4
 # This is free software, licensed under the GNU General Public License v2.
5 5
 # See /LICENSE for more information.
@@ -8,14 +8,14 @@
8 8
 include $(TOPDIR)/rules.mk
9 9
 
10 10
 PKG_NAME:=gst1-libav
11
-PKG_VERSION:=1.4.4
11
+PKG_VERSION:=1.4.5
12 12
 PKG_RELEASE:=1
13 13
 
14 14
 PKG_MAINTAINER:=W. Michael Petullo <mike@flyn.org>
15 15
 
16 16
 PKG_SOURCE:=gst-libav-$(PKG_VERSION).tar.xz
17 17
 PKG_SOURCE_URL:=http://gstreamer.freedesktop.org/src/gst-libav
18
-PKG_MD5SUM:=64a3e2cda2687132cadca4efdc63f3b4
18
+PKG_MD5SUM:=f4922a46adbcbe7bd01331ff5dc7979d
19 19
 
20 20
 PKG_LICENSE:=GPL-2.0 LGPL-2.0
21 21
 PKG_LICENSE_FILES:=COPYING COPYING.LIB

+ 6
- 4
multimedia/gst1-plugins-bad/Makefile Переглянути файл

@@ -8,8 +8,8 @@
8 8
 include $(TOPDIR)/rules.mk
9 9
 
10 10
 PKG_NAME:=gst1-plugins-bad
11
-PKG_VERSION:=1.4.4
12
-PKG_RELEASE:=5
11
+PKG_VERSION:=1.4.5
12
+PKG_RELEASE:=1
13 13
 
14 14
 PKG_MAINTAINER:=W. Michael Petullo <mike@flyn.org>
15 15
 
@@ -19,9 +19,9 @@ PKG_LICENSE_FILES:=COPYING.LIB COPYING
19 19
 PKG_BUILD_DIR:=$(BUILD_DIR)/gst-plugins-bad-$(PKG_VERSION)
20 20
 PKG_SOURCE:=gst-plugins-bad-$(PKG_VERSION).tar.xz
21 21
 PKG_SOURCE_URL:=http://gstreamer.freedesktop.org/src/gst-plugins-bad/
22
-PKG_MD5SUM:=972c6e22dd2e44fcf0b04b9d810a56be
22
+PKG_MD5SUM:=e0bb39412cf4a48fe0397bcf3a7cd451
23 23
 
24
-PKG_BUILD_DEPENDS:= libgstreamer1 gstreamer1-plugins-base liboil
24
+PKG_BUILD_DEPENDS:= libgstreamer1 gstreamer1-plugins-base
25 25
 
26 26
 PKG_FIXUP:=autoreconf
27 27
 PKG_INSTALL:=1
@@ -148,9 +148,11 @@ CONFIGURE_ARGS += \
148 148
 	--disable-schro \
149 149
 	--disable-zbar \
150 150
 	--disable-srtp \
151
+	--disable-hls \
151 152
 	\
152 153
 	--without-libiconv-prefix \
153 154
 	--without-libintl-prefix \
155
+	--with-libgcrypt-prefix="$(STAGING_DIR)/usr" \
154 156
 	--without-x \
155 157
 
156 158
 TARGET_CFLAGS+= -std=gnu99

+ 10
- 13
multimedia/gst1-plugins-bad/patches/000-gettext.patch Переглянути файл

@@ -1,18 +1,16 @@
1
-diff -u --recursive gst-plugins-bad-1.0.7-vanilla/configure.ac gst-plugins-bad-1.0.7/configure.ac
2
---- gst-plugins-bad-1.0.7-vanilla/configure.ac	2013-06-01 19:44:32.199308073 -0500
3
-+++ gst-plugins-bad-1.0.7/configure.ac	2013-06-01 19:45:27.754119344 -0500
4
-@@ -2373,7 +2373,6 @@
5
- ext/timidity/Makefile
1
+--- a/configure.ac
2
++++ b/configure.ac
3
+@@ -3334,7 +3334,6 @@ ext/timidity/Makefile
4
+ ext/webp/Makefile
6 5
  ext/xvid/Makefile
7 6
  ext/zbar/Makefile
8 7
 -po/Makefile.in
9 8
  docs/Makefile
10 9
  docs/plugins/Makefile
11 10
  docs/libs/Makefile
12
-diff -u --recursive gst-plugins-bad-1.0.7-vanilla/Makefile.am gst-plugins-bad-1.0.7/Makefile.am
13
---- gst-plugins-bad-1.0.7-vanilla/Makefile.am	2013-06-01 19:44:32.165309412 -0500
14
-+++ gst-plugins-bad-1.0.7/Makefile.am	2013-06-01 19:45:39.016675625 -0500
15
-@@ -2,11 +2,11 @@
11
+--- a/Makefile.am
12
++++ b/Makefile.am
13
+@@ -2,11 +2,11 @@ DISTCHECK_CONFIGURE_FLAGS=--enable-gtk-d
16 14
  
17 15
  SUBDIRS = \
18 16
  	gst-libs gst sys ext pkgconfig \
@@ -26,10 +24,9 @@ diff -u --recursive gst-plugins-bad-1.0.7-vanilla/Makefile.am gst-plugins-bad-1.
26 24
  
27 25
  # include before EXTRA_DIST for win32 assignment
28 26
  include $(top_srcdir)/common/win32.mak
29
-diff -u --recursive gst-plugins-bad-1.0.7-vanilla/Makefile.in gst-plugins-bad-1.0.7/Makefile.in
30
---- gst-plugins-bad-1.0.7-vanilla/Makefile.in	2013-06-01 19:44:32.217307364 -0500
31
-+++ gst-plugins-bad-1.0.7/Makefile.in	2013-06-01 19:45:44.624454691 -0500
32
-@@ -636,11 +636,11 @@
27
+--- a/Makefile.in
28
++++ b/Makefile.in
29
+@@ -739,11 +739,11 @@ wayland_scanner = @wayland_scanner@
33 30
  DISTCHECK_CONFIGURE_FLAGS = --enable-gtk-doc
34 31
  SUBDIRS = \
35 32
  	gst-libs gst sys ext pkgconfig \

+ 4
- 4
multimedia/gst1-plugins-base/Makefile Переглянути файл

@@ -8,8 +8,8 @@
8 8
 include $(TOPDIR)/rules.mk
9 9
 
10 10
 PKG_NAME:=gst1-plugins-base
11
-PKG_VERSION:=1.4.4
12
-PKG_RELEASE:=4
11
+PKG_VERSION:=1.4.5
12
+PKG_RELEASE:=1
13 13
 
14 14
 PKG_MAINTAINER:=W. Michael Petullo <mike@flyn.org>
15 15
 
@@ -19,9 +19,9 @@ PKG_LICENSE_FILES:=COPYING.LIB COPYING
19 19
 PKG_BUILD_DIR:=$(BUILD_DIR)/gst-plugins-base-$(PKG_VERSION)
20 20
 PKG_SOURCE:=gst-plugins-base-$(PKG_VERSION).tar.xz
21 21
 PKG_SOURCE_URL:=http://gstreamer.freedesktop.org/src/gst-plugins-base/
22
-PKG_MD5SUM:=0c42eca8f9e4efd56d2ce8e9249ce4a1
22
+PKG_MD5SUM:=357165af625c0ca353ab47c5d843920e
23 23
 
24
-PKG_BUILD_DEPENDS:= libgstreamer1 liboil
24
+PKG_BUILD_DEPENDS:= libgstreamer1
25 25
 PKG_CONFIG_DEPENDS:= \
26 26
 	CONFIG_PACKAGE_gst1-mod-alsa \
27 27
 	CONFIG_PACKAGE_gst1-mod-app \

+ 6
- 8
multimedia/gst1-plugins-base/patches/001-no_docs.patch Переглянути файл

@@ -1,7 +1,6 @@
1
-diff -u --recursive gst-plugins-base-1.0.7-vanilla/Makefile.am gst-plugins-base-1.0.7/Makefile.am
2
---- gst-plugins-base-1.0.7-vanilla/Makefile.am	2013-06-01 22:38:30.495678685 -0500
3
-+++ gst-plugins-base-1.0.7/Makefile.am	2013-06-01 22:39:04.374335121 -0500
4
-@@ -12,14 +12,12 @@
1
+--- a/Makefile.am
2
++++ b/Makefile.am
3
+@@ -12,14 +12,12 @@ SUBDIRS = 			\
5 4
  	gst sys $(SUBDIRS_EXT) 	\
6 5
  	tools 			\
7 6
  	tests 			\
@@ -16,10 +15,9 @@ diff -u --recursive gst-plugins-base-1.0.7-vanilla/Makefile.am gst-plugins-base-
16 15
  	gst-libs		\
17 16
  	gst sys ext		\
18 17
  	tools 			\
19
-diff -u --recursive gst-plugins-base-1.0.7-vanilla/Makefile.in gst-plugins-base-1.0.7/Makefile.in
20
---- gst-plugins-base-1.0.7-vanilla/Makefile.in	2013-06-01 22:38:30.527677416 -0500
21
-+++ gst-plugins-base-1.0.7/Makefile.in	2013-06-01 22:38:59.110543873 -0500
22
-@@ -493,14 +493,12 @@
18
+--- a/Makefile.in
19
++++ b/Makefile.in
20
+@@ -539,14 +539,12 @@ SUBDIRS = \
23 21
  	gst sys $(SUBDIRS_EXT) 	\
24 22
  	tools 			\
25 23
  	tests 			\

+ 8
- 10
multimedia/gst1-plugins-base/patches/002-no_tests.patch Переглянути файл

@@ -1,7 +1,6 @@
1
-diff -u --recursive gst-plugins-base-1.0.7-vanilla/Makefile.am gst-plugins-base-1.0.7/Makefile.am
2
---- gst-plugins-base-1.0.7-vanilla/Makefile.am	2013-06-01 19:49:37.986260708 -0500
3
-+++ gst-plugins-base-1.0.7/Makefile.am	2013-06-01 19:49:54.998590479 -0500
4
-@@ -11,7 +11,6 @@
1
+--- a/Makefile.am
2
++++ b/Makefile.am
3
+@@ -11,7 +11,6 @@ SUBDIRS = 			\
5 4
  	gst-libs 		\
6 5
  	gst sys $(SUBDIRS_EXT) 	\
7 6
  	tools 			\
@@ -9,7 +8,7 @@ diff -u --recursive gst-plugins-base-1.0.7-vanilla/Makefile.am gst-plugins-base-
9 8
  	po 			\
10 9
  	common 			\
11 10
  	m4
12
-@@ -21,7 +20,6 @@
11
+@@ -21,7 +20,6 @@ DIST_SUBDIRS = 			\
13 12
  	gst-libs		\
14 13
  	gst sys ext		\
15 14
  	tools 			\
@@ -17,10 +16,9 @@ diff -u --recursive gst-plugins-base-1.0.7-vanilla/Makefile.am gst-plugins-base-
17 16
  	po 			\
18 17
  	common 			\
19 18
  	m4
20
-diff -u --recursive gst-plugins-base-1.0.7-vanilla/Makefile.in gst-plugins-base-1.0.7/Makefile.in
21
---- gst-plugins-base-1.0.7-vanilla/Makefile.in	2013-06-01 19:49:37.987260668 -0500
22
-+++ gst-plugins-base-1.0.7/Makefile.in	2013-06-01 19:49:58.374457466 -0500
23
-@@ -492,7 +492,6 @@
19
+--- a/Makefile.in
20
++++ b/Makefile.in
21
+@@ -538,7 +538,6 @@ SUBDIRS = \
24 22
  	gst-libs 		\
25 23
  	gst sys $(SUBDIRS_EXT) 	\
26 24
  	tools 			\
@@ -28,7 +26,7 @@ diff -u --recursive gst-plugins-base-1.0.7-vanilla/Makefile.in gst-plugins-base-
28 26
  	po 			\
29 27
  	common 			\
30 28
  	m4
31
-@@ -502,7 +501,6 @@
29
+@@ -548,7 +547,6 @@ DIST_SUBDIRS = \
32 30
  	gst-libs		\
33 31
  	gst sys ext		\
34 32
  	tools 			\

+ 11
- 14
multimedia/gst1-plugins-base/patches/003-no_translations.patch Переглянути файл

@@ -1,7 +1,6 @@
1
-diff -u --recursive gst-plugins-base-1.0.7-vanilla/configure.ac gst-plugins-base-1.0.7/configure.ac
2
---- gst-plugins-base-1.0.7-vanilla/configure.ac	2013-06-01 19:48:21.931257133 -0500
3
-+++ gst-plugins-base-1.0.7/configure.ac	2013-06-01 19:51:30.371829534 -0500
4
-@@ -923,7 +923,6 @@
1
+--- a/configure.ac
2
++++ b/configure.ac
3
+@@ -918,7 +918,6 @@ docs/design/Makefile
5 4
  docs/libs/Makefile
6 5
  docs/plugins/Makefile
7 6
  docs/version.entities
@@ -9,10 +8,9 @@ diff -u --recursive gst-plugins-base-1.0.7-vanilla/configure.ac gst-plugins-base
9 8
  common/Makefile
10 9
  common/m4/Makefile
11 10
  m4/Makefile
12
-diff -u --recursive gst-plugins-base-1.0.7-vanilla/Makefile.am gst-plugins-base-1.0.7/Makefile.am
13
---- gst-plugins-base-1.0.7-vanilla/Makefile.am	2013-06-01 19:50:30.232202309 -0500
14
-+++ gst-plugins-base-1.0.7/Makefile.am	2013-06-01 19:50:58.973069965 -0500
15
-@@ -11,7 +11,6 @@
11
+--- a/Makefile.am
12
++++ b/Makefile.am
13
+@@ -11,7 +11,6 @@ SUBDIRS = 			\
16 14
  	gst-libs 		\
17 15
  	gst sys $(SUBDIRS_EXT) 	\
18 16
  	tools 			\
@@ -20,7 +18,7 @@ diff -u --recursive gst-plugins-base-1.0.7-vanilla/Makefile.am gst-plugins-base-
20 18
  	common 			\
21 19
  	m4
22 20
  
23
-@@ -20,7 +19,6 @@
21
+@@ -20,7 +19,6 @@ DIST_SUBDIRS = 			\
24 22
  	gst-libs		\
25 23
  	gst sys ext		\
26 24
  	tools 			\
@@ -28,10 +26,9 @@ diff -u --recursive gst-plugins-base-1.0.7-vanilla/Makefile.am gst-plugins-base-
28 26
  	common 			\
29 27
  	m4
30 28
  
31
-diff -u --recursive gst-plugins-base-1.0.7-vanilla/Makefile.in gst-plugins-base-1.0.7/Makefile.in
32
---- gst-plugins-base-1.0.7-vanilla/Makefile.in	2013-06-01 19:50:30.233202273 -0500
33
-+++ gst-plugins-base-1.0.7/Makefile.in	2013-06-01 19:51:22.796130711 -0500
34
-@@ -492,7 +492,6 @@
29
+--- a/Makefile.in
30
++++ b/Makefile.in
31
+@@ -538,7 +538,6 @@ SUBDIRS = \
35 32
  	gst-libs 		\
36 33
  	gst sys $(SUBDIRS_EXT) 	\
37 34
  	tools 			\
@@ -39,7 +36,7 @@ diff -u --recursive gst-plugins-base-1.0.7-vanilla/Makefile.in gst-plugins-base-
39 36
  	common 			\
40 37
  	m4
41 38
  
42
-@@ -501,7 +500,6 @@
39
+@@ -547,7 +546,6 @@ DIST_SUBDIRS = \
43 40
  	gst-libs		\
44 41
  	gst sys ext		\
45 42
  	tools 			\

+ 4
- 4
multimedia/gst1-plugins-good/Makefile Переглянути файл

@@ -8,8 +8,8 @@
8 8
 include $(TOPDIR)/rules.mk
9 9
 
10 10
 PKG_NAME:=gst1-plugins-good
11
-PKG_VERSION:=1.4.4
12
-PKG_RELEASE:=2
11
+PKG_VERSION:=1.4.5
12
+PKG_RELEASE:=1
13 13
 
14 14
 PKG_MAINTAINER:=W. Michael Petullo <mike@flyn.org>
15 15
 
@@ -19,9 +19,9 @@ PKG_LICENSE_FILES:=COPYING
19 19
 PKG_BUILD_DIR:=$(BUILD_DIR)/gst-plugins-good-$(PKG_VERSION)
20 20
 PKG_SOURCE:=gst-plugins-good-$(PKG_VERSION).tar.xz
21 21
 PKG_SOURCE_URL:=http://gstreamer.freedesktop.org/src/gst-plugins-good/
22
-PKG_MD5SUM:=673cf9276952bd3937dafd817c9ead2b
22
+PKG_MD5SUM:=eaf1a6daf73749bc423feac301d60038
23 23
 
24
-PKG_BUILD_DEPENDS:= libgstreamer1 gstreamer1-plugins-base liboil
24
+PKG_BUILD_DEPENDS:= libgstreamer1 gstreamer1-plugins-base
25 25
 
26 26
 PKG_FIXUP:=autoreconf
27 27
 PKG_INSTALL:=1

+ 6
- 8
multimedia/gst1-plugins-good/patches/001-no_docs.patch Переглянути файл

@@ -1,7 +1,6 @@
1
-diff -u --recursive gst-plugins-good-1.0.7-vanilla/Makefile.am gst-plugins-good-1.0.7/Makefile.am
2
---- gst-plugins-good-1.0.7-vanilla/Makefile.am	2013-06-01 19:54:57.652601127 -0500
3
-+++ gst-plugins-good-1.0.7/Makefile.am	2013-06-01 19:55:15.281902215 -0500
4
-@@ -3,7 +3,6 @@
1
+--- a/Makefile.am
2
++++ b/Makefile.am
3
+@@ -3,7 +3,6 @@ DISTCHECK_CONFIGURE_FLAGS=--enable-gtk-d
5 4
  ALWAYS_SUBDIRS =		\
6 5
  	gst sys ext 		\
7 6
  	tests			\
@@ -9,10 +8,9 @@ diff -u --recursive gst-plugins-good-1.0.7-vanilla/Makefile.am gst-plugins-good-
9 8
  	po			\
10 9
  	common			\
11 10
  	m4			\
12
-diff -u --recursive gst-plugins-good-1.0.7-vanilla/Makefile.in gst-plugins-good-1.0.7/Makefile.in
13
---- gst-plugins-good-1.0.7-vanilla/Makefile.in	2013-06-01 19:54:57.692599541 -0500
14
-+++ gst-plugins-good-1.0.7/Makefile.in	2013-06-01 19:55:23.025595255 -0500
15
-@@ -523,7 +523,6 @@
11
+--- a/Makefile.in
12
++++ b/Makefile.in
13
+@@ -571,7 +571,6 @@ DISTCHECK_CONFIGURE_FLAGS = --enable-gtk
16 14
  ALWAYS_SUBDIRS = \
17 15
  	gst sys ext 		\
18 16
  	tests			\

+ 6
- 8
multimedia/gst1-plugins-good/patches/002-no_tests.patch Переглянути файл

@@ -1,7 +1,6 @@
1
-diff -u --recursive gst-plugins-good-1.0.7-vanilla/Makefile.am gst-plugins-good-1.0.7/Makefile.am
2
---- gst-plugins-good-1.0.7-vanilla/Makefile.am	2013-06-01 19:56:00.995090476 -0500
3
-+++ gst-plugins-good-1.0.7/Makefile.am	2013-06-01 19:56:12.911618318 -0500
4
-@@ -2,7 +2,6 @@
1
+--- a/Makefile.am
2
++++ b/Makefile.am
3
+@@ -2,7 +2,6 @@ DISTCHECK_CONFIGURE_FLAGS=--enable-gtk-d
5 4
  
6 5
  ALWAYS_SUBDIRS =		\
7 6
  	gst sys ext 		\
@@ -9,10 +8,9 @@ diff -u --recursive gst-plugins-good-1.0.7-vanilla/Makefile.am gst-plugins-good-
9 8
  	po			\
10 9
  	common			\
11 10
  	m4			\
12
-diff -u --recursive gst-plugins-good-1.0.7-vanilla/Makefile.in gst-plugins-good-1.0.7/Makefile.in
13
---- gst-plugins-good-1.0.7-vanilla/Makefile.in	2013-06-01 19:56:00.995090476 -0500
14
-+++ gst-plugins-good-1.0.7/Makefile.in	2013-06-01 19:56:16.655469989 -0500
15
-@@ -522,7 +522,6 @@
11
+--- a/Makefile.in
12
++++ b/Makefile.in
13
+@@ -570,7 +570,6 @@ top_srcdir = @top_srcdir@
16 14
  DISTCHECK_CONFIGURE_FLAGS = --enable-gtk-doc
17 15
  ALWAYS_SUBDIRS = \
18 16
  	gst sys ext 		\

+ 9
- 12
multimedia/gst1-plugins-good/patches/003-no_translations.patch Переглянути файл

@@ -1,7 +1,6 @@
1
-diff -u --recursive gst-plugins-good-1.0.7-vanilla/configure.ac gst-plugins-good-1.0.7/configure.ac
2
---- gst-plugins-good-1.0.7-vanilla/configure.ac	2013-06-01 19:56:23.004218467 -0500
3
-+++ gst-plugins-good-1.0.7/configure.ac	2013-06-01 19:56:52.919033496 -0500
4
-@@ -1157,7 +1157,6 @@
1
+--- a/configure.ac
2
++++ b/configure.ac
3
+@@ -1083,7 +1083,6 @@ sys/sunaudio/Makefile
5 4
  sys/v4l2/Makefile
6 5
  sys/waveform/Makefile
7 6
  sys/ximage/Makefile
@@ -9,10 +8,9 @@ diff -u --recursive gst-plugins-good-1.0.7-vanilla/configure.ac gst-plugins-good
9 8
  tests/Makefile
10 9
  tests/check/Makefile
11 10
  tests/examples/Makefile
12
-diff -u --recursive gst-plugins-good-1.0.7-vanilla/Makefile.am gst-plugins-good-1.0.7/Makefile.am
13
---- gst-plugins-good-1.0.7-vanilla/Makefile.am	2013-06-01 19:56:23.043216922 -0500
14
-+++ gst-plugins-good-1.0.7/Makefile.am	2013-06-01 19:56:43.671399777 -0500
15
-@@ -2,7 +2,6 @@
11
+--- a/Makefile.am
12
++++ b/Makefile.am
13
+@@ -2,7 +2,6 @@ DISTCHECK_CONFIGURE_FLAGS=--enable-gtk-d
16 14
  
17 15
  ALWAYS_SUBDIRS =		\
18 16
  	gst sys ext 		\
@@ -20,10 +18,9 @@ diff -u --recursive gst-plugins-good-1.0.7-vanilla/Makefile.am gst-plugins-good-
20 18
  	common			\
21 19
  	m4			\
22 20
  	pkgconfig
23
-diff -u --recursive gst-plugins-good-1.0.7-vanilla/Makefile.in gst-plugins-good-1.0.7/Makefile.in
24
---- gst-plugins-good-1.0.7-vanilla/Makefile.in	2013-06-01 19:56:23.043216922 -0500
25
-+++ gst-plugins-good-1.0.7/Makefile.in	2013-06-01 19:56:47.703240080 -0500
26
-@@ -522,7 +522,6 @@
21
+--- a/Makefile.in
22
++++ b/Makefile.in
23
+@@ -570,7 +570,6 @@ top_srcdir = @top_srcdir@
27 24
  DISTCHECK_CONFIGURE_FLAGS = --enable-gtk-doc
28 25
  ALWAYS_SUBDIRS = \
29 26
  	gst sys ext 		\

+ 4
- 4
multimedia/gst1-plugins-ugly/Makefile Переглянути файл

@@ -1,5 +1,5 @@
1 1
 #
2
-# Copyright (C) 2009-2014 OpenWrt.org
2
+# Copyright (C) 2009-2015 OpenWrt.org
3 3
 #
4 4
 # This is free software, licensed under the GNU General Public License v2.
5 5
 # See /LICENSE for more information.
@@ -8,7 +8,7 @@
8 8
 include $(TOPDIR)/rules.mk
9 9
 
10 10
 PKG_NAME:=gst1-plugins-ugly
11
-PKG_VERSION:=1.4.4
11
+PKG_VERSION:=1.4.5
12 12
 PKG_RELEASE:=1
13 13
 
14 14
 PKG_MAINTAINER:=W. Michael Petullo <mike@flyn.org>
@@ -19,9 +19,9 @@ PKG_LICENSE_FILES:=COPYING
19 19
 PKG_BUILD_DIR:=$(BUILD_DIR)/gst-plugins-ugly-$(PKG_VERSION)
20 20
 PKG_SOURCE:=gst-plugins-ugly-$(PKG_VERSION).tar.xz
21 21
 PKG_SOURCE_URL:=http://gstreamer.freedesktop.org/src/gst-plugins-ugly/
22
-PKG_MD5SUM:=abd832c5cab1a37fb1d9d15fb08e6e59
22
+PKG_MD5SUM:=6954beed7bb9a93e426dee543ff46393
23 23
 
24
-PKG_BUILD_DEPENDS:= libgstreamer1 gstreamer1-plugins-base liboil
24
+PKG_BUILD_DEPENDS:= libgstreamer1 gstreamer1-plugins-base
25 25
 PKG_CONFIG_DEPENDS:= \
26 26
 	CONFIG_PACKAGE_gst1-mod-asf \
27 27
 	CONFIG_PACKAGE_gst1-mod-lame \

+ 5
- 7
multimedia/gst1-plugins-ugly/patches/001-no_docs.patch Переглянути файл

@@ -1,6 +1,5 @@
1
-diff -u --recursive gst-plugins-ugly-1.0.7-vanilla/Makefile.am gst-plugins-ugly-1.0.7/Makefile.am
2
---- gst-plugins-ugly-1.0.7-vanilla/Makefile.am	2013-06-01 19:58:12.400886469 -0500
3
-+++ gst-plugins-ugly-1.0.7/Makefile.am	2013-06-01 19:58:33.306059047 -0500
1
+--- a/Makefile.am
2
++++ b/Makefile.am
4 3
 @@ -1,7 +1,7 @@
5 4
  DISTCHECK_CONFIGURE_FLAGS=--enable-gtk-doc
6 5
  
@@ -10,10 +9,9 @@ diff -u --recursive gst-plugins-ugly-1.0.7-vanilla/Makefile.am gst-plugins-ugly-
10 9
  
11 10
  # include before EXTRA_DIST for win32 assignment
12 11
  include $(top_srcdir)/common/win32.mak
13
-diff -u --recursive gst-plugins-ugly-1.0.7-vanilla/Makefile.in gst-plugins-ugly-1.0.7/Makefile.in
14
---- gst-plugins-ugly-1.0.7-vanilla/Makefile.in	2013-06-01 19:58:12.412885994 -0500
15
-+++ gst-plugins-ugly-1.0.7/Makefile.in	2013-06-01 19:58:39.810801615 -0500
16
-@@ -453,7 +453,7 @@
12
+--- a/Makefile.in
13
++++ b/Makefile.in
14
+@@ -502,7 +502,7 @@ top_builddir = @top_builddir@
17 15
  top_srcdir = @top_srcdir@
18 16
  DISTCHECK_CONFIGURE_FLAGS = --enable-gtk-doc
19 17
  SUBDIRS = \

+ 5
- 7
multimedia/gst1-plugins-ugly/patches/002-no_tests.patch Переглянути файл

@@ -1,6 +1,5 @@
1
-diff -u --recursive gst-plugins-ugly-1.0.7-vanilla/Makefile.am gst-plugins-ugly-1.0.7/Makefile.am
2
---- gst-plugins-ugly-1.0.7-vanilla/Makefile.am	2013-06-01 19:59:16.988330482 -0500
3
-+++ gst-plugins-ugly-1.0.7/Makefile.am	2013-06-01 19:59:28.455876771 -0500
1
+--- a/Makefile.am
2
++++ b/Makefile.am
4 3
 @@ -1,7 +1,7 @@
5 4
  DISTCHECK_CONFIGURE_FLAGS=--enable-gtk-doc
6 5
  
@@ -10,10 +9,9 @@ diff -u --recursive gst-plugins-ugly-1.0.7-vanilla/Makefile.am gst-plugins-ugly-
10 9
  
11 10
  # include before EXTRA_DIST for win32 assignment
12 11
  include $(top_srcdir)/common/win32.mak
13
-diff -u --recursive gst-plugins-ugly-1.0.7-vanilla/Makefile.in gst-plugins-ugly-1.0.7/Makefile.in
14
---- gst-plugins-ugly-1.0.7-vanilla/Makefile.in	2013-06-01 19:59:16.988330482 -0500
15
-+++ gst-plugins-ugly-1.0.7/Makefile.in	2013-06-01 19:59:39.840426385 -0500
16
-@@ -453,7 +453,7 @@
12
+--- a/Makefile.in
13
++++ b/Makefile.in
14
+@@ -502,7 +502,7 @@ top_builddir = @top_builddir@
17 15
  top_srcdir = @top_srcdir@
18 16
  DISTCHECK_CONFIGURE_FLAGS = --enable-gtk-doc
19 17
  SUBDIRS = \

+ 8
- 11
multimedia/gst1-plugins-ugly/patches/003-no_translations.patch Переглянути файл

@@ -1,7 +1,6 @@
1
-diff -u --recursive gst-plugins-ugly-1.0.7-vanilla/configure.ac gst-plugins-ugly-1.0.7/configure.ac
2
---- gst-plugins-ugly-1.0.7-vanilla/configure.ac	2013-06-01 19:59:46.199174835 -0500
3
-+++ gst-plugins-ugly-1.0.7/configure.ac	2013-06-01 20:00:29.709453831 -0500
4
-@@ -479,7 +479,6 @@
1
+--- a/configure.ac
2
++++ b/configure.ac
3
+@@ -475,7 +475,6 @@ docs/version.entities
5 4
  tests/Makefile
6 5
  tests/check/Makefile
7 6
  m4/Makefile
@@ -9,9 +8,8 @@ diff -u --recursive gst-plugins-ugly-1.0.7-vanilla/configure.ac gst-plugins-ugly
9 8
  pkgconfig/Makefile
10 9
  pkgconfig/gstreamer-plugins-ugly-uninstalled.pc
11 10
  gst-plugins-ugly.spec
12
-diff -u --recursive gst-plugins-ugly-1.0.7-vanilla/Makefile.am gst-plugins-ugly-1.0.7/Makefile.am
13
---- gst-plugins-ugly-1.0.7-vanilla/Makefile.am	2013-06-01 19:59:46.210174399 -0500
14
-+++ gst-plugins-ugly-1.0.7/Makefile.am	2013-06-01 20:00:11.351179921 -0500
11
+--- a/Makefile.am
12
++++ b/Makefile.am
15 13
 @@ -1,7 +1,7 @@
16 14
  DISTCHECK_CONFIGURE_FLAGS=--enable-gtk-doc
17 15
  
@@ -21,10 +19,9 @@ diff -u --recursive gst-plugins-ugly-1.0.7-vanilla/Makefile.am gst-plugins-ugly-
21 19
  
22 20
  # include before EXTRA_DIST for win32 assignment
23 21
  include $(top_srcdir)/common/win32.mak
24
-diff -u --recursive gst-plugins-ugly-1.0.7-vanilla/Makefile.in gst-plugins-ugly-1.0.7/Makefile.in
25
---- gst-plugins-ugly-1.0.7-vanilla/Makefile.in	2013-06-01 19:59:46.210174399 -0500
26
-+++ gst-plugins-ugly-1.0.7/Makefile.in	2013-06-01 20:00:20.222829049 -0500
27
-@@ -453,7 +453,7 @@
22
+--- a/Makefile.in
23
++++ b/Makefile.in
24
+@@ -502,7 +502,7 @@ top_builddir = @top_builddir@
28 25
  top_srcdir = @top_srcdir@
29 26
  DISTCHECK_CONFIGURE_FLAGS = --enable-gtk-doc
30 27
  SUBDIRS = \

+ 4
- 4
multimedia/gstreamer1/Makefile Переглянути файл

@@ -1,5 +1,5 @@
1 1
 #
2
-# Copyright (C) 2008-2014 OpenWrt.org
2
+# Copyright (C) 2008-2015 OpenWrt.org
3 3
 #
4 4
 # This is free software, licensed under the GNU General Public License v2.
5 5
 # See /LICENSE for more information.
@@ -8,8 +8,8 @@
8 8
 include $(TOPDIR)/rules.mk
9 9
 
10 10
 PKG_NAME:=gstreamer1
11
-PKG_VERSION:=1.4.4
12
-PKG_RELEASE:=2
11
+PKG_VERSION:=1.4.5
12
+PKG_RELEASE:=1
13 13
 
14 14
 PKG_MAINTAINER:=W. Michael Petullo <mike@flyn.org>
15 15
 
@@ -19,7 +19,7 @@ PKG_LICENSE_FILES:=COPYING
19 19
 PKG_BUILD_DIR:=$(BUILD_DIR)/gstreamer-$(PKG_VERSION)
20 20
 PKG_SOURCE:=gstreamer-$(PKG_VERSION).tar.xz
21 21
 PKG_SOURCE_URL:=http://gstreamer.freedesktop.org/src/gstreamer/
22
-PKG_MD5SUM:=98f4a6d45a28dd195144baef0244ba38
22
+PKG_MD5SUM:=88a9289c64a4950ebb4f544980234289
23 23
 
24 24
 PKG_FIXUP:=autoreconf
25 25
 PKG_REMOVE_FILES:=autogen.sh aclocal.m4

+ 7
- 9
multimedia/gstreamer1/patches/001-no_docs.patch Переглянути файл

@@ -1,7 +1,6 @@
1
-diff -u --recursive gstreamer-1.0.7-vanilla/Makefile.am gstreamer-1.0.7/Makefile.am
2
---- gstreamer-1.0.7-vanilla/Makefile.am	2013-06-01 18:47:44.498057069 -0500
3
-+++ gstreamer-1.0.7/Makefile.am	2013-06-01 19:01:41.634143861 -0500
4
-@@ -8,7 +8,6 @@
1
+--- a/Makefile.am
2
++++ b/Makefile.am
3
+@@ -8,7 +8,6 @@ aclocal_DATA = gst-element-check-@GST_AP
5 4
  
6 5
  SUBDIRS = pkgconfig \
7 6
  	gst libs plugins tests \
@@ -9,7 +8,7 @@ diff -u --recursive gstreamer-1.0.7-vanilla/Makefile.am gstreamer-1.0.7/Makefile
9 8
  	po \
10 9
  	m4 \
11 10
  	common
12
-@@ -20,7 +19,6 @@
11
+@@ -20,7 +19,6 @@ endif
13 12
  # These are all the possible subdirs
14 13
  DIST_SUBDIRS = pkgconfig \
15 14
  	gst libs plugins tools tests \
@@ -17,10 +16,9 @@ diff -u --recursive gstreamer-1.0.7-vanilla/Makefile.am gstreamer-1.0.7/Makefile
17 16
  	po \
18 17
  	m4 \
19 18
  	common
20
-diff -u --recursive gstreamer-1.0.7-vanilla/Makefile.in gstreamer-1.0.7/Makefile.in
21
---- gstreamer-1.0.7-vanilla/Makefile.in	2013-06-01 18:47:44.533056863 -0500
22
-+++ gstreamer-1.0.7/Makefile.in	2013-06-01 19:02:04.529246907 -0500
23
-@@ -508,13 +508,12 @@
19
+--- a/Makefile.in
20
++++ b/Makefile.in
21
+@@ -554,13 +554,12 @@ top_srcdir = @top_srcdir@
24 22
  DISTCHECK_CONFIGURE_FLAGS = --enable-gtk-doc --enable-docbook
25 23
  aclocaldir = $(datadir)/aclocal
26 24
  aclocal_DATA = gst-element-check-@GST_API_VERSION@.m4

+ 7
- 9
multimedia/gstreamer1/patches/002-no_tests.patch Переглянути файл

@@ -1,7 +1,6 @@
1
-diff -u --recursive gstreamer-1.0.7-vanilla/Makefile.am gstreamer-1.0.7/Makefile.am
2
---- gstreamer-1.0.7-vanilla/Makefile.am	2013-06-01 19:22:31.546496381 -0500
3
-+++ gstreamer-1.0.7/Makefile.am	2013-06-01 19:20:38.141070908 -0500
4
-@@ -7,7 +7,7 @@
1
+--- a/Makefile.am
2
++++ b/Makefile.am
3
+@@ -7,7 +7,7 @@ aclocaldir = $(datadir)/aclocal
5 4
  aclocal_DATA = gst-element-check-@GST_API_VERSION@.m4
6 5
  
7 6
  SUBDIRS = pkgconfig \
@@ -10,7 +9,7 @@ diff -u --recursive gstreamer-1.0.7-vanilla/Makefile.am gstreamer-1.0.7/Makefile
10 9
  	po \
11 10
  	m4 \
12 11
  	common
13
-@@ -18,7 +18,7 @@
12
+@@ -18,7 +18,7 @@ endif
14 13
  
15 14
  # These are all the possible subdirs
16 15
  DIST_SUBDIRS = pkgconfig \
@@ -19,10 +18,9 @@ diff -u --recursive gstreamer-1.0.7-vanilla/Makefile.am gstreamer-1.0.7/Makefile
19 18
  	po \
20 19
  	m4 \
21 20
  	common
22
-diff -u --recursive gstreamer-1.0.7-vanilla/Makefile.in gstreamer-1.0.7/Makefile.in
23
---- gstreamer-1.0.7-vanilla/Makefile.in	2013-06-01 19:22:31.547496342 -0500
24
-+++ gstreamer-1.0.7/Makefile.in	2013-06-01 19:20:48.948632307 -0500
25
-@@ -508,12 +508,12 @@
21
+--- a/Makefile.in
22
++++ b/Makefile.in
23
+@@ -554,12 +554,12 @@ top_srcdir = @top_srcdir@
26 24
  DISTCHECK_CONFIGURE_FLAGS = --enable-gtk-doc --enable-docbook
27 25
  aclocaldir = $(datadir)/aclocal
28 26
  aclocal_DATA = gst-element-check-@GST_API_VERSION@.m4

+ 10
- 13
multimedia/gstreamer1/patches/003-no_translations.patch Переглянути файл

@@ -1,7 +1,6 @@
1
-diff -u --recursive gstreamer-1.0.7-vanilla/configure.ac gstreamer-1.0.7/configure.ac
2
---- gstreamer-1.0.7-vanilla/configure.ac	2013-06-01 18:47:44.506057110 -0500
3
-+++ gstreamer-1.0.7/configure.ac	2013-06-01 19:24:05.035756124 -0500
4
-@@ -769,7 +769,6 @@
1
+--- a/configure.ac
2
++++ b/configure.ac
3
+@@ -780,7 +780,6 @@ libs/gst/helpers/Makefile
5 4
  libs/gst/net/Makefile
6 5
  plugins/Makefile
7 6
  plugins/elements/Makefile
@@ -9,10 +8,9 @@ diff -u --recursive gstreamer-1.0.7-vanilla/configure.ac gstreamer-1.0.7/configu
9 8
  tests/Makefile
10 9
  tests/benchmarks/Makefile
11 10
  tests/check/Makefile
12
-diff -u --recursive gstreamer-1.0.7-vanilla/Makefile.am gstreamer-1.0.7/Makefile.am
13
---- gstreamer-1.0.7-vanilla/Makefile.am	2013-06-01 19:23:08.361020919 -0500
14
-+++ gstreamer-1.0.7/Makefile.am	2013-06-01 19:24:15.036357308 -0500
15
-@@ -8,7 +8,6 @@
11
+--- a/Makefile.am
12
++++ b/Makefile.am
13
+@@ -8,7 +8,6 @@ aclocal_DATA = gst-element-check-@GST_AP
16 14
  
17 15
  SUBDIRS = pkgconfig \
18 16
  	gst libs plugins \
@@ -20,7 +18,7 @@ diff -u --recursive gstreamer-1.0.7-vanilla/Makefile.am gstreamer-1.0.7/Makefile
20 18
  	m4 \
21 19
  	common
22 20
  
23
-@@ -19,7 +18,6 @@
21
+@@ -19,7 +18,6 @@ endif
24 22
  # These are all the possible subdirs
25 23
  DIST_SUBDIRS = pkgconfig \
26 24
  	gst libs plugins tools \
@@ -28,10 +26,9 @@ diff -u --recursive gstreamer-1.0.7-vanilla/Makefile.am gstreamer-1.0.7/Makefile
28 26
  	m4 \
29 27
  	common
30 28
  
31
-diff -u --recursive gstreamer-1.0.7-vanilla/Makefile.in gstreamer-1.0.7/Makefile.in
32
---- gstreamer-1.0.7-vanilla/Makefile.in	2013-06-01 19:23:08.362020867 -0500
33
-+++ gstreamer-1.0.7/Makefile.in	2013-06-01 19:24:27.907844191 -0500
34
-@@ -508,13 +508,12 @@
29
+--- a/Makefile.in
30
++++ b/Makefile.in
31
+@@ -554,13 +554,12 @@ top_srcdir = @top_srcdir@
35 32
  DISTCHECK_CONFIGURE_FLAGS = --enable-gtk-doc --enable-docbook
36 33
  aclocaldir = $(datadir)/aclocal
37 34
  aclocal_DATA = gst-element-check-@GST_API_VERSION@.m4