Browse Source

sqm-scripts: Modify installation step to ensure correct file permissions

Use INSTALL_BIN & INSTALL_DATA macros instead of cp
to ensure correct file permissions for the executable files.

Signed-off-by: Hannu Nyman <hannu.nyman@iki.fi>
Hannu Nyman 10 years ago
parent
commit
0f0b241d56
1 changed files with 9 additions and 3 deletions
  1. 9
    3
      net/sqm-scripts/Makefile

+ 9
- 3
net/sqm-scripts/Makefile View File

@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
9 9
 
10 10
 PKG_NAME:=sqm-scripts
11 11
 PKG_VERSION:=7
12
-PKG_RELEASE:=2
12
+PKG_RELEASE:=3
13 13
 PKG_LICENSE:=GPLv2
14 14
 
15 15
 PKG_BUILD_DIR := $(BUILD_DIR)/$(PKG_NAME)
@@ -44,8 +44,14 @@ define Build/Compile
44 44
 endef
45 45
 
46 46
 define Package/sqm-scripts/install
47
-	$(INSTALL_DIR) $(1)
48
-	$(CP) ./files/* $(1)/
47
+	$(INSTALL_DIR) $(1)/etc/init.d
48
+	$(INSTALL_BIN) ./files/etc/init.d/sqm $(1)/etc/init.d/sqm
49
+	$(INSTALL_DIR) $(1)/etc/config
50
+	$(INSTALL_DATA) ./files/etc/config/sqm $(1)/etc/config/sqm
51
+	$(INSTALL_DIR) $(1)/usr/lib/sqm
52
+	$(INSTALL_BIN) ./files/usr/lib/sqm/*.sh $(1)/usr/lib/sqm/
53
+	$(INSTALL_BIN) ./files/usr/lib/sqm/*.qos $(1)/usr/lib/sqm/
54
+	$(INSTALL_DATA) ./files/usr/lib/sqm/*.help $(1)/usr/lib/sqm/
49 55
 endef
50 56
 
51 57
 $(eval $(call BuildPackage,sqm-scripts))