Bläddra i källkod

joe: add a new package to the build tree

Joe is world-famous Wordstar like text editor,
that also features Emacs and Pico emulation

Signed-off-by: Vitaly Protsko <villy@sft.ru>
---
 Makefile                   |   63 ++++
 files/joerc                |  621 +++++++++++++++++++++++++++++++++++++++++++++
 patches/001-mathaway.patch |   58 ++++
 3 files changed, 742 insertions(+)
aTanW 10 år sedan
förälder
incheckning
0f0cdec0b9
3 ändrade filer med 742 tillägg och 0 borttagningar
  1. 63
    0
      utils/joe/Makefile
  2. 621
    0
      utils/joe/files/joerc
  3. 58
    0
      utils/joe/patches/001-mathaway.patch

+ 63
- 0
utils/joe/Makefile Visa fil

@@ -0,0 +1,63 @@
1
+#
2
+# Copyright (C) 2007-2014 OpenWrt.org
3
+#
4
+# This is free software, licensed under the GNU General Public License v2.
5
+# See /LICENSE for more information.
6
+#
7
+
8
+# changes by David Kuehling <dvdkhlng TA gmx TOD de>:
9
+#
10
+#  - include support for all emulation modes jmacs jpico etc.
11
+#  - see patches/002-builtinrc.patch
12
+#
13
+# changes by Vitaly Prosko <villy TA sft TOD ru>:
14
+#
15
+#  - updated for new build system rules
16
+#  - added static joerc config - no more defaults for native mode
17
+#  - got maintenance role
18
+#
19
+
20
+include $(TOPDIR)/rules.mk
21
+
22
+PKG_NAME:=joe
23
+PKG_VERSION:=3.7
24
+PKG_RELEASE:=3
25
+
26
+PKG_SOURCE_URL:=@SF/joe-editor
27
+PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
28
+PKG_MD5SUM:=66de1b073e869ba12abbfcde3885c577
29
+PKG_BUILD_DIR=$(BUILD_DIR)/$(PKG_NAME)-$(PKG_VERSION)
30
+PKG_MAINTAINER:=Vitaly Protsko <villy@sft.ru>
31
+PKG_LICENCE:=GPL-1.0
32
+
33
+include $(INCLUDE_DIR)/package.mk
34
+
35
+define Package/joe
36
+  SECTION:=utils
37
+  CATEGORY:=Utilities
38
+  SUBMENU:=Editors
39
+  TITLE:=JOE - Joes own editor
40
+  URL:=http://sourceforge.net/projects/joe-editor/
41
+  DEPENDS:=+libncurses
42
+endef
43
+
44
+define Package/joe/description
45
+Joe is world-famous Wordstar like text editor, that also features
46
+Emacs and Pico emulation
47
+endef
48
+
49
+define Package/joe/install
50
+	$(INSTALL_DIR) $(1)/usr/bin
51
+	$(INSTALL_BIN) $(PKG_BUILD_DIR)/joe $(1)/usr/bin/
52
+	for i in jmacs jstar rjoe jpico; do \
53
+	  ln -sf joe $(1)/usr/bin/$$$$i; \
54
+	done
55
+	$(INSTALL_DIR) $(1)/etc/joe
56
+	$(INSTALL_CONF) ./files/joerc $(1)/etc/joe/joerc
57
+endef
58
+
59
+define Package/joe/conffiles
60
+/etc/joe/joerc
61
+endef
62
+
63
+$(eval $(call BuildPackage,joe))

+ 621
- 0
utils/joe/files/joerc Visa fil

@@ -0,0 +1,621 @@
1
+
2
+-asis
3
+-nobackups
4
+-nonotice
5
+-noxon
6
+-notite
7
+-assume_color
8
+-assume_256color
9
+-guess_non_utf8
10
+-guess_crlf
11
+-guess_indent
12
+-menu_above
13
+-transpose
14
+-joe_state
15
+-restore
16
+-mouse
17
+-joexterm
18
+-search_prompting
19
+-lmsg \i%k%T%W%I%X %n %m%y%R %M %x
20
+-rmsg  %S Row %r Col %c %t  Ctrl-K H for help
21
+-highlight
22
+-istep 2
23
+
24
+ :include ftyperc
25
+
26
+:defmenu root
27
+mode,"overwrite",rtn	T Overtype %Zoverwrite%
28
+mode,"hex",rtn	% % Hex edit mode
29
+mode,"autoindent",rtn	I Autoindent %Zautoindent%
30
+mode,"wordwrap",rtn	W Word wrap %Zwordwrap%
31
+mode,"tab",rtn	D Tab width %Ztab%
32
+mode,"lmargin",rtn	L Left margin %Zlmargin%
33
+mode,"rmargin",rtn	R Right margin %Zrmargin%
34
+mode,"square",rtn	X Rectangle mode %Zsquare%
35
+mode,"indentc",rtn	% % Indent char %Zindentc%
36
+mode,"istep",rtn	% % Indent step %Zistep%
37
+mode,"highlight",rtn	H Highlighting %Zhighlight%
38
+mode,"crlf",rtn	Z CR-LF (MS-DOS) %Zcrlf%
39
+mode,"linums",rtn	N Line numbers %Zlinums%
40
+mode,"beep",rtn	B Beep %Zbeep%
41
+mode,"rdonly",rtn	O Read only %Zrdonly%
42
+ mode,"syntax",rtn	Y Syntax
43
+mode,"encoding",rtn	E Encoding
44
+mode,"asis",rtn	% % Meta chars as-is
45
+mode,"language",rtn	V Language
46
+mode,"picture",rtn	P picture %Zpicture%
47
+menu,"more-options",rtn	  % % More options...
48
+
49
+:defmenu more-options
50
+menu,"^G",rtn	% % ^G options
51
+menu,"search",rtn	% % search options
52
+menu,"paragraph",rtn	% % paragraph options
53
+menu,"file",rtn	% % file options
54
+menu,"menu",rtn	% % menu options
55
+menu,"global",rtn	% % global options
56
+menu,"cursor",rtn	% % cursor options
57
+menu,"marking",rtn	% % marking options
58
+menu,"tab",rtn	% % tab/indent options
59
+
60
+:defmenu menu
61
+mode,"menu_explorer",rtn	% % Menu explorer %Zmenu_explorer%
62
+mode,"menu_above",rtn	% % Menu position %Zmenu_above%
63
+mode,"menu_jump",rtn	% % Jump into menu %Zmenu_jump%
64
+mode,"transpose",rtn	% % Transpose menus %Ztranspose%
65
+
66
+:defmenu ^G
67
+mode,"single_quoted",rtn	% % ^G ignores '...' %Zsingle_quoted%
68
+mode,"no_double_quoted",rtn	% % ^G no ignore "..." %Zno_double_quoted%
69
+mode,"c_comment",rtn	% % ^G ignores /*...*/ %Zc_comment%
70
+mode,"cpp_comment",rtn	% % ^G ignores //... %Zcpp_comment%
71
+mode,"pound_comment",rtn	% % ^G ignores #... %Zpound_comment%
72
+mode,"vhdl_comment",rtn	% % ^G ignores --... %Zvhdl_comment%
73
+mode,"semi_comment",rtn	% % ^G ignores ;... %Zsemi_comment%
74
+mode,"tex_comment",rtn % % ^G ignores %... %Ztex_comment%
75
+mode,"text_delimiters",rtn % % Text delimiters %Ztext_delimiters%
76
+
77
+:defmenu search
78
+mode,"icase",rtn	% % Case insensitivity %Zicase%
79
+mode,"wrap",rtn	% % Search wraps %Zwrap%
80
+mode,"search_prompting",rtn	% % Search prompting %Zsearch_prompting%
81
+mode,"csmode",rtn	% % Continued search %Zcsmode%
82
+
83
+:defmenu paragraph
84
+mode,"french",rtn	% % French spacing %Zfrench%
85
+mode,"flowed",rtn	% % Flowed text %Zflowed%
86
+mode,"cpara",rtn	% % Paragraph indent chars %Zcpara%
87
+
88
+:defmenu file
89
+mode,"restore",rtn	% % Restore cursor %Zrestore%
90
+mode,"guess_crlf",rtn	% % Auto detect CR-LF %Zguess_crlf%
91
+mode,"guess_indent",rtn	% % Guess indent %Zguess_indent%
92
+mode,"guess_non_utf8",rtn	% % Guess non-UTF-8 %Zguess_non_utf8%
93
+mode,"guess_utf8",rtn	% % Guess UTF-8 %Zguess_utf8%
94
+mode,"force",rtn	% % Force last NL %Zforce%
95
+mode,"nobackup",rtn	% % No backup %Znobackup%
96
+
97
+:defmenu global
98
+mode,"nolocks",rtn	% % Disable locks %Znolocks%
99
+mode,"nobackups",rtn	% % Disable backups %Znobackups%
100
+mode,"nomodcheck",rtn	% % Disable mtime check %Znomodcheck%
101
+mode,"nocurdir",rtn	% % Disable current dir %Znocurdir%
102
+mode,"exask",rtn	% % Exit ask %Zexask%
103
+mode,"nosta",rtn	% % Disable status line %Znosta%
104
+mode,"keepup",rtn	% % Fast status line %Zkeepup%
105
+mode,"break_hardlinks",rtn	% % Break hard links %Zbreak_hardlinks%
106
+mode,"break_links",rtn	% % Break links %Zbreak_links%
107
+mode,"joe_state",rtn	% % Joe_state file %Zjoe_state%
108
+mode,"undo_keep",rtn	% % No. undo records %Zundo_keep%
109
+mode,"backpath",rtn	% % Path to backup files %Zbackpath%
110
+
111
+:defmenu cursor
112
+mode,"pg",rtn	% % No. PgUp/PgDn lines %Zpg%
113
+mode,"mid",rtn	C Center on scroll %Zmid%
114
+mode,"floatmouse",rtn	% % Click past end %Zfloatmouse%
115
+mode,"rtbutton",rtn	% % Right button %Zrtbutton%
116
+
117
+:defmenu marking
118
+mode,"autoswap",rtn	% % Autoswap mode %Zautoswap%
119
+mode,"marking",rtn	% % Marking %Zmarking%
120
+mode,"lightoff",rtn	% % Auto unmask %Zlightoff%
121
+
122
+:defmenu tab
123
+mode,"smarthome",rtn	% % Smart home key %Zsmarthome%
124
+mode,"smartbacks",rtn	% % Smart backspace %Zsmartbacks%
125
+mode,"indentfirst",rtn	% % To indent first %Zindentfirst%
126
+mode,"purify",rtn	% % Clean up indents %Zpurify%
127
+mode,"spaces",rtn	% % No tabs %Zspaces%
128
+
129
+{Basic
130
+\i   Help Screen    \|turn off with ^KH    more help with ESC . (^[.)              \i
131
+\i \i\|\uCURSOR\u           \|\uGO TO\u            \|\uBLOCK\u      \|\uDELETE\u   \|\uMISC\u         \|\uEXIT\u      \|\i \i
132
+\i \i\|^B left ^F right \|^U  prev. screen \|^KB begin  \|^D char. \|^KJ reformat \|^KX save  \|\i \i
133
+\i \i\|^P up   ^N down  \|^V  next screen  \|^KK end    \|^Y line  \|^KA center   \|^C  abort \|\i \i
134
+\i \i\|^Z previous word \|^A  beg. of line \|^KM move   \|^W >word \|^T  options  \|^KZ shell \|\i \i
135
+\i \i\|^X next word     \|^E  end of line  \|^KC copy   \|^O word< \|^R  refresh  \|\uFILE\u      \|\i \i
136
+\i \i\|\uSEARCH\u           \|^KU top of file  \|^KW file   \|^J >line \|\uSPELL\u        \|^KE edit  \|\i \i
137
+\i \i\|^KF find text    \|^KV end of file  \|^KY delete \|^_ undo  \|^[N word     \|^KR insert\|\i \i
138
+\i \i\|^L  find next    \|^KL to line No.  \|^K/ filter \|^^ redo  \|^[L file     \|^KD save  \|\i \i
139
+}
140
+
141
+{Windows
142
+\i   Help Screen    \|turn off with ^KH    prev. screen ^[,    next screen ^[.     \i
143
+\i \i\|^KO Split the window in half           \|^KE Load file into window             \|\i \i
144
+\i \i\|^KG Make current window bigger         \|^KT Make current window smaller       \|\i \i
145
+\i \i\|^KN Go to the window below             \|^KP Go to the window above            \|\i \i
146
+\i \i\|^[V Switch to next buffer              \|^[U Switch to previous buffer         \|\i \i
147
+\i \i\|^C  Eliminate the current window       \|^KI Show all windows / Show one window\|\i \i
148
+}
149
+
150
+{Advanced
151
+\i   Help Screen    \|turn off with ^KH    prev. screen ^[,    next screen ^[.     \i
152
+\i \i\|\uMACROS\u         \|\uMISC\u            \|\uSCROLL\u    \|\uSHELL\u       \|\uGOTO\u       \|\uI-SEARCH\u     \|\i \i
153
+\i \i\|^K[ 0-9 Record \|^K SPACE status \|^[W Up    \|^K' Window  \|^[B To ^KB \|^[R Backwards\|\i \i
154
+\i \i\|^K]     Stop   \|^K\\ Repeat      \|^[Z Down  \|^[! Command \|^[K To ^KK \|^[S Forwards \|\i \i
155
+\i \i\|^K 0-9  Play   \|\uINSERT\u          \|^K< Left  \|\uQUOTE\u       \|\uDELETE\u     \|\uBOOKMARKS\u    \|\i \i
156
+\i \i\|^K?     Query  \|^] split line   \|^K> Right \|^[' Ctrl-   \|^[Y yank   \|^[ 0-9 Goto  \|\i \i
157
+\i \i\|^[D     Dump   \|^SPACE ins space\|          \|^\\ Meta-    \|^[O line<  \|^[^[   Set   \|\i \i
158
+}
159
+
160
+{Programs
161
+\i   Help Screen    \|turn off with ^KH    prev. screen ^[,    next screen ^[.     \i
162
+\i \i\|\uGOTO\u                 \|\uINDENT\u   \|\uCOMPILING\u          \uQUICK\u                       \|\i \i
163
+\i \i\|^G  Matching ( [ {   \|^K, less \|^[C Compile & parse ^G  find word under cursor \|\i \i
164
+\i \i\|^K- Previous place   \|^K. more \|^[G Grep & parse    ^[ENTER complete word      \|\i \i
165
+\i \i\|^K= Next place       \|\uFILE\u     \|^[= To next error   ^[Y paste deleted text     \|\i \i
166
+\i \i\|^K; Tags file search \|^K `     \|^[- To prev. error  ^[^Y cycle through deleted \|\i \i
167
+\i \i\|                     \| revert  \|^[ SP Jump to error                            \|\i \i
168
+}
169
+
170
+{Search
171
+\i   Help Screen    \|turn off with ^KH    prev. screen ^[,    next screen ^[.     \i
172
+\i \iSpecial search sequences:                                                    \|\i \i
173
+\i \i    \\^  \\$  matches beg./end of line      \\?     match any single char       \|\i \i
174
+\i \i    \\<  \\>  matches beg./end of word      \\*     match 0 or more chars       \|\i \i
175
+\i \i    \\c      matches balanced C expression \\\\     matches a \\                 \|\i \i
176
+\i \i    \\[..]   matches one of a set          \\n     matches a newline           \|\i \i
177
+\i \i    \\+      matches 0 or more of the character which follows the \\+          \|\i \i
178
+\i \iSpecial replace sequences:                                                   \|\i \i
179
+\i \i    \\&      replaced with text which matched search string                   \|\i \i
180
+\i \i    \\0 - 9  replaced with text which matched Nth \\*, \\?, \\c, \\+, or \\[..]    \|\i \i
181
+\i \i    \\\\      replaced with \\               \\n     replaced with newline       \|\i \i
182
+}
183
+
184
+{SearchOptions
185
+\i   Help Screen    \|turn off with ^KH    prev. screen ^[,    next screen ^[.     \i
186
+\i \iSearch options:                                                              \|\i \i
187
+\i \i   r Replace                                                                 \|\i \i
188
+\i \i   k Restrict search to highlighted block, which can be rectangular          \|\i \i
189
+\i \i   b Search backward instead of forward                                      \|\i \i
190
+\i \i   i Ignore case                                                             \|\i \i
191
+\i \i   a Search across all loaded files                                          \|\i \i
192
+\i \i   e Search across all files in Grep or Compile error list                   \|\i \i
193
+\i \i   w Wrap to beginning of file for this search                               \|\i \i
194
+\i \i   n Do not wrap to beginning of file for this search                        \|\i \i
195
+\i \i   nnn Perform exaclty nnn replacements                                      \|\i \i
196
+}
197
+
198
+{Math
199
+\i   Help Screen    \|turn off with ^KH    prev. screen ^[,    next screen ^[.     \i
200
+\i \i \uCOMMANDS\u (hit ESC m for math)  \uFUNCTIONS\u                                    \|\i \i
201
+\i \i     hex hex display mode       sin cos tab asin acos atan                   \|\i \i
202
+\i \i     dec decimal mode           sinh cosh tanh asinh acosh atanh             \|\i \i
203
+\i \i     ins type result into file  sqrt cbrt exp ln log                         \|\i \i
204
+\i \i    eval evaluate block         int floor ceil abs erg ergc                  \|\i \i
205
+\i \i    0xff enter number in hex    joe(..macro..) - runs an editor macro        \|\i \i
206
+\i \i    3e-4 floating point decimal \uBLOCK\u                                        \|\i \i
207
+\i \i    a=10 assign a variable      sum cnt  Sum, count                          \|\i \i
208
+\i \i 2+3:ins multiple commands      avg dev  Average, std. deviation             \|\i \i
209
+\i \i    e pi constants              \uOPERATORS\u                                    \|\i \i
210
+\i \i     ans previous result        ! ^  * / %  + -  < <= > >= == !=  &&  ||  ? :\|\i \i
211
+}
212
+
213
+{Names
214
+\i   Help Screen    \|turn off with ^KH    prev. screen ^[,    next screen ^[.     \i
215
+\i \i Hit TAB at file name prompts to generate menu of file names                 \|\i \i
216
+\i \i Or use up/down keys to access history of previously entered names           \|\i \i
217
+\i \i Special file names:                                                         \|\i \i
218
+\i \i      !command                 Pipe in/out of a shell command                \|\i \i
219
+\i \i      >>filename               Append to a file                              \|\i \i
220
+\i \i      -                        Read/Write to/from standard I/O               \|\i \i
221
+\i \i      filename,START,SIZE      Read/Write a part of a file/device            \|\i \i
222
+\i \i          Give START/SIZE in decimal (255), octal (0377) or hex (0xFF)       \|\i \i
223
+}
224
+
225
+{Joe
226
+\i   Help Screen    \|turn off with ^KH    prev. screen ^[,    next screen ^[.     \i
227
+\i \i Send bug reports to: http://sourceforge.net/projects/joe-editor \|\i \i
228
+\i \i \|\i \i
229
+\i \i  default joerc file is here /etc/joe/joerc \|\i \i
230
+\i \i  default syntax and i18n files are here /usr/share/joe \|\i \i
231
+\i \i  additional documentation can be found here /usr/share/doc/joe \|\i \i
232
+}
233
+
234
+{CharTable
235
+\i   Help Screen    \|turn off with ^KH    prev. screen ^[,                        \i
236
+\i \i\| Dec  \u 0123 4567  8901 2345    0123 4567  8901 2345 \u  Dec \|\i \i
237
+\i \i\|     |                                              |     \|\i \i
238
+\i \i\|   0 | \u@ABC\u \uDEFG\u  \uHIJK\u \uLMNO\u    \i\u@ABC\u\i \i\uDEFG\u\i  \i\uHIJK\u\i \i\uLMNO\u\i | 128 \|\i \i
239
+\i \i\|  16 | \uPQRS\u \uTUVW\u  \uXYZ[\u \u\\]^_\u    \i\uPQRS\u\i \i\uTUVW\u\i  \i\uXYZ[\u\i \i\u\\]^_\u\i | 144 \|\i \i
240
+\i \i\|  32 |  !"# $%&'  ()*+ ,-./    嵗╯ 丰戍  貝物 洎悖 | 160 \|\i \i
241
+\i \i\|  48 | 0123 4567  89:; <=>?    停眾 斯須  號獄 播噶 | 176 \|\i \i
242
+\i \i\|  64 | @ABC DEFG  HIJK LMNO    擱藏 霰匸  �帊 昅恘 | 192 \|\i \i
243
+\i \i\|  80 | PQRS TUVW  XYZ[ \\]^_    倳眑 婭笫  崷窙 嗲睧 | 208 \|\i \i
244
+\i \i\|  96 | `abc defg  hijk lmno    颬睼 麧緗  鴇膹 擨闀 | 224 \|\i \i
245
+\i \i\| 112 | pqrs tuvw  xyz{ |}~    貘覷 鏷禴  矙𡜍 𦶠� | 240 \|\i \i
246
+}
247
+
248
+:windows		Bindings common to all windows
249
+type		^@ TO �
250
+abort		^C
251
+abort		^K Q
252
+abort		^K ^Q
253
+abort		^K q
254
+arg		^K \
255
+explode		^K I
256
+explode		^K ^I
257
+explode		^K i
258
+help		^K H
259
+help		^K ^H
260
+help		^K h
261
+hnext		^[ .
262
+hprev		^[ ,
263
+math		^[ m
264
+math		^[ M
265
+msg		^[ h
266
+msg		^[ H
267
+msg		^[ ^H
268
+nextw		^K N
269
+nextw		^K ^N
270
+nextw		^K n
271
+pgdn		.kN
272
+pgdn		^V
273
+pgdn		^[ [ 6 ~
274
+pgup		.kP
275
+pgup		^U
276
+pgup		^[ [ 5 ~
277
+play		^K 0 TO 9
278
+prevw		^K P
279
+prevw		^K ^P
280
+prevw		^K p
281
+query		^K ?
282
+record		^K [
283
+retype		^R
284
+rtn		^M
285
+shell		^K Z
286
+shell		^K ^Z
287
+shell		^K z
288
+stop		^K ]
289
+
290
+defmdown	MDOWN
291
+defmup		MUP
292
+defmdrag	MDRAG
293
+defm2down	M2DOWN
294
+defm2up		M2UP
295
+defm2drag	M2DRAG
296
+defm3down	M3DOWN
297
+defm3up		M3UP
298
+defm3drag	M3DRAG
299
+
300
+xtmouse		^[ [ M
301
+
302
+if,"char==65",then,"it's an A",else,"it's not an a",endif	^[ q
303
+
304
+:main			Text editing window
305
+:inherit windows
306
+
307
+:def ispellfile filt,"cat >ispell.tmp;ispell ispell.tmp </dev/tty >/dev/tty;cat ispell.tmp;/bin/rm ispell.tmp",rtn,retype
308
+:def ispellword psh,nextword,markk,prevword,markb,filt,"cat >ispell.tmp;ispell ispell.tmp </dev/tty >/dev/tty;tr -d <ispell.tmp '\\012';/bin/rm ispell.tmp",rtn,retype,nextword
309
+
310
+:def aspellfile filt,"SPLTMP=ispell.tmp;cat >$SPLTMP;aspell --lang=",language,".",charset," -x -c $SPLTMP </dev/tty >/dev/tty;cat $SPLTMP;/bin/rm $SPLTMP",rtn,retype
311
+:def aspellword psh,nextword,markk,prevword,markb,filt,"SPLTMP=ispell.tmp;cat >$SPLTMP;aspell --lang=",language,".",charset," -x -c $SPLTMP </dev/tty >/dev/tty;tr -d <$SPLTMP '\\012';/bin/rm $SPLTMP",rtn,retype,nextword
312
+
313
+aspellfile	^[ l
314
+aspellword	^[ n
315
+
316
+:def compile mwind!,mfit!,querysave,query,scratch,"* Build Log *",rtn,bof,markb,eof," ",markk,blkdel,build
317
+
318
+:def grep_find mwind!,mfit!,scratch,"* Grep Log *",rtn,bof,markb,eof," ",markk,blkdel,grep
319
+
320
+:def man scratch,"* Man Page *",rtn,bof,markb,eof," ",markk,blkdel," ",ltarw,run,"man -P cat -S 2:3 "
321
+
322
+paste			^[ ] 5 2 ;
323
+
324
+insc			^[ [ 2 ~
325
+insc			^[ [ L
326
+
327
+delch			^[ [ 3 ~
328
+
329
+pgup			^[ [ I
330
+
331
+pgdn			^[ [ G
332
+
333
+home			^[ [ 1 ~
334
+home			^[ [ H
335
+home			^[ O H
336
+home			^[ [ 7 ~
337
+
338
+eol			^[ [ 4 ~
339
+eol			^[ [ F
340
+eol			^[ O F
341
+eol			^[ [ 8 ~
342
+
343
+rtarw,ltarw,begin_marking,rtarw,toggle_marking	^[ [ 1 ; 5 C
344
+rtarw,ltarw,begin_marking,rtarw,toggle_marking	^[ [ 5 C
345
+rtarw,ltarw,begin_marking,rtarw,toggle_marking	^[ O c
346
+
347
+ltarw,rtarw,begin_marking,ltarw,toggle_marking	^[ [ 1 ; 5 D
348
+ltarw,rtarw,begin_marking,ltarw,toggle_marking	^[ [ 5 D
349
+ltarw,rtarw,begin_marking,ltarw,toggle_marking	^[ O d
350
+
351
+uparw,dnarw,begin_marking,uparw,toggle_marking	^[ [ 1 ; 5 A
352
+uparw,dnarw,begin_marking,uparw,toggle_marking	^[ [ 5 A
353
+uparw,dnarw,begin_marking,uparw,toggle_marking	^[ O a
354
+
355
+dnarw,uparw,begin_marking,dnarw,toggle_marking	^[ [ 1 ; 5 B
356
+dnarw,uparw,begin_marking,dnarw,toggle_marking	^[ [ 5 B
357
+dnarw,uparw,begin_marking,dnarw,toggle_marking	^[ O b
358
+
359
+blkdel,nmark   ^[ [ 3 ; 5 -
360
+blkdel,nmark   ^[ [ 3 ; 5 ~
361
+
362
+yank		^[ [ 2 ; 5 -
363
+yank		^[ [ 2 ; 5 ~
364
+
365
+delbol		^[ o
366
+delbol		^[ ^O
367
+dnslide		^[ z
368
+dnslide		^[ Z
369
+dnslide		^[ ^Z
370
+dnslide,dnslide,dnslide,dnslide		MWDOWN
371
+compile		^[ c
372
+compile		^[ C
373
+compile		^[ ^C
374
+grep_find	^[ g
375
+grep_find	^[ G
376
+grep_find	^[ ^G
377
+execmd		^[ x
378
+execmd		^[ X
379
+execmd		^[ ^X
380
+finish		^[ ^I
381
+finish		^[ ^M
382
+mwind,mfit,jump,bol		^[ SP
383
+isrch		^[ s
384
+isrch		^[ S
385
+isrch		^[ ^S
386
+notmod		^[ ~
387
+mwind,mfit,prevw,nxterr		^[ =
388
+parserr		^[ e
389
+parserr		^[ E
390
+parserr		^[ ^E
391
+mwind,mfit,prevw,prverr		^[ -
392
+rsrch		^[ r
393
+rsrch		^[ R
394
+rsrch		^[ ^R
395
+run		^[ !
396
+tomarkb		^[ b
397
+tomarkb		^[ ^B
398
+tomarkk		^[ k
399
+tomarkk		^[ ^K
400
+tomarkk		^[ K
401
+txt		^[ i
402
+txt		^[ I
403
+upslide		^[ w
404
+upslide		^[ ^W
405
+upslide		^[ W
406
+upslide,upslide,upslide,upslide		MWUP
407
+yank		^[ y
408
+yankpop		^[ ^Y
409
+yank		^[ Y
410
+
411
+insc		^@
412
+
413
+nbuf		^[ v
414
+nbuf		^[ V
415
+nbuf		^[ ^V
416
+pbuf		^[ u
417
+pbuf		^[ U
418
+pbuf		^[ ^U
419
+
420
+quote8		^\
421
+quote		^[ '
422
+quote		^Q
423
+
424
+backs		^?
425
+backs		^H
426
+backw		^O
427
+bknd		^K '
428
+blkcpy		^K C
429
+blkcpy		^K ^C
430
+blkcpy		^K c
431
+blkdel		^K Y
432
+blkdel		^K ^Y
433
+blkdel		^K y
434
+blkmove		^K M
435
+blkmove		^K ^M
436
+blkmove		^K m
437
+blksave		^K W
438
+blksave		^K ^W
439
+blksave		^K w
440
+bof		^K U
441
+bof		^K ^U
442
+bof		^K u
443
+home		.kh
444
+home		^A
445
+center		^K A
446
+center		^K ^A
447
+center		^K a
448
+crawll		^K <
449
+crawlr		^K >
450
+delch		.kD
451
+delch		^D
452
+deleol		^J
453
+dellin		^Y
454
+delw		^W
455
+dnarw		.kd
456
+dnarw		^N
457
+dnarw		^[ O B
458
+dnarw		^[ [ B
459
+edit		^K E
460
+edit		^K ^E
461
+edit		^K e
462
+eof		^K V
463
+eof		^K ^V
464
+eof		^K v
465
+eol		.kH
466
+eol		.@7
467
+eol		^E
468
+exsave		^K X
469
+exsave		^K ^X
470
+exsave		^K x
471
+ffirst		^K F
472
+ffirst		^K ^F
473
+ffirst		^K f
474
+filt		^K /
475
+fnext		^L
476
+fmtblk		^K J
477
+fmtblk		^K ^J
478
+fmtblk		^K j
479
+gomark		^[ 0 TO 9
480
+groww		^K G
481
+groww		^K ^G
482
+groww		^K g
483
+insc		.kI
484
+insf		^K R
485
+insf		^K ^R
486
+insf		^K r
487
+lindent		^K ,
488
+line		^K L
489
+line		^K ^L
490
+line		^K l
491
+ltarw		.kl
492
+ltarw		^B
493
+ltarw		^[ O D
494
+ltarw		^[ [ D
495
+macros		^[ d
496
+macros		^[ ^D
497
+markb		^K B
498
+markb		^K ^B
499
+markb		^K b
500
+markk		^K K
501
+markk		^K ^K
502
+markk		^K k
503
+menu,"root",rtn	^T
504
+nextpos		^K =
505
+nextword	^X
506
+open		^]
507
+prevpos		^K -
508
+prevword	^Z
509
+reload		^K `
510
+redo		^^
511
+rindent		^K .
512
+rtarw		.kr
513
+rtarw		^F
514
+rtarw		^[ O C
515
+rtarw		^[ [ C
516
+run		^K !
517
+save		^K D
518
+save		^K S
519
+save		^K ^D
520
+save		^K ^S
521
+save		^K d
522
+save		^K s
523
+setmark		^[ ^[
524
+shrinkw		^K T
525
+shrinkw		^K ^T
526
+shrinkw		^K t
527
+splitw		^K O
528
+splitw		^K ^O
529
+splitw		^K o
530
+stat		^K SP
531
+tag		^K ;
532
+tomatch		^G
533
+undo		^_
534
+uparw		.ku
535
+uparw		^P
536
+uparw		^[ O A
537
+uparw		^[ [ A
538
+
539
+:prompt			Prompt windows
540
+:inherit main
541
+if,"byte>size",then,complete,complete,else,delch,endif	^D
542
+complete	^I
543
+dnarw,eol	.kd
544
+dnarw,eol	^N
545
+dnarw,eol	^[ O B
546
+dnarw,eol	^[ [ B
547
+uparw,eol	.ku
548
+uparw,eol	^P
549
+uparw,eol	^[ O A
550
+uparw,eol	^[ [ A
551
+
552
+:menu			Selection menus
553
+:inherit windows
554
+
555
+pgupmenu	^[ [ I
556
+
557
+pgdnmenu	^[ [ G
558
+
559
+bolmenu		^[ [ 1 ~
560
+bolmenu		^[ [ H
561
+bolmenu		^[ O H
562
+bolmenu		^[ [ 7 ~
563
+
564
+eolmenu		^[ [ 4 ~
565
+eolmenu		^[ [ F
566
+eolmenu		^[ O F
567
+eolmenu		^[ [ 8 ~
568
+
569
+abort		^[ ^[
570
+backsmenu	^?
571
+backsmenu	^H
572
+bofmenu		^K U
573
+bofmenu		^K ^U
574
+bofmenu		^K u
575
+bolmenu		.kh
576
+bolmenu		^A
577
+dnarwmenu	.kd
578
+dnarwmenu	^N
579
+dnarwmenu	^[ [ B
580
+dnarwmenu	^[ O B
581
+dnarwmenu	MWDOWN
582
+eofmenu		^K V
583
+eofmenu		^K ^V
584
+eofmenu		^K v
585
+eolmenu		.kH
586
+eolmenu		^E
587
+ltarwmenu	.kl
588
+ltarwmenu	^B
589
+ltarwmenu	^[ [ D
590
+ltarwmenu	^[ O D
591
+pgdnmenu	.kN
592
+pgdnmenu	^V
593
+pgdnmenu	^[ [ 6 ~
594
+pgupmenu	.kP
595
+pgupmenu	^U
596
+pgupmenu	^[ [ 5 ~
597
+rtarwmenu	.kr
598
+rtarwmenu	^F
599
+rtarwmenu	^[ [ C
600
+rtarwmenu	^[ O C
601
+rtn		SP
602
+rtn		^I
603
+rtn		^K H
604
+rtn		^K h
605
+rtn		^K ^H
606
+tabmenu		^I
607
+uparwmenu	.ku
608
+uparwmenu	^P
609
+uparwmenu	^[ [ A
610
+uparwmenu	^[ O A
611
+uparwmenu	MWUP
612
+defm2down	M2DOWN
613
+
614
+:query			Single-key query window
615
+:inherit windows
616
+
617
+:querya			Single-key query window for quoting
618
+type		^@ TO �
619
+
620
+:querysr		Search & replace query window
621
+type		^@ TO �

+ 58
- 0
utils/joe/patches/001-mathaway.patch Visa fil

@@ -0,0 +1,58 @@
1
+--- a/umath.c
2
++++ b/umath.c
3
+@@ -378,7 +378,6 @@ double m_cos(double n) { return cos(n); 
4
+ double m_tan(double n) { return tan(n); }
5
+ double m_exp(double n) { return exp(n); }
6
+ double m_sqrt(double n) { return sqrt(n); }
7
+-double m_cbrt(double n) { return cbrt(n); }
8
+ double m_log(double n) { return log(n); }
9
+ double m_log10(double n) { return log10(n); }
10
+ double m_asin(double n) { return asin(n); }
11
+@@ -387,19 +386,10 @@ double m_atan(double n) { return atan(n)
12
+ double m_sinh(double n) { return sinh(n); }
13
+ double m_cosh(double n) { return cosh(n); }
14
+ double m_tanh(double n) { return tanh(n); }
15
+-double m_asinh(double n) { return asinh(n); }
16
+-double m_acosh(double n) { return acosh(n); }
17
+-double m_atanh(double n) { return atanh(n); }
18
+ double m_int(double n) { return (int)(n); }
19
+ double m_floor(double n) { return floor(n); }
20
+ double m_ceil(double n) { return ceil(n); }
21
+ double m_fabs(double n) { return fabs(n); }
22
+-double m_erf(double n) { return erf(n); }
23
+-double m_erfc(double n) { return erfc(n); }
24
+-double m_j0(double n) { return j0(n); }
25
+-double m_j1(double n) { return j1(n); }
26
+-double m_y0(double n) { return y0(n); }
27
+-double m_y1(double n) { return y1(n); }
28
+ 
29
+ double calc(BW *bw, unsigned char *s)
30
+ {
31
+@@ -414,7 +404,6 @@ double calc(BW *bw, unsigned char *s)
32
+ 		v = get(USTR "tan"); v->func = m_tan;
33
+ 		v = get(USTR "exp"); v->func = m_exp;
34
+ 		v = get(USTR "sqrt"); v->func = m_sqrt;
35
+-		v = get(USTR "cbrt"); v->func = m_cbrt;
36
+ 		v = get(USTR "ln"); v->func = m_log;
37
+ 		v = get(USTR "log"); v->func = m_log10;
38
+ 		v = get(USTR "asin"); v->func = m_asin;
39
+@@ -425,19 +414,10 @@ double calc(BW *bw, unsigned char *s)
40
+ 		v = get(USTR "sinh"); v->func = m_sinh;
41
+ 		v = get(USTR "cosh"); v->func = m_cosh;
42
+ 		v = get(USTR "tanh"); v->func = m_tanh;
43
+-		v = get(USTR "asinh"); v->func = m_asinh;
44
+-		v = get(USTR "acosh"); v->func = m_acosh;
45
+-		v = get(USTR "atanh"); v->func = m_atanh;
46
+ 		v = get(USTR "int"); v->func = m_int;
47
+ 		v = get(USTR "floor"); v->func = m_floor;
48
+ 		v = get(USTR "ceil"); v->func = m_ceil;
49
+ 		v = get(USTR "abs"); v->func = m_fabs;
50
+-		v = get(USTR "erf"); v->func = m_erf;
51
+-		v = get(USTR "erfc"); v->func = m_erfc;
52
+-		v = get(USTR "j0"); v->func = m_j0;
53
+-		v = get(USTR "j1"); v->func = m_j1;
54
+-		v = get(USTR "y0"); v->func = m_y0;
55
+-		v = get(USTR "y1"); v->func = m_y1;
56
+ 	}
57
+ 
58
+ 	v = get(USTR "top");