Browse Source

Add dhcpcd-6.4.3, a fully featured yet light weight

DHCPv4/IPv4LL/IPv6RS/DHCPv6 quad stack client.

Signed-off-by: Roy Marples <roy@marples.name>
Roy Marples 10 years ago
parent
commit
0f3f802446
2 changed files with 87 additions and 0 deletions
  1. 63
    0
      net/dhcpcd/Makefile
  2. 24
    0
      net/dhcpcd/files/dhcpcd.init

+ 63
- 0
net/dhcpcd/Makefile View File

@@ -0,0 +1,63 @@
1
+#
2
+# Copyright (C) 2014 OpenWrt.org
3
+#
4
+# This is free software, licensed under the GNU General Public License v2.
5
+# See /LICENSE for more information.
6
+#
7
+
8
+include $(TOPDIR)/rules.mk
9
+
10
+PKG_NAME:=dhcpcd
11
+PKG_VERSION:=6.4.3
12
+PKG_RELEASE:=1
13
+
14
+PKG_SOURCE_URL:=ftp://roy.marples.name/pub/dhcpcd \
15
+    http://roy.marples.name/downloads/dhcpcd
16
+PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
17
+PKG_MD5SUM:=b22005c131e7108ecf598b6a4ac091eb
18
+
19
+PKG_LICENSE:=BSD-2c
20
+PKG_LICENSE_FILES:=
21
+
22
+PKG_MAINTAINER:=Roy Marples <roy@marples.name>
23
+
24
+PKG_BUILD_PARALLEL:=1
25
+PKG_INSTALL:=1
26
+
27
+include $(INCLUDE_DIR)/package.mk
28
+
29
+define Package/dhcpcd
30
+  SECTION:=net
31
+  CATEGORY:=Network
32
+  TITLE:=DHCPv4/IPv4LL/IPv6RS/DHCPv6 quad stack client
33
+  URL:=http://roy.marples.name/projects/dhcpcd
34
+endef
35
+
36
+define Package/dhcpcd/description
37
+  DHCPv4, IPv6RS and DHCPv6 client with IPv4LL support
38
+  dhcpcd is a one stop network management daemon which includes
39
+    * RFC compliant DHCPv4 and DHCPv6 clients
40
+    * DHCPv6 Prefix Delegation support
41
+    * IPv4LL (aka ZeroConf) support
42
+    * ARP address conflict resolution
43
+    * Link carrier detection
44
+    * Wireless SSID profiles
45
+    * ARP ping profiles
46
+endef
47
+
48
+CONFIGURE_ARGS+=	--prefix=/ --sbindir=/sbin \
49
+			--libexecdir=/lib/dhcpcd --dbdir=/var/dhcpcd
50
+
51
+define Package/dhcpcd/install
52
+	$(INSTALL_DIR) $(1)/sbin $(1)/etc $(1)/lib/dhcpcd/dhcpcd-hooks
53
+	$(INSTALL_BIN) $(PKG_INSTALL_DIR)/sbin/dhcpcd $(1)/sbin/
54
+	$(INSTALL_BIN) $(PKG_INSTALL_DIR)/lib/dhcpcd/dhcpcd-run-hooks \
55
+	    $(1)/lib/dhcpcd/
56
+	$(INSTALL_DATA) $(PKG_INSTALL_DIR)/lib/dhcpcd/dhcpcd-hooks/* \
57
+	    $(1)/lib/dhcpcd/dhcpcd-hooks/
58
+	$(INSTALL_DIR) $(1)/etc/init.d
59
+	$(INSTALL_BIN) ./files/dhcpcd.init $(1)/etc/init.d/dhcpcd
60
+	$(INSTALL_CONF) $(PKG_INSTALL_DIR)/etc/dhcpcd.conf $(1)/etc/dhcpcd.conf
61
+endef
62
+
63
+$(eval $(call BuildPackage,dhcpcd))

+ 24
- 0
net/dhcpcd/files/dhcpcd.init View File

@@ -0,0 +1,24 @@
1
+#!/bin/sh /etc/rc.common
2
+#
3
+# Copyright (C) 2014 OpenWrt.org
4
+#
5
+# This is free software, licensed under the GNU General Public License v2.
6
+# See /LICENSE for more information.
7
+#
8
+
9
+START=30
10
+STOP=85
11
+USE_PROCD=1
12
+
13
+start_service()
14
+{
15
+	procd_open_instance
16
+	procd_set_param command /sbin/dhcpcd -B
17
+	procd_set_param respawn
18
+	procd_close_instance
19
+}
20
+
21
+reload_service()
22
+{
23
+	/sbin/dhcpcd -n
24
+}