Browse Source

madplay: Fix various build issues

Signed-off-by: Ted Hess <thess@kitschensync.net>
Ted Hess 9 years ago
parent
commit
0f8522e9f0
2 changed files with 34 additions and 4 deletions
  1. 4
    4
      sound/madplay/Makefile
  2. 30
    0
      sound/madplay/patches/010-use_correct_shell.patch

+ 4
- 4
sound/madplay/Makefile View File

@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
9 9
 
10 10
 PKG_NAME:=madplay
11 11
 PKG_VERSION:=0.15.2b
12
-PKG_RELEASE:=3
12
+PKG_RELEASE:=4
13 13
 
14 14
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
15 15
 PKG_SOURCE_URL:=@SF/mad \
@@ -20,14 +20,14 @@ PKG_LICENSE_FILES:=COPYING
20 20
 PKG_MAINTAINER:=Simon Peter <probono@puredarwin.org>
21 21
 
22 22
 PKG_FIXUP:=autoreconf
23
-PKG_INSTALL:=1
24 23
 
25 24
 include $(INCLUDE_DIR)/package.mk
25
+include $(INCLUDE_DIR)/nls.mk
26 26
 
27 27
 define Package/madplay
28 28
   SECTION:=sound
29 29
   CATEGORY:=Sound
30
-  DEPENDS:=+libid3tag +libmad
30
+  DEPENDS:=+libid3tag +libmad $(INTL_DEPENDS)
31 31
   TITLE:=MPEG audio player in fixed point
32 32
   URL:=http://sourceforge.net/projects/mad
33 33
 endef
@@ -57,7 +57,7 @@ endef
57 57
 
58 58
 define Package/madplay/install
59 59
 	$(INSTALL_DIR) $(1)/usr/bin
60
-	$(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/bin/madplay $(1)/usr/bin/
60
+	$(INSTALL_BIN) $(PKG_BUILD_DIR)/madplay $(1)/usr/bin/
61 61
 endef
62 62
 
63 63
 $(eval $(call BuildPackage,madplay))

+ 30
- 0
sound/madplay/patches/010-use_correct_shell.patch View File

@@ -0,0 +1,30 @@
1
+--- a/intl/Makefile.in
2
++++ b/intl/Makefile.in
3
+@@ -19,7 +19,7 @@
4
+ PACKAGE = @PACKAGE@
5
+ VERSION = @VERSION@
6
+ 
7
+-SHELL = /bin/sh
8
++SHELL = @SHELL@
9
+ 
10
+ srcdir = @srcdir@
11
+ top_srcdir = @top_srcdir@
12
+@@ -56,6 +56,7 @@ DEFS = -DLOCALEDIR=\"$(localedir)\" -DLO
13
+ -DENABLE_RELOCATABLE=1 -DIN_LIBRARY -DINSTALLDIR=\"$(libdir)\" -DNO_XMALLOC \
14
+ -Dset_relocation_prefix=libintl_set_relocation_prefix \
15
+ -Drelocate=libintl_relocate \
16
++-DINSTALLPREFIX=\"$(prefix)\" \
17
+ -DDEPENDS_ON_LIBICONV=1 @DEFS@
18
+ CPPFLAGS = @CPPFLAGS@
19
+ CFLAGS = @CFLAGS@
20
+--- a/po/Makefile.in.in
21
++++ b/po/Makefile.in.in
22
+@@ -13,7 +13,7 @@
23
+ PACKAGE = @PACKAGE@
24
+ VERSION = @VERSION@
25
+ 
26
+-SHELL = /bin/sh
27
++SHELL = @SHELL@
28
+ @SET_MAKE@
29
+ 
30
+ srcdir = @srcdir@