Browse Source

Merge pull request #1062 from smoofra/tmux

tmux: build fix: don't -I /usr/local/include
Steven Barth 10 years ago
parent
commit
0f8e376b08
1 changed files with 14 additions and 0 deletions
  1. 14
    0
      utils/tmux/patches/200-usr-local.patch

+ 14
- 0
utils/tmux/patches/200-usr-local.patch View File

@@ -0,0 +1,14 @@
1
+--- a/Makefile.in
2
++++ b/Makefile.in
3
+@@ -101,9 +101,9 @@ bin_PROGRAMS = tmux$(EXEEXT)
4
+ @IS_DEBUG_TRUE@@IS_GCC_TRUE@	-Wdeclaration-after-statement
5
+ @IS_DEBUG_TRUE@@IS_GCC_TRUE@am__append_4 = -DDEBUG
6
+ @IS_DEBUG_FALSE@@IS_GCC_TRUE@am__append_5 = -O2
7
+-@IS_GCC4_TRUE@@IS_GCC_TRUE@am__append_6 = -iquote. -I/usr/local/include
8
++@IS_GCC4_TRUE@@IS_GCC_TRUE@am__append_6 = -iquote.
9
+ @IS_DEBUG_TRUE@@IS_GCC4_TRUE@@IS_GCC_TRUE@am__append_7 = -Wno-pointer-sign
10
+-@IS_GCC4_FALSE@@IS_GCC_TRUE@am__append_8 = -I. -I- -I/usr/local/include
11
++@IS_GCC4_FALSE@@IS_GCC_TRUE@am__append_8 = -I. -I-
12
+ 
13
+ # Set flags for Solaris.
14
+ @IS_GCC_TRUE@@IS_SUNOS_TRUE@am__append_9 = -D_XPG6 -D__EXTENSIONS__ -D_POSIX_PTHREAD_SEMANTICS