Browse Source

Merge pull request #927 from commodo/python-push2

python: add patch to abort build on failed module build
Steven Barth 10 years ago
parent
commit
10313e98af
1 changed files with 21 additions and 0 deletions
  1. 21
    0
      lang/python/patches/170-abort-on-failed-modules.patch

+ 21
- 0
lang/python/patches/170-abort-on-failed-modules.patch View File

@@ -0,0 +1,21 @@
1
+Abort on failed module build
2
+
3
+When building a Python module fails, the setup.py script currently
4
+doesn't exit with an error, and simply continues. This is not a really
5
+nice behavior, so this patch changes setup.py to abort with an error,
6
+so that the build issue is clearly noticeable.
7
+
8
+Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
9
+
10
+Index: b/setup.py
11
+===================================================================
12
+--- a/setup.py
13
++++ b/setup.py
14
+@@ -283,6 +283,7 @@
15
+             print "Failed to build these modules:"
16
+             print_three_column(failed)
17
+             print
18
++            sys.exit(1)
19
+ 
20
+     def build_extension(self, ext):
21
+