|
@@ -0,0 +1,44 @@
|
|
1
|
+#
|
|
2
|
+# Copyright (c) 2015 OpenWrt.org
|
|
3
|
+#
|
|
4
|
+# This is free software, licensed under the BSD 2-Clause License.
|
|
5
|
+#
|
|
6
|
+
|
|
7
|
+include $(TOPDIR)/rules.mk
|
|
8
|
+
|
|
9
|
+PKG_NAME:=port-mirroring
|
|
10
|
+PKG_VERSION:=1.4.2
|
|
11
|
+PKG_RELEASE:=1
|
|
12
|
+PKG_MAINTAINER:=Mike Maraya <mike.maraya@gmail.com>
|
|
13
|
+PKG_LICENSE:=BSD-2-Clause
|
|
14
|
+PKG_LICENSE_FILES:=LICENSE
|
|
15
|
+PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
|
|
16
|
+PKG_SOURCE_SUBDIR:=$(PKG_NAME)-$(PKG_VERSION)
|
|
17
|
+PKG_SOURCE_URL:=git://github.com/mmaraya/port-mirroring.git
|
|
18
|
+PKG_SOURCE_PROTO:=git
|
|
19
|
+PKG_SOURCE_VERSION:=f6ead68b7760fa86e8da73ac1e062349f243ac93
|
|
20
|
+PKG_FIXUP:=autoreconf
|
|
21
|
+PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(PKG_VERSION)
|
|
22
|
+
|
|
23
|
+include $(INCLUDE_DIR)/package.mk
|
|
24
|
+
|
|
25
|
+define Package/port-mirroring
|
|
26
|
+ SECTION:=net
|
|
27
|
+ CATEGORY:=Network
|
|
28
|
+ DEPENDS:=+libpcap +libpthread
|
|
29
|
+ TITLE:=Copy network packets with optional support for TaZmen Sniffer Protocol (TZSP)
|
|
30
|
+ URL:=https://github.com/mmaraya/port-mirroring
|
|
31
|
+ MENU:=1
|
|
32
|
+endef
|
|
33
|
+
|
|
34
|
+define Package/port-mirroring/install
|
|
35
|
+ $(INSTALL_DIR) $(1)/usr/sbin
|
|
36
|
+ $(INSTALL_BIN) $(PKG_BUILD_DIR)/port-mirroring $(1)/usr/sbin/
|
|
37
|
+ $(INSTALL_DIR) $(1)/etc/config
|
|
38
|
+ $(INSTALL_CONF) $(PKG_BUILD_DIR)/port-mirroring.conf $(1)/etc/config/port-mirroring
|
|
39
|
+ $(INSTALL_DIR) $(1)/etc/init.d
|
|
40
|
+ $(INSTALL_BIN) $(PKG_BUILD_DIR)/port-mirroringd $(1)/etc/init.d/port_mirroring
|
|
41
|
+endef
|
|
42
|
+
|
|
43
|
+$(eval $(call BuildPackage,port-mirroring))
|
|
44
|
+
|