Browse Source

aiccu: fix uClibc build after #1389

Signed-off-by: Jo-Philipp Wich <jow@openwrt.org>
Jo-Philipp Wich 9 years ago
parent
commit
1208a25e71

+ 1
- 1
ipv6/aiccu/Makefile View File

@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
9 9
 
10 10
 PKG_NAME:=aiccu
11 11
 PKG_VERSION:=20070115
12
-PKG_RELEASE:=13
12
+PKG_RELEASE:=14
13 13
 
14 14
 PKG_SOURCE:=$(PKG_NAME)_$(PKG_VERSION).tar.gz
15 15
 PKG_SOURCE_URL:=http://www.sixxs.net/archive/sixxs/aiccu/unix

+ 3
- 14
ipv6/aiccu/patches/300-resolver-uclibc.patch View File

@@ -5,7 +5,7 @@
5 5
  int getrrs(const char *label, int rrtype, void gotrec(unsigned int num, int type, const char *record))
6 6
  {
7 7
 -#ifdef _LINUX
8
-+#if defined(_LINUX) && defined(__GLIBC__)
8
++#if defined(_LINUX) && defined(__GLIBC__) && !defined(__UCLIBC__)
9 9
  	struct __res_state	res;
10 10
  #endif
11 11
  	unsigned char		answer[8192];
@@ -14,7 +14,7 @@
14 14
  	uint32_t		ttl = 0;
15 15
  
16 16
 -#ifdef _LINUX
17
-+#if defined(_LINUX) && defined(__GLIBC__)
17
++#if defined(_LINUX) && defined(__GLIBC__) && !defined(__UCLIBC__)
18 18
  	memset(&res, 0, sizeof(res));
19 19
  	res.options = RES_DEBUG;
20 20
  	res_ninit(&res);
@@ -23,18 +23,7 @@
23 23
  
24 24
  	memset(answer, 0, sizeof(answer));
25 25
 -#ifdef _LINUX
26
-+#if defined(_LINUX) && defined(__GLIBC__)
26
++#if defined(_LINUX) && defined(__GLIBC__) && !defined(__UCLIBC__)
27 27
  	ret = res_nquery(&res, label, C_IN, rrtype, answer, sizeof(answer));
28 28
  #else
29 29
  	ret = res_query(label, C_IN, rrtype, answer, sizeof(answer));
30
---- a/common/dn_skipname.c
31
-+++ b/common/dn_skipname.c
32
-@@ -9,7 +9,7 @@
33
-  * return:
34
-  *      0 on success, -1 (with errno set) on failure.
35
-  */
36
--int ns_name_skip(const u_char **ptrptr, const u_char *eom)
37
-+static int ns_name_skip(const u_char **ptrptr, const u_char *eom)
38
- {
39
- 	const u_char *cp;
40
- 	u_int n;

+ 4
- 2
ipv6/aiccu/patches/400-musl-compat.patch View File

@@ -20,10 +20,12 @@
20 20
  	#include <linux/if_tun.h>
21 21
 --- a/common/dn_skipname.c
22 22
 +++ b/common/dn_skipname.c
23
-@@ -1,5 +1,6 @@
23
+@@ -1,6 +1,8 @@
24 24
  #include <errno.h>
25 25
  #include <resolv.h>
26
-+#include <sys/types.h>
27 26
  
27
++#include <sys/types.h>
28
++
28 29
  /* Ripped from glibc 2.4 sources. */
29 30
  
31
+ /*