Bladeren bron

python-cffi: new package

From PyPI:

Foreign Function Interface for Python calling C code.

This depends on python-pycparser, which is in PR #1970

Signed-off-by: Jeffery To <jeffery.to@gmail.com>
Jeffery To 9 jaren geleden
bovenliggende
commit
1440f75ac7
1 gewijzigde bestanden met toevoegingen van 45 en 0 verwijderingen
  1. 45
    0
      lang/python-cffi/Makefile

+ 45
- 0
lang/python-cffi/Makefile Bestand weergeven

@@ -0,0 +1,45 @@
1
+#
2
+# Copyright (C) 2015 OpenWrt.org
3
+#
4
+# This is free software, licensed under the GNU General Public License v2.
5
+# See /LICENSE for more information.
6
+#
7
+
8
+include $(TOPDIR)/rules.mk
9
+
10
+PKG_NAME:=cffi
11
+PKG_VERSION:=1.3.0
12
+PKG_RELEASE:=1
13
+
14
+PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
15
+PKG_SOURCE_URL:=https://pypi.python.org/packages/source/c/cffi
16
+PKG_MD5SUM:=a40ed8c8ac653c8fc7d5603711b06eaf
17
+
18
+PKG_BUILD_DEPENDS:=python python-setuptools
19
+
20
+PKG_LICENSE:=MIT
21
+PKG_LICENSE_FILES:=LICENSE
22
+PKG_MAINTAINER:=Jeffery To <jeffery.to@gmail.com>
23
+
24
+include $(INCLUDE_DIR)/package.mk
25
+$(call include_mk, python-package.mk)
26
+
27
+define Package/python-cffi
28
+	SECTION:=lang
29
+	CATEGORY:=Languages
30
+	SUBMENU:=Python
31
+	TITLE:=python-cffi
32
+	URL:=http://cffi.readthedocs.org/
33
+	DEPENDS:=+libffi +python-light +python-pycparser
34
+endef
35
+
36
+define Package/python-cffi/description
37
+Foreign Function Interface for Python calling C code.
38
+endef
39
+
40
+define Build/Compile
41
+	$(call Build/Compile/PyMod,,install --prefix=/usr --root=$(PKG_INSTALL_DIR))
42
+endef
43
+
44
+$(eval $(call PyPackage,python-cffi))
45
+$(eval $(call BuildPackage,python-cffi))