|
@@ -0,0 +1,51 @@
|
|
1
|
+#
|
|
2
|
+# Copyright (C) 2015 OpenWrt.org
|
|
3
|
+#
|
|
4
|
+# This is free software, licensed under the GNU General Public License v2.
|
|
5
|
+# See /LICENSE for more information.
|
|
6
|
+#
|
|
7
|
+
|
|
8
|
+include $(TOPDIR)/rules.mk
|
|
9
|
+
|
|
10
|
+PKG_NAME:=mt-st
|
|
11
|
+PKG_VERSION:=1.1
|
|
12
|
+PKG_RELEASE:=1
|
|
13
|
+
|
|
14
|
+PKG_SOURCE_SUBDIR:=$(PKG_NAME)
|
|
15
|
+PKG_SOURCE_VERSION:=$(PKG_VERSION)
|
|
16
|
+PKG_SOURCE:=$(PKG_NAME)-$(PKG_SOURCE_VERSION).tar.gz
|
|
17
|
+PKG_SOURCE_URL:=http://ftp.ibiblio.org/pub/Linux/system/backup/
|
|
18
|
+PKG_MD5SUM:=fdd5f5ec673c9f630a102ceff7612774
|
|
19
|
+
|
|
20
|
+PKG_LICENSE:=GPL-2.0
|
|
21
|
+
|
|
22
|
+include $(INCLUDE_DIR)/package.mk
|
|
23
|
+
|
|
24
|
+define Package/mt-st
|
|
25
|
+ SECTION:=utils
|
|
26
|
+ CATEGORY:=Utilities
|
|
27
|
+ TITLE:=Magnetic tape control tools for Linux SCSI tapes
|
|
28
|
+ URL:=http://ftp.ibiblio.org/pub/Linux/system/backup/
|
|
29
|
+ MAINTAINER:=Giuseppe Magnotta <giuseppe.magnotta@gmail.com>
|
|
30
|
+endef
|
|
31
|
+
|
|
32
|
+define Package/mt-st/description
|
|
33
|
+ Includes a mt-like program supporting additional commands using ioctls
|
|
34
|
+ specific to the Linux SCSI tape driver (up to kernel 2.6.26), and the program
|
|
35
|
+ stinit to define the SCSI tape devices in system startup scripts.
|
|
36
|
+endef
|
|
37
|
+
|
|
38
|
+define Build/Compile
|
|
39
|
+ $(MAKE) -C $(PKG_BUILD_DIR) \
|
|
40
|
+ LDFLAGS="$(TARGET_LDFLAGS)" \
|
|
41
|
+ CFLAGS="$(TARGET_CFLAGS) $(TARGET_CPPFLAGS)" \
|
|
42
|
+ CC="$(TARGET_CC)"
|
|
43
|
+endef
|
|
44
|
+
|
|
45
|
+define Package/mt-st/install
|
|
46
|
+ $(INSTALL_DIR) $(1)/usr/bin
|
|
47
|
+ $(INSTALL_BIN) $(PKG_BUILD_DIR)/mt $(1)/usr/bin/
|
|
48
|
+ $(INSTALL_BIN) $(PKG_BUILD_DIR)/stinit $(1)/usr/bin/
|
|
49
|
+endef
|
|
50
|
+
|
|
51
|
+$(eval $(call BuildPackage,mt-st))
|