Browse Source

nbd: import from oldpackages and make myself maintainer

Signed-off-by: Marcin Jurkowski <marcin1j@gmail.com>
Marcin Jurkowski 9 years ago
parent
commit
14f66e3ff5
1 changed files with 53 additions and 0 deletions
  1. 53
    0
      net/nbd/Makefile

+ 53
- 0
net/nbd/Makefile View File

@@ -0,0 +1,53 @@
1
+#
2
+# Copyright (C) 2006-2011 OpenWrt.org
3
+#
4
+# This is free software, licensed under the GNU General Public License v2.
5
+# See /LICENSE for more information.
6
+#
7
+
8
+include $(TOPDIR)/rules.mk
9
+
10
+PKG_NAME:=nbd
11
+PKG_VERSION:=2.9.23
12
+PKG_RELEASE:=1
13
+
14
+PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
15
+PKG_SOURCE_URL:=@SF/nbd
16
+PKG_MD5SUM:=065b6ded41887a08be6dbb8d77280f24
17
+PKG_MAINTAINER:=Marcin Jurkowski <marcin1j@gmail.com>
18
+
19
+PKG_INSTALL:=1
20
+
21
+include $(INCLUDE_DIR)/package.mk
22
+
23
+# -liconv due to glib2, to be revisited later
24
+include $(INCLUDE_DIR)/nls.mk
25
+
26
+PKG_BUILD_DEPENDS:=glib2 libintl
27
+
28
+define Package/nbd
29
+  SECTION:=net
30
+  CATEGORY:=Network
31
+  TITLE:=Network Block Device utilities
32
+  URL:=http://nbd.sourceforge.net
33
+  DEPENDS:=+kmod-nbd
34
+endef
35
+
36
+define Package/nbd/description
37
+  This package contains the network block device client.
38
+endef
39
+
40
+CONFIGURE_ARGS+= \
41
+	--disable-glibtest
42
+
43
+define Build/Compile
44
+	$(MAKE) -C $(PKG_BUILD_DIR) \
45
+		nbd-client
46
+endef
47
+
48
+define Package/nbd/install
49
+	$(INSTALL_DIR) $(1)/usr/sbin
50
+	$(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/sbin/nbd-client $(1)/usr/sbin/
51
+endef
52
+
53
+$(eval $(call BuildPackage,nbd))