Browse Source

perl: Also strip begin, end and for pragmas

Signed-off-by: Marcel Denia <naoir@gmx.net>
Marcel Denia 10 years ago
parent
commit
1549919b71
1 changed files with 2 additions and 2 deletions
  1. 2
    2
      lang/perl/perlmod.mk

+ 2
- 2
lang/perl/perlmod.mk View File

@@ -128,8 +128,8 @@ define perlmod/Install
128 128
 	@echo "---> Stripping modules in: $(strip $(1))$(PERL_SITELIB)"
129 129
 	find $(strip $(1))$(PERL_SITELIB) -name \*.pm -or -name \*.pl | \
130 130
 	xargs -r sed -i \
131
-		-e '/^=\(head\|pod\|item\|over\|back\|encoding\)/,/^=cut/d' \
132
-		-e '/^=\(head\|pod\|item\|over\|back\|encoding\)/,$$$$d' \
131
+		-e '/^=\(head\|pod\|item\|over\|back\|encoding\|begin\|end\|for\)/,/^=cut/d' \
132
+		-e '/^=\(head\|pod\|item\|over\|back\|encoding\|begin\|end\|for\)/,$$$$d' \
133 133
 		-e '/^#$$$$/d' \
134 134
 		-e '/^#[^!"'"'"']/d'
135 135
 endef