Browse Source

lxc: add configuration section

Signed-off-by: Luka Perkov <luka@openwrt.org>
Luka Perkov 10 years ago
parent
commit
1614bed10b
2 changed files with 20 additions and 1 deletions
  1. 15
    0
      utils/lxc/Config.in
  2. 5
    1
      utils/lxc/Makefile

+ 15
- 0
utils/lxc/Config.in View File

@@ -0,0 +1,15 @@
1
+menu "Configuration"
2
+        depends on PACKAGE_lxc
3
+
4
+config LXC_KERNEL_OPTIONS
5
+	bool "Enable kernel support for LXC"
6
+	default n
7
+	select KERNEL_CGROUPS
8
+	select KERNEL_NAMESPACES
9
+	select KERNEL_LXC_MISC
10
+	help
11
+	  Select needed kernel options for LXC related utilities. Options
12
+	  include cgroups, namespaces and other miscellaneous options. These
13
+	  options unfortunately can not be installed as a module.
14
+
15
+endmenu

+ 5
- 1
utils/lxc/Makefile View File

@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
9 9
 
10 10
 PKG_NAME:=lxc
11 11
 PKG_VERSION:=1.0.5
12
-PKG_RELEASE:=1
12
+PKG_RELEASE:=2
13 13
 
14 14
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
15 15
 PKG_SOURCE_URL:=http://linuxcontainers.org/downloads/
@@ -49,6 +49,10 @@ define Package/lxc
49 49
   MENU:=1
50 50
 endef
51 51
 
52
+define Package/lxc/config
53
+  source "$(SOURCE)/Config.in"
54
+endef
55
+
52 56
 define Package/lxc/description
53 57
  LXC is the userspace control package for Linux Containers, a lightweight
54 58
  virtual system mechanism sometimes described as "chroot on steroids".