ソースを参照

gnunet: update source to r35963

Signed-off-by: Daniel Golle <daniel@makrotopia.org>
Daniel Golle 9 年 前
コミット
161b225acc
共有2 個のファイルを変更した1 個の追加89 個の削除を含む
  1. 1
    1
      net/gnunet/Makefile
  2. 0
    88
      net/gnunet/patches/012-work-around-bad-workarounds.patch

+ 1
- 1
net/gnunet/Makefile ファイルの表示

@@ -8,7 +8,7 @@
8 8
 include $(TOPDIR)/rules.mk
9 9
 
10 10
 PKG_NAME:=gnunet
11
-PKG_SOURCE_VERSION:=35949
11
+PKG_SOURCE_VERSION:=35963
12 12
 PKG_VERSION:=0.10.1-svn$(PKG_SOURCE_VERSION)
13 13
 PKG_RELEASE:=1
14 14
 

+ 0
- 88
net/gnunet/patches/012-work-around-bad-workarounds.patch ファイルの表示

@@ -1,88 +0,0 @@
1
---- a/m4/libgnurl.m4
2
-+++ b/m4/libgnurl.m4
3
-@@ -146,7 +146,7 @@ AC_DEFUN([LIBGNURL_CHECK_CONFIG],
4
-            _libgnurl_save_libs=$LIBS
5
-            LIBS="$LIBGNURL $LIBS"
6
- 
7
--           AC_LINK_IFELSE([AC_LANG_PROGRAM([#include <curl/curl.h>],[
8
-+           AC_LINK_IFELSE([AC_LANG_PROGRAM([#include <gnurl/curl.h>],[
9
- /* Try and use a few common options to force a failure if we are
10
-    missing symbols or can't link. */
11
- int x;
12
---- a/src/gns/gnunet-gns-proxy.c
13
-+++ b/src/gns/gnunet-gns-proxy.c
14
-@@ -29,7 +29,7 @@
15
-  */
16
- #include "platform.h"
17
- #include <microhttpd.h>
18
--#include <curl/curl.h>
19
-+#include <gnurl/curl.h>
20
- #include <gnutls/gnutls.h>
21
- #include <gnutls/x509.h>
22
- #include <gnutls/abstract.h>
23
---- a/src/gns/test_gns_proxy.c
24
-+++ b/src/gns/test_gns_proxy.c
25
-@@ -24,7 +24,7 @@
26
-  * @author Martin Schanzenbach
27
-  */
28
- #include "platform.h"
29
--#include <curl/curl.h>
30
-+#include <gnurl/curl.h>
31
- #include <microhttpd.h>
32
- #include "gnunet_namestore_service.h"
33
- #include "gnunet_gns_service.h"
34
---- a/src/hostlist/gnunet-daemon-hostlist_client.c
35
-+++ b/src/hostlist/gnunet-daemon-hostlist_client.c
36
-@@ -29,7 +29,7 @@
37
- #include "gnunet_statistics_service.h"
38
- #include "gnunet_transport_service.h"
39
- #include "gnunet-daemon-hostlist.h"
40
--#include <curl/curl.h>
41
-+#include <gnurl/curl.h>
42
- 
43
- 
44
- /**
45
---- a/src/pt/test_gns_vpn.c
46
-+++ b/src/pt/test_gns_vpn.c
47
-@@ -24,7 +24,7 @@
48
-  * @author Martin Schanzenbach
49
-  */
50
- #include "platform.h"
51
--#include <curl/curl.h>
52
-+#include <gnurl/curl.h>
53
- #include <microhttpd.h>
54
- #include "gnunet_identity_service.h"
55
- #include "gnunet_namestore_service.h"
56
---- a/src/pt/test_gnunet_vpn.c
57
-+++ b/src/pt/test_gnunet_vpn.c
58
-@@ -24,7 +24,7 @@
59
-  * @author Christian Grothoff
60
-  */
61
- #include "platform.h"
62
--#include <curl/curl.h>
63
-+#include <gnurl/curl.h>
64
- #include <microhttpd.h>
65
- #include "gnunet_vpn_service.h"
66
- #include "gnunet_testing_lib.h"
67
---- a/src/transport/plugin_transport_http.h
68
-+++ b/src/transport/plugin_transport_http.h
69
-@@ -41,7 +41,7 @@
70
- #include "gnunet_os_lib.h"
71
- #include "gnunet_nat_lib.h"
72
- #include "microhttpd.h"
73
--#include <curl/curl.h>
74
-+#include <gnurl/curl.h>
75
- 
76
- 
77
- #define DEBUG_HTTP GNUNET_EXTRA_LOGGING
78
---- a/src/transport/plugin_transport_http_client.c
79
-+++ b/src/transport/plugin_transport_http_client.c
80
-@@ -49,7 +49,7 @@
81
- #include "gnunet_protocols.h"
82
- #include "gnunet_transport_plugin.h"
83
- #include "plugin_transport_http_common.h"
84
--#include <curl/curl.h>
85
-+#include <gnurl/curl.h>
86
- 
87
- 
88
- #define LOG(kind,...) GNUNET_log_from(kind, PLUGIN_NAME, __VA_ARGS__)