Browse Source

avrdude: move from oldpackages, update to latest version & build opts

Signed-off-by: Ted Hess <thess@kitschensync.net>
Ted Hess 9 years ago
parent
commit
1637dcbf99
2 changed files with 72 additions and 0 deletions
  1. 54
    0
      utils/avrdude/Makefile
  2. 18
    0
      utils/avrdude/patches/010-configure-fixups.patch

+ 54
- 0
utils/avrdude/Makefile View File

@@ -0,0 +1,54 @@
1
+#
2
+# Copyright (C) 2008-2015 OpenWrt.org
3
+#
4
+# This is free software, licensed under the GNU General Public License v2.
5
+# See /LICENSE for more information.
6
+#
7
+
8
+include $(TOPDIR)/rules.mk
9
+
10
+PKG_NAME:=avrdude
11
+PKG_VERSION:=6.1
12
+PKG_RELEASE:=1
13
+
14
+PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
15
+PKG_SOURCE_URL:=http://download.savannah.gnu.org/releases/avrdude
16
+PKG_MD5SUM:=9db8c25b935d34234b9b1ba16ad55fd5
17
+
18
+PKG_MAINTAINER:=Ted Hess <thess@kitschensync.net>
19
+PKG_LICENSE:=GPL-2.0
20
+PKG_LICENSE_FILES:=COPYING
21
+
22
+PKG_FIXUP:=autoreconf
23
+PKG_INSTALL:=1
24
+
25
+include $(INCLUDE_DIR)/package.mk
26
+
27
+define Package/avrdude
28
+  SECTION:=utils
29
+  CATEGORY:=Utilities
30
+  TITLE:=AVR Downloader/UploaDEr
31
+  URL:=http://www.nongnu.org/avrdude/
32
+  DEPENDS:=+libncurses +libreadline +libusb-compat +libftdi1
33
+endef
34
+
35
+define Package/avrdude/description
36
+ AVRDUDE is a full featured program for programming Atmel's AVR CPU's.
37
+endef
38
+
39
+CONFIGURE_ARGS+= \
40
+	--disable-doc \
41
+	--disable-parport \
42
+
43
+define Package/avrdude/conffiles
44
+/etc/avrdude.conf
45
+endef
46
+
47
+define Package/avrdude/install
48
+	$(INSTALL_DIR) $(1)/etc
49
+	$(INSTALL_CONF) $(PKG_INSTALL_DIR)/etc/avrdude.conf $(1)/etc/
50
+	$(INSTALL_DIR) $(1)/usr/bin
51
+	$(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/bin/avrdude $(1)/usr/bin/
52
+endef
53
+
54
+$(eval $(call BuildPackage,avrdude))

+ 18
- 0
utils/avrdude/patches/010-configure-fixups.patch View File

@@ -0,0 +1,18 @@
1
+--- a/configure.ac
2
++++ b/configure.ac
3
+@@ -35,6 +35,7 @@ AC_CONFIG_HEADERS(ac_cfg.h)
4
+ 
5
+ # Checks for programs.
6
+ AC_PROG_CC
7
++AC_PROG_CPP
8
+ AC_PROG_INSTALL
9
+ AC_PROG_SED
10
+ AC_PROG_YACC
11
+@@ -183,6 +184,7 @@ fi
12
+ AC_SUBST(LIBPTHREAD, $LIBPTHREAD)
13
+ # Checks for header files.
14
+ AC_CHECK_HEADERS([limits.h stdlib.h string.h])
15
++AC_CHECK_HEADERS([inttypes.h stdint.h])
16
+ AC_CHECK_HEADERS([fcntl.h sys/ioctl.h sys/time.h termios.h unistd.h])
17
+ AC_CHECK_HEADERS([ddk/hidsdi.h],,,[#include <windows.h>
18
+ #include <setupapi.h>])