|
@@ -8,13 +8,13 @@
|
8
|
8
|
include $(TOPDIR)/rules.mk
|
9
|
9
|
|
10
|
10
|
PKG_NAME:=erlang
|
11
|
|
-PKG_VERSION:=17.4
|
|
11
|
+PKG_VERSION:=17.5
|
12
|
12
|
PKG_RELEASE:=1
|
13
|
13
|
|
14
|
14
|
PKG_SOURCE:=otp_src_$(PKG_VERSION).tar.gz
|
15
|
15
|
PKG_SOURCE_URL:= http://www.erlang.org/download/ \
|
16
|
16
|
http://erlang.mirror.su.se/
|
17
|
|
-PKG_MD5SUM:=3d33c4c6bd7950240dcd7479edd9c7d8
|
|
17
|
+PKG_MD5SUM:=346dd0136bf1cc28cebc140e505206bb
|
18
|
18
|
|
19
|
19
|
PKG_LICENSE:=ErlPL-1.1
|
20
|
20
|
PKG_LICENSE_FILES:=EPLICENCE
|
|
@@ -45,7 +45,7 @@ endef
|
45
|
45
|
define Package/erlang
|
46
|
46
|
$(call Package/erlang/Default)
|
47
|
47
|
DEPENDS+= +libncurses +librt +zlib
|
48
|
|
- PROVIDES:= erlang-erts=6.1 erlang-kernel=3.0.1 erlang-sasl=2.4 erlang-stdlib=2.1
|
|
48
|
+ PROVIDES:= erlang-erts=6.4 erlang-kernel=3.2 erlang-sasl=2.4.1 erlang-stdlib=2.4
|
49
|
49
|
endef
|
50
|
50
|
|
51
|
51
|
define Package/erlang/description
|
|
@@ -59,7 +59,7 @@ endef
|
59
|
59
|
define Package/erlang-asn1
|
60
|
60
|
$(call Package/erlang/Default)
|
61
|
61
|
TITLE:=Abstract Syntax Notation One (ASN.1) support
|
62
|
|
- VERSION:=3.0.1
|
|
62
|
+ VERSION:=3.0.4
|
63
|
63
|
DEPENDS+= +erlang +erlang-syntax-tools
|
64
|
64
|
endef
|
65
|
65
|
|
|
@@ -74,7 +74,7 @@ endef
|
74
|
74
|
define Package/erlang-compiler
|
75
|
75
|
$(call Package/erlang/Default)
|
76
|
76
|
TITLE:=Byte code compiler
|
77
|
|
- VERSION:=5.0.1
|
|
77
|
+ VERSION:=5.0.4
|
78
|
78
|
DEPENDS+= +erlang +erlang-hipe
|
79
|
79
|
endef
|
80
|
80
|
|
|
@@ -89,7 +89,7 @@ endef
|
89
|
89
|
define Package/erlang-crypto
|
90
|
90
|
$(call Package/erlang/Default)
|
91
|
91
|
TITLE:=Cryptography support
|
92
|
|
- VERSION:=3.4
|
|
92
|
+ VERSION:=3.5
|
93
|
93
|
DEPENDS+= +erlang +libopenssl
|
94
|
94
|
endef
|
95
|
95
|
|
|
@@ -104,7 +104,7 @@ endef
|
104
|
104
|
define Package/erlang-hipe
|
105
|
105
|
$(call Package/erlang/Default)
|
106
|
106
|
TITLE:=High Performance Erlang
|
107
|
|
- VERSION:=3.11
|
|
107
|
+ VERSION:=3.11.3
|
108
|
108
|
DEPENDS+= +erlang
|
109
|
109
|
endef
|
110
|
110
|
|
|
@@ -119,7 +119,7 @@ endef
|
119
|
119
|
define Package/erlang-inets
|
120
|
120
|
$(call Package/erlang/Default)
|
121
|
121
|
TITLE:=Internet clients and servers
|
122
|
|
- VERSION:=5.10.2
|
|
122
|
+ VERSION:=5.10.6
|
123
|
123
|
DEPENDS+= +erlang
|
124
|
124
|
endef
|
125
|
125
|
|
|
@@ -135,7 +135,7 @@ endef
|
135
|
135
|
define Package/erlang-mnesia
|
136
|
136
|
$(call Package/erlang/Default)
|
137
|
137
|
TITLE:=Distributed database
|
138
|
|
- VERSION:=4.12.1
|
|
138
|
+ VERSION:=4.12.5
|
139
|
139
|
DEPENDS+= +erlang
|
140
|
140
|
endef
|
141
|
141
|
|
|
@@ -152,7 +152,7 @@ endef
|
152
|
152
|
define Package/erlang-runtime-tools
|
153
|
153
|
$(call Package/erlang/Default)
|
154
|
154
|
TITLE:=Low-profile debugging/tracing tools
|
155
|
|
- VERSION:=1.8.14
|
|
155
|
+ VERSION:=1.8.16
|
156
|
156
|
DEPENDS+= +erlang
|
157
|
157
|
endef
|
158
|
158
|
|
|
@@ -167,7 +167,7 @@ endef
|
167
|
167
|
define Package/erlang-snmp
|
168
|
168
|
$(call Package/erlang/Default)
|
169
|
169
|
TITLE:=Simple Network Management Protocol (SNMP) support
|
170
|
|
- VERSION:=4.25.1
|
|
170
|
+ VERSION:=5.1.1
|
171
|
171
|
DEPENDS+= +erlang +erlang-asn1
|
172
|
172
|
endef
|
173
|
173
|
|
|
@@ -183,7 +183,7 @@ endef
|
183
|
183
|
define Package/erlang-ssh
|
184
|
184
|
$(call Package/erlang/Default)
|
185
|
185
|
TITLE:=Secure Shell (SSH) support
|
186
|
|
- VERSION:=3.0.3
|
|
186
|
+ VERSION:=3.2
|
187
|
187
|
DEPENDS+= +erlang +erlang-crypto
|
188
|
188
|
endef
|
189
|
189
|
|
|
@@ -198,7 +198,7 @@ endef
|
198
|
198
|
define Package/erlang-ssl
|
199
|
199
|
$(call Package/erlang/Default)
|
200
|
200
|
TITLE:=Secure Sockets Layer (SSL) support
|
201
|
|
- VERSION:=5.3.5
|
|
201
|
+ VERSION:=6.0
|
202
|
202
|
DEPENDS+= +erlang +erlang-crypto
|
203
|
203
|
endef
|
204
|
204
|
|
|
@@ -213,7 +213,7 @@ endef
|
213
|
213
|
define Package/erlang-syntax-tools
|
214
|
214
|
$(call Package/erlang/Default)
|
215
|
215
|
TITLE:=Abstract Erlang syntax trees handling support
|
216
|
|
- VERSION:=1.6.15
|
|
216
|
+ VERSION:=1.6.18
|
217
|
217
|
DEPENDS+= +erlang
|
218
|
218
|
endef
|
219
|
219
|
|
|
@@ -300,9 +300,9 @@ endef
|
300
|
300
|
|
301
|
301
|
define Build/InstallDev
|
302
|
302
|
$(INSTALL_DIR) $(1)/usr/lib
|
303
|
|
- $(CP) $(PKG_BUILD_DIR)/lib/erl_interface/obj/*/*.a $(1)/usr/lib
|
|
303
|
+ $(CP) $(PKG_BUILD_DIR)/lib/erl_interface/obj/*/*.a $(1)/usr/lib/
|
304
|
304
|
$(INSTALL_DIR) $(1)/usr/include
|
305
|
|
- $(CP) $(PKG_BUILD_DIR)/lib/erl_interface/include/*.h $(1)/usr/include
|
|
305
|
+ $(CP) $(PKG_BUILD_DIR)/lib/erl_interface/include/*.h $(1)/usr/include/
|
306
|
306
|
endef
|
307
|
307
|
|
308
|
308
|
define BuildModule
|