Browse Source

rsync: add support for ACL and XATTR

Signed-off-by: Maxim Storchak <m.storchak@gmail.com>
Maxim Storchak 10 years ago
parent
commit
174ee67042
2 changed files with 30 additions and 3 deletions
  1. 12
    0
      net/rsync/Config.in
  2. 18
    3
      net/rsync/Makefile

+ 12
- 0
net/rsync/Config.in View File

@@ -0,0 +1,12 @@
1
+if PACKAGE_rsync
2
+
3
+	config RSYNC_xattr
4
+		bool
5
+		prompt "Enable xattr support"
6
+		default n
7
+
8
+	config RSYNC_acl
9
+		bool
10
+		prompt "Enable ACL support"
11
+		default n
12
+endif

+ 18
- 3
net/rsync/Makefile View File

@@ -26,10 +26,27 @@ define Package/rsync
26 26
   CATEGORY:=Network
27 27
   SUBMENU:=File Transfer
28 28
   TITLE:=Fast remote file copy program (like rcp)
29
-  DEPENDS:=+libpopt +zlib
29
+  DEPENDS:=+libpopt +zlib +RSYNC_xattr:libattr +RSYNC_acl:libacl
30 30
   URL:=http://rsync.samba.org/
31
+  MENU:=1
31 32
 endef
32 33
 
34
+define Package/rsync/config
35
+	source "$(SOURCE)/Config.in"
36
+endef
37
+
38
+ifeq ($(CONFIG_RSYNC_xattr),y)
39
+	CONFIGURE_ARGS+= --enable-xattr-support
40
+else
41
+	CONFIGURE_ARGS+= --disable-xattr-support
42
+endif
43
+
44
+ifeq ($(CONFIG_RSYNC_acl),y)
45
+	CONFIGURE_ARGS+= --enable-acl-support
46
+else
47
+	CONFIGURE_ARGS+= --disable-acl-support
48
+endif
49
+
33 50
 define Package/rsyncd
34 51
   SECTION:=net
35 52
   CATEGORY:=Network
@@ -54,8 +71,6 @@ CONFIGURE_ARGS += \
54 71
 	--with-included-zlib=no \
55 72
 	--disable-debug \
56 73
 	--disable-locale \
57
-	--disable-xattr-support \
58
-	--disable-acl-support \
59 74
 
60 75
 define Package/rsync/install
61 76
 	$(INSTALL_DIR) $(1)/usr/bin