Browse Source

nginx: make depencies more stricter

This should fix isse #54. It should no not be possible to select an
nginx subpackage without the appropriate module.

Signed-off-by: Thomas Heil <heil@terminal-consulting.de>
Thomas Heil 10 years ago
parent
commit
17925c4e33
2 changed files with 10 additions and 7 deletions
  1. 4
    1
      net/nginx/Config.in
  2. 6
    6
      net/nginx/Makefile

+ 4
- 1
net/nginx/Config.in View File

@@ -162,13 +162,15 @@ config NGINX_NAXSI
162 162
 	bool
163 163
 	prompt "Enable NAXSI module"
164 164
 	select PACKAGE_nginx-naxsi
165
+	default y
165 166
 	help
166 167
 		Enable support for NAXSI WAF.
167 168
 
168 169
 config NGINX_PROXYPROTOCOL
169 170
 	bool
170
-	prompt "Enable NAXSI proxyprotocol"
171
+	prompt "Enable HAProxy proxyprotocol"
171 172
 	select PACKAGE_nginx-proxyprotocol
173
+	default y
172 174
 	help
173 175
 		Enable support for NAXSI WAF.
174 176
 
@@ -176,6 +178,7 @@ config NGINX_SYSLOG
176 178
 	bool
177 179
 	prompt "Enable Syslog module"
178 180
 	select PACKAGE_nginx-syslog
181
+	default y
179 182
 	help
180 183
 		Provides the ability log to a remote destination
181 184
 

+ 6
- 6
net/nginx/Makefile View File

@@ -252,8 +252,8 @@ endef
252 252
 define Package/nginx-naxsi
253 253
         MENU:=1
254 254
         $(call Package/nginx)
255
-        TITLE+= nginx-naxsi
256
-        DEPENDS:=nginx
255
+        TITLE:=nginx-naxsi
256
+        DEPENDS:=nginx @NGINX_NAXSI
257 257
 endef
258 258
 
259 259
 define Package/nginx-naxsi/description
@@ -263,8 +263,8 @@ endef
263 263
 define Package/nginx-proxyprotocol
264 264
         MENU:=1
265 265
         $(call Package/nginx)
266
-        TITLE+= nginx-proxyprotocol
267
-        DEPENDS:=nginx
266
+        TITLE:=nginx 
267
+        DEPENDS:=nginx @NGINX_PROXYPROTOCOL
268 268
 endef
269 269
 
270 270
 define Package/nginx-proxyprotocol/description
@@ -274,8 +274,8 @@ endef
274 274
 define Package/nginx-syslog
275 275
         MENU:=1
276 276
         $(call Package/nginx)
277
-        TITLE+= nginx-syslog
278
-        DEPENDS:=nginx
277
+        TITLE:=nginx-syslog
278
+        DEPENDS:=nginx @NGINX_SYSLOG
279 279
 endef
280 280
 
281 281
 define Package/nginx-syslog/description