Browse Source

ocserv: correct md5sum, install ocserv-fw, and eliminate ip dependency

Signed-off-by: Nikos Mavrogiannopoulos <nmav@gnutls.org>
Nikos Mavrogiannopoulos 9 years ago
parent
commit
18595194cf
2 changed files with 8 additions and 7 deletions
  1. 4
    3
      net/ocserv/Makefile
  2. 4
    4
      net/ocserv/files/ocserv.conf.template

+ 4
- 3
net/ocserv/Makefile View File

@@ -9,13 +9,13 @@ include $(TOPDIR)/rules.mk
9 9
 
10 10
 PKG_NAME:=ocserv
11 11
 PKG_VERSION:=0.10.10
12
-PKG_RELEASE:=1
12
+PKG_RELEASE:=2
13 13
 PKG_USE_MIPS16:=0
14 14
 
15 15
 PKG_BUILD_DIR :=$(BUILD_DIR)/$(PKG_NAME)-$(PKG_VERSION)
16 16
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.xz
17 17
 PKG_SOURCE_URL:=ftp://ftp.infradead.org/pub/ocserv/
18
-PKG_MD5SUM:=99c75719e02937deb03263f80d29ac1b
18
+PKG_MD5SUM:=1f73ccb66d36cd51279323e95ae99e68
19 19
 
20 20
 PKG_LICENSE:=GPLv2
21 21
 PKG_LICENSE_FILES:=COPYING
@@ -39,7 +39,7 @@ define Package/ocserv
39 39
   TITLE:=OpenConnect VPN server
40 40
   URL:=http://www.infradead.org/ocserv/
41 41
   MAINTAINER:=Nikos Mavrogiannopoulos <n.mavrogiannopoulos@gmail.com>
42
-  DEPENDS:= +OCSERV_RADIUS:libradcli +OCSERV_HTTP_PARSER:libhttp-parser +OCSERV_SECCOMP:libseccomp +libgnutls +certtool +libncurses +libreadline +OCSERV_PAM:libpam +OCSERV_PROTOBUF:libprotobuf-c +kmod-tun +ip
42
+  DEPENDS:= +OCSERV_RADIUS:libradcli +OCSERV_HTTP_PARSER:libhttp-parser +OCSERV_SECCOMP:libseccomp +libgnutls +certtool +libncurses +libreadline +OCSERV_PAM:libpam +OCSERV_PROTOBUF:libprotobuf-c +kmod-tun
43 43
   USERID:=ocserv=72:ocserv=72
44 44
 endef
45 45
 
@@ -90,6 +90,7 @@ endef
90 90
 define Package/ocserv/install
91 91
 	$(INSTALL_DIR) $(1)/usr/sbin
92 92
 	$(INSTALL_BIN) $(PKG_BUILD_DIR)/src/ocserv $(1)/usr/sbin/
93
+	$(INSTALL_BIN) $(PKG_BUILD_DIR)/src/ocserv-fw $(1)/usr/sbin/
93 94
 	$(INSTALL_DIR) $(1)/usr/bin
94 95
 	$(INSTALL_BIN) $(PKG_BUILD_DIR)/src/ocpasswd $(1)/usr/bin/
95 96
 	$(INSTALL_BIN) $(PKG_BUILD_DIR)/src/occtl $(1)/usr/bin/

+ 4
- 4
net/ocserv/files/ocserv.conf.template View File

@@ -343,11 +343,11 @@ config-per-group = /etc/ocserv/config-per-group/
343 343
 # The following example is from linux systems. %{R} should be something
344 344
 # like 192.168.2.0/24
345 345
 
346
-route-add-cmd = "/usr/sbin/ip route add %{R} dev %{D}"
347
-route-del-cmd = "/usr/sbin/ip route delete %{R} dev %{D}"
346
+#route-add-cmd = "/usr/sbin/ip route add %{R} dev %{D}"
347
+#route-del-cmd = "/usr/sbin/ip route delete %{R} dev %{D}"
348 348
 
349
-#route-add-cmd = "/sbin/route add -net %{RI} dev %{D}"
350
-#route-del-cmd = "/sbin/route del -net %{RI} dev %{D}"
349
+route-add-cmd = "/sbin/route add -net %{RI} dev %{D}"
350
+route-del-cmd = "/sbin/route del -net %{RI} dev %{D}"
351 351
 
352 352
 # This option allows to forward a proxy. The special strings '%{U}'
353 353
 # and '%{G}', if present will be replaced by the username and group name.