|
@@ -1,58 +1,58 @@
|
1
|
1
|
--- a/configure.ac
|
2
|
2
|
+++ b/configure.ac
|
3
|
|
-@@ -580,6 +580,9 @@ AC_CHECK_HEADERS(net/pfvar.h,
|
|
3
|
+@@ -589,6 +589,9 @@ AC_CHECK_HEADERS(net/pfvar.h,
|
4
|
4
|
have_termios_h="no"
|
5
|
5
|
AC_CHECK_HEADERS(termios.h, [have_termios_h="yes"])
|
6
|
6
|
|
7
|
7
|
+# For the iwinfo plugin
|
8
|
8
|
+AC_CHECK_LIB(iwinfo, iwinfo_backend, [with_iwinfo="yes"], [with_iwinfo="no (libiwinfo not found)"], [])
|
9
|
9
|
+
|
10
|
|
- #
|
11
|
|
- # Checks for typedefs, structures, and compiler characteristics.
|
12
|
|
- #
|
13
|
|
-@@ -4841,6 +4844,7 @@ plugin_interface="no"
|
|
10
|
+ # For the turbostat plugin
|
|
11
|
+ have_asm_msrindex_h="no"
|
|
12
|
+ AC_CHECK_HEADERS(asm/msr-index.h, [have_asm_msrindex_h="yes"])
|
|
13
|
+@@ -5171,6 +5174,7 @@ plugin_interface="no"
|
14
|
14
|
plugin_ipmi="no"
|
15
|
15
|
plugin_ipvs="no"
|
16
|
16
|
plugin_irq="no"
|
17
|
17
|
+plugin_iwinfo="no"
|
18
|
|
- plugin_libvirt="no"
|
19
|
18
|
plugin_load="no"
|
|
19
|
+ plugin_log_logstash="no"
|
20
|
20
|
plugin_memory="no"
|
21
|
|
-@@ -5179,6 +5183,7 @@ AC_PLUGIN([ipmi], [$plugin_ipmi],
|
|
21
|
+@@ -5562,6 +5566,7 @@ AC_PLUGIN([ipmi], [$plugin_ipmi],
|
22
|
22
|
AC_PLUGIN([iptables], [$with_libiptc], [IPTables rule counters])
|
23
|
23
|
AC_PLUGIN([ipvs], [$plugin_ipvs], [IPVS connection statistics])
|
24
|
24
|
AC_PLUGIN([irq], [$plugin_irq], [IRQ statistics])
|
25
|
25
|
+AC_PLUGIN([iwinfo], [$with_iwinfo], [Common iwinfo wireless statistics])
|
26
|
26
|
AC_PLUGIN([java], [$with_java], [Embed the Java Virtual Machine])
|
27
|
|
- AC_PLUGIN([libvirt], [$plugin_libvirt], [Virtual machine statistics])
|
28
|
27
|
AC_PLUGIN([load], [$plugin_load], [System load])
|
29
|
|
-@@ -5480,6 +5485,7 @@ Configuration:
|
30
|
|
- protobuf-c . . . . . $have_protoc_c
|
|
28
|
+ AC_PLUGIN([logfile], [yes], [File logging plugin])
|
|
29
|
+@@ -5891,6 +5896,7 @@ Configuration:
|
31
|
30
|
oracle . . . . . . . $with_oracle
|
|
31
|
+ protobuf-c . . . . . $have_protoc_c
|
32
|
32
|
python . . . . . . . $with_python
|
33
|
33
|
+ iwinfo . . . . . . . $with_iwinfo
|
34
|
34
|
|
35
|
35
|
Features:
|
36
|
36
|
daemon mode . . . . . $enable_daemon
|
37
|
|
-@@ -5524,6 +5530,7 @@ Configuration:
|
|
37
|
+@@ -5940,6 +5946,7 @@ Configuration:
|
38
|
38
|
iptables . . . . . . $enable_iptables
|
39
|
39
|
ipvs . . . . . . . . $enable_ipvs
|
40
|
40
|
irq . . . . . . . . . $enable_irq
|
41
|
41
|
+ iwinfo . . . . . . . $enable_iwinfo
|
42
|
42
|
java . . . . . . . . $enable_java
|
43
|
|
- libvirt . . . . . . . $enable_libvirt
|
44
|
43
|
load . . . . . . . . $enable_load
|
|
44
|
+ logfile . . . . . . . $enable_logfile
|
45
|
45
|
--- a/src/collectd.conf.in
|
46
|
46
|
+++ b/src/collectd.conf.in
|
47
|
|
-@@ -109,6 +109,7 @@
|
|
47
|
+@@ -128,6 +128,7 @@
|
48
|
48
|
#@BUILD_PLUGIN_IPMI_TRUE@LoadPlugin ipmi
|
49
|
49
|
#@BUILD_PLUGIN_IPVS_TRUE@LoadPlugin ipvs
|
50
|
50
|
#@BUILD_PLUGIN_IRQ_TRUE@LoadPlugin irq
|
51
|
51
|
+#@BUILD_PLUGIN_IWINFO_TRUE@LoadPlugin iwinfo
|
52
|
52
|
#@BUILD_PLUGIN_JAVA_TRUE@LoadPlugin java
|
53
|
|
- #@BUILD_PLUGIN_LIBVIRT_TRUE@LoadPlugin libvirt
|
54
|
53
|
@BUILD_PLUGIN_LOAD_TRUE@@BUILD_PLUGIN_LOAD_TRUE@LoadPlugin load
|
55
|
|
-@@ -502,6 +503,12 @@
|
|
54
|
+ #@BUILD_PLUGIN_LPAR_TRUE@LoadPlugin lpar
|
|
55
|
+@@ -582,6 +583,12 @@
|
56
|
56
|
# IgnoreSelected true
|
57
|
57
|
#</Plugin>
|
58
|
58
|
|
|
@@ -62,12 +62,12 @@
|
62
|
62
|
+# Interface "wlan0"
|
63
|
63
|
+#</Plugin>
|
64
|
64
|
+
|
65
|
|
- #<Plugin "java">
|
|
65
|
+ #<Plugin java>
|
66
|
66
|
# JVMArg "-verbose:jni"
|
67
|
67
|
# JVMArg "-Djava.class.path=@prefix@/share/collectd/java/collectd-api.jar"
|
68
|
68
|
--- a/src/collectd.conf.pod
|
69
|
69
|
+++ b/src/collectd.conf.pod
|
70
|
|
-@@ -2077,6 +2077,27 @@ and all other interrupts are collected.
|
|
70
|
+@@ -2572,6 +2572,27 @@ and all other interrupts are collected.
|
71
|
71
|
|
72
|
72
|
=back
|
73
|
73
|
|
|
@@ -250,17 +250,15 @@
|
250
|
250
|
+}
|
251
|
251
|
--- a/src/Makefile.am
|
252
|
252
|
+++ b/src/Makefile.am
|
253
|
|
-@@ -530,6 +530,15 @@ collectd_LDADD += "-dlopen" irq.la
|
254
|
|
- collectd_DEPENDENCIES += irq.la
|
|
253
|
+@@ -459,6 +459,13 @@ irq_la_SOURCES = irq.c \
|
|
254
|
+ irq_la_LDFLAGS = $(PLUGIN_LDFLAGS)
|
255
|
255
|
endif
|
256
|
256
|
|
257
|
257
|
+if BUILD_PLUGIN_IWINFO
|
258
|
258
|
+pkglib_LTLIBRARIES += iwinfo.la
|
259
|
|
-+iwinfo_la_SOURCES = iwinfo.c
|
|
259
|
++iwinfo_la_SOURCES = iwinfo.c utils_ignorelist.c utils_ignorelist.h
|
260
|
260
|
+iwinfo_la_LDFLAGS = -module -avoid-version
|
261
|
261
|
+iwinfo_la_LIBADD = -liwinfo
|
262
|
|
-+collectd_LDADD += "-dlopen" iwinfo.la
|
263
|
|
-+collectd_DEPENDENCIES += iwinfo.la
|
264
|
262
|
+endif
|
265
|
263
|
+
|
266
|
264
|
if BUILD_PLUGIN_JAVA
|
|
@@ -268,12 +266,11 @@
|
268
|
266
|
java_la_SOURCES = java.c
|
269
|
267
|
--- a/src/types.db
|
270
|
268
|
+++ b/src/types.db
|
271
|
|
-@@ -195,7 +195,7 @@ voltage value:GAUGE:U:U
|
|
269
|
+@@ -227,6 +227,7 @@ voltage value:GAUGE:U:U
|
272
|
270
|
vs_memory value:GAUGE:0:9223372036854775807
|
273
|
271
|
vs_processes value:GAUGE:0:65535
|
274
|
272
|
vs_threads value:GAUGE:0:65535
|
275
|
|
--
|
276
|
273
|
+stations value:GAUGE:0:256
|
|
274
|
+
|
277
|
275
|
#
|
278
|
276
|
# Legacy types
|
279
|
|
- # (required for the v5 upgrade target)
|