Procházet zdrojové kódy

tgt: update to 1.0.61

Signed-off-by: Maxim Storchak <m.storchak@gmail.com>
Maxim Storchak před 9 roky
rodič
revize
186b29820a

+ 3
- 3
net/tgt/Makefile Zobrazit soubor

@@ -7,9 +7,9 @@
7 7
 include $(TOPDIR)/rules.mk
8 8
 
9 9
 PKG_NAME:=tgt
10
-PKG_VERSION:=1.0.53
11
-PKG_REV:=9764e0afd9a7115e356fc85569a780f9003c4eac
12
-PKG_RELEASE:=4
10
+PKG_VERSION:=1.0.61
11
+PKG_REV:=f13345e12f49e5bcae2cfd6c5c7d530b328753f0
12
+PKG_RELEASE:=1
13 13
 PKG_USE_MIPS16:=0
14 14
 
15 15
 PKG_SOURCE_PROTO:=git

+ 0
- 14
net/tgt/patches/010-fallocate.patch Zobrazit soubor

@@ -1,14 +0,0 @@
1
---- tgt-1.0.48.orig/usr/util.h	2014-06-04 15:03:53.000000000 +0300
2
-+++ tgt-1.0.48/usr/util.h	2014-06-04 15:17:48.548123039 +0300
3
-@@ -212,11 +212,6 @@
4
-  */
5
- static inline int unmap_file_region(int fd, off_t offset, off_t length)
6
- {
7
--#ifdef FALLOC_FL_PUNCH_HOLE
8
--	if (fallocate(fd, FALLOC_FL_KEEP_SIZE | FALLOC_FL_PUNCH_HOLE,
9
--			offset, length) == 0)
10
--		return 0;
11
--#endif
12
- 	return -1;
13
- }
14
- 

+ 8
- 6
net/tgt/patches/020-usr_Makefile.patch Zobrazit soubor

@@ -1,5 +1,7 @@
1
---- tgt-1.0.48.orig/usr/Makefile	2014-06-04 15:03:53.000000000 +0300
2
-+++ tgt-1.0.48/usr/Makefile	2014-06-04 15:17:56.373670618 +0300
1
+diff --git a/usr/Makefile b/usr/Makefile
2
+index 1fae7e7..b05b970 100644
3
+--- a/usr/Makefile
4
++++ b/usr/Makefile
3 5
 @@ -1,13 +1,13 @@
4 6
  sbindir ?= $(PREFIX)/sbin
5 7
  libdir ?= $(PREFIX)/lib/tgt
@@ -18,7 +20,7 @@
18 20
  
19 21
  TGTD_OBJS += $(addprefix iscsi/, conn.o param.o session.o \
20 22
  		iscsid.o target.o chap.o sha1.o md5.o transport.o iscsi_tcp.o \
21
-@@ -25,8 +25,9 @@
23
+@@ -25,8 +25,9 @@ ifneq ($(SD_NOTIFY),)
22 24
  CFLAGS += -DUSE_SYSTEMD
23 25
  endif
24 26
  
@@ -30,8 +32,8 @@
30 32
  TGTD_OBJS += bs_aio.o
31 33
  LIBS += -laio
32 34
  endif
33
-@@ -55,7 +56,7 @@
34
- LIBS += -lsystemd-daemon
35
+@@ -55,7 +56,7 @@ ifneq ($(SD_NOTIFY),)
36
+ LIBS += -lsystemd
35 37
  endif
36 38
  
37 39
 -PROGRAMS += tgtd tgtadm tgtimg
@@ -39,7 +41,7 @@
39 41
  TGTD_OBJS += tgtd.o mgmt.o target.o scsi.o log.o driver.o util.o work.o \
40 42
  		concat_buf.o parser.o spc.o sbc.o mmc.o osd.o scc.o smc.o \
41 43
  		ssc.o libssc.o bs_rdwr.o bs_ssc.o \
42
-@@ -82,14 +83,8 @@
44
+@@ -82,14 +83,8 @@ tgtadm: $(TGTADM_OBJS)
43 45
  
44 46
  -include $(TGTADM_DEP)
45 47
  

+ 6
- 12
net/tgt/patches/100-musl-compat.patch Zobrazit soubor

@@ -1,3 +1,5 @@
1
+diff --git a/usr/tgtd.h b/usr/tgtd.h
2
+index d8b2ac1..c6eee54 100644
1 3
 --- a/usr/tgtd.h
2 4
 +++ b/usr/tgtd.h
3 5
 @@ -9,6 +9,10 @@
@@ -5,12 +7,14 @@
5 7
  #endif
6 8
  
7 9
 +#ifndef __WORDSIZE
8
-+#include <sys/user.h>
10
++#include <sys/reg.h>
9 11
 +#endif
10 12
 +
11 13
  struct concat_buf;
12 14
  
13 15
  #define NR_SCSI_OPCODES		256
16
+diff --git a/usr/util.h b/usr/util.h
17
+index 0e34c35..3e2e63b 100644
14 18
 --- a/usr/util.h
15 19
 +++ b/usr/util.h
16 20
 @@ -16,6 +16,10 @@
@@ -18,19 +22,9 @@
18 22
  #include <linux/types.h>
19 23
  
20 24
 +#ifndef __WORDSIZE
21
-+#include <sys/user.h>
25
++#include <sys/reg.h>
22 26
 +#endif
23 27
 +
24 28
  #include "be_byteshift.h"
25 29
  
26 30
  #define roundup(x, y) ((((x) + ((y) - 1)) / (y)) * (y))
27
---- a/usr/libssc.c
28
-+++ b/usr/libssc.c
29
-@@ -23,6 +23,7 @@
30
- #include <string.h>
31
- #include <unistd.h>
32
- #include <stdio.h>
33
-+#include <fcntl.h>
34
- #include "bs_ssc.h"
35
- #include "ssc.h"
36
- #include "be_byteshift.h"