Przeglądaj źródła

Add package: bc

Copied from oldpackages and slightly updated.

Signed-off-by: Bruno Randolf <br1@einfach.org>
Bruno Randolf 9 lat temu
rodzic
commit
18dbe6dbfd
2 zmienionych plików z 86 dodań i 0 usunięć
  1. 65
    0
      utils/bc/Makefile
  2. 21
    0
      utils/bc/patches/001-disable-doc.patch

+ 65
- 0
utils/bc/Makefile Wyświetl plik

@@ -0,0 +1,65 @@
1
+#
2
+# Copyright (C) 2006-2015 OpenWrt.org
3
+#
4
+# This is free software, licensed under the GNU General Public License v2.
5
+# See /LICENSE for more information.
6
+#
7
+
8
+include $(TOPDIR)/rules.mk
9
+
10
+PKG_NAME:=bc
11
+PKG_VERSION:=1.06.95
12
+PKG_RELEASE:=1
13
+
14
+PKG_SOURCE:=$(PKG_NAME)_$(PKG_VERSION).orig.tar.gz
15
+PKG_SOURCE_URL:=ftp://ftp.debian.org/debian/pool/main/b/bc
16
+PKG_MD5SUM:=24d0831812d8262b6cac8316b0bac483
17
+
18
+PKG_MAINTAINER:=Bruno Randolf <br1@einfach.org>
19
+PKG_LICENSE:=GPL-2.0
20
+PKG_LICENSE_FILES:=COPYING
21
+
22
+include $(INCLUDE_DIR)/package.mk
23
+
24
+define Package/bc/Default
25
+  SECTION:=utils
26
+  CATEGORY:=Utilities
27
+  URL:=http://packages.debian.org/bc
28
+endef
29
+
30
+define Package/bc
31
+  $(call Package/bc/Default)
32
+  TITLE:=Arbitrary precision calculator language
33
+  DEPENDS:=+libreadline +libncurses
34
+endef
35
+
36
+define Package/bc/description
37
+ bc is a language that supports arbitrary precision numbers with
38
+ interactive execution of statements.
39
+endef
40
+
41
+define Package/dc
42
+  $(call Package/bc/Default)
43
+  TITLE:=Arbitrary precision reverse-polish calculator
44
+  DEPENDS:=bc
45
+endef
46
+
47
+define Package/dc/description
48
+ dc is a reverse-polish desk calculator which supports unlimited
49
+ precision arithmetic.
50
+endef
51
+
52
+CONFIGURE_ARGS += --with-readline
53
+
54
+define Package/bc/install
55
+	$(INSTALL_DIR) $(1)/usr/bin
56
+	$(INSTALL_BIN) $(PKG_BUILD_DIR)/bc/bc $(1)/usr/bin/
57
+endef
58
+
59
+define Package/dc/install
60
+	$(INSTALL_DIR) $(1)/usr/bin
61
+	$(INSTALL_BIN) $(PKG_BUILD_DIR)/dc/dc $(1)/usr/bin/
62
+endef
63
+
64
+$(eval $(call BuildPackage,bc))
65
+$(eval $(call BuildPackage,dc))

+ 21
- 0
utils/bc/patches/001-disable-doc.patch Wyświetl plik

@@ -0,0 +1,21 @@
1
+--- bc-1.06.95/Makefile.in	2010-07-03 10:48:13.422725147 +0000
2
++++ bc-1.06.95/Makefile.in	2010-07-03 10:50:09.714725197 +0000
3
+@@ -149,7 +149,7 @@
4
+ sharedstatedir = @sharedstatedir@
5
+ sysconfdir = @sysconfdir@
6
+ target_alias = @target_alias@
7
+-SUBDIRS = lib bc dc doc
8
++SUBDIRS = lib bc dc
9
+ MAINTAINERCLEANFILES = aclocal.m4 config.h.in configure Makefile.in \
10
+ 			stamp-h $(distdir).tar.gz h/number.h depcomp missing
11
+ 
12
+--- bc-1.06.95/Makefile.am	2010-07-03 10:48:32.522725037 +0000
13
++++ bc-1.06.95/Makefile.am	2010-07-03 10:48:38.114725024 +0000
14
+@@ -1,6 +1,6 @@
15
+ ## Process this file with automake to produce Makefile.in
16
+ 
17
+-SUBDIRS = lib bc dc doc
18
++SUBDIRS = lib bc dc
19
+ 
20
+ MAINTAINERCLEANFILES =  aclocal.m4 config.h.in configure Makefile.in \
21
+ 			stamp-h $(distdir).tar.gz h/number.h depcomp missing