瀏覽代碼

openvswitch: add +kmod-vxlan dependency for kernels >= 3.12

When OVS detects a kernel version >= 3.12 it does not build
it's own vxlan module and tries to use the kernel's, when building
the OVS kernel module.

I also pushed a patch to the OpenWRT trunk to add a +kmod-vxlan package.

This will add the kernel's vxlan.ko kernel module if it exists.
So, for kernel >= 3.12, this package should exist and be installed
when installing OVS.

Tested on OpenWRT trunk with kernel 3.14.18.

Signed-off-by: Alexandru Ardelean <ardeleanalex@gmail.com>
Alexandru Ardelean 10 年之前
父節點
當前提交
194c0f608a
共有 1 個檔案被更改,包括 1 行新增1 行删除
  1. 1
    1
      net/openvswitch/Makefile

+ 1
- 1
net/openvswitch/Makefile 查看文件

@@ -94,7 +94,7 @@ define KernelPackage/openvswitch
94 94
   SUBMENU:=Network Support
95 95
   TITLE:=Open vSwitch Kernel Package
96 96
   KCONFIG:=CONFIG_BRIDGE
97
-  DEPENDS:=+kmod-stp +kmod-ipv6 +kmod-gre +kmod-lib-crc32c
97
+  DEPENDS:=+kmod-stp +kmod-ipv6 +kmod-gre +kmod-lib-crc32c +kmod-vxlan
98 98
   FILES:= \
99 99
 	$(PKG_BUILD_DIR)/datapath/linux/openvswitch.$(LINUX_KMOD_SUFFIX)
100 100
   AUTOLOAD:=$(call AutoLoad,21,openvswitch)