Procházet zdrojové kódy

Merge pull request #515 from Wedmer/master

utils/zoneifo: Moved from old packages with updates
sbyx před 10 roky
rodič
revize
1a2d453184
1 změnil soubory, kde provedl 259 přidání a 0 odebrání
  1. 259
    0
      utils/zoneinfo/Makefile

+ 259
- 0
utils/zoneinfo/Makefile Zobrazit soubor

@@ -0,0 +1,259 @@
1
+#
2
+# Copyright (C) 2007-2014 OpenWrt.org
3
+#
4
+# This is free software, licensed under the GNU General Public License v2.
5
+# See /LICENSE for more information.
6
+#
7
+# Author: Michael Geddes
8
+
9
+include $(TOPDIR)/rules.mk
10
+
11
+PKG_NAME:=zoneinfo
12
+PKG_VERSION:=2014i
13
+PKG_VERSION_CODE:=2014i
14
+PKG_RELEASE:=2
15
+
16
+#As i couldn't find real license used "Puplic Domain"
17
+#as referense to http://www.iana.org/time-zones/repository/tz-link.html
18
+PKG_LICENSE:=Public Domain
19
+
20
+PKG_SOURCE:=tzdata$(PKG_VERSION).tar.gz
21
+PKG_SOURCE_CODE:=tzcode$(PKG_VERSION_CODE).tar.gz
22
+PKG_SOURCE_URL:=http://www.iana.org/time-zones/repository/releases
23
+PKG_MD5SUM:=00adeb62a0897aac5ba67da838351adb
24
+
25
+include $(INCLUDE_DIR)/package.mk
26
+
27
+define Download/tzcode
28
+   FILE=$(PKG_SOURCE_CODE)
29
+   URL=$(PKG_SOURCE_URL)
30
+   MD5SUM=7fa413158f01a961348aa6a289b6be21
31
+endef
32
+
33
+$(eval $(call Download,tzcode))
34
+
35
+define Package/zoneinfo/Default
36
+  SUBMENU:=zoneinfo
37
+  TITLE:=Zone Information
38
+  SECTION:=utils
39
+  CATEGORY:=Utilities
40
+  MAINTAINER=Vladimir Ulrich <admin@evl.su>
41
+endef
42
+
43
+define Package/zoneinfo-core
44
+$(call Package/zoneinfo/Default)
45
+  TITLE:=Zone Information (core)
46
+endef
47
+
48
+define Package/zoneinfo-simple
49
+$(call Package/zoneinfo/Default)
50
+  TITLE:=Zone Information (simple)
51
+endef
52
+
53
+define Package/zoneinfo-africa
54
+$(call Package/zoneinfo/Default)
55
+  TITLE:=Zone Information (Africa)
56
+endef
57
+
58
+define Package/zoneinfo-northamerica
59
+$(call Package/zoneinfo/Default)
60
+  TITLE:=Zone Information (NorthAmerica)
61
+endef
62
+
63
+define Package/zoneinfo-southamerica
64
+$(call Package/zoneinfo/Default)
65
+  TITLE:=Zone Information (SouthAmerica)
66
+endef
67
+
68
+define Package/zoneinfo-poles
69
+$(call Package/zoneinfo/Default)
70
+  TITLE:=Zone Information (Arctic, Antarctic)
71
+endef
72
+
73
+define Package/zoneinfo-asia
74
+$(call Package/zoneinfo/Default)
75
+  TITLE:=Zone Information (Asia)
76
+endef
77
+
78
+define Package/zoneinfo-atlantic
79
+$(call Package/zoneinfo/Default)
80
+  TITLE:=Zone Information (Atlantic)
81
+endef
82
+
83
+define Package/zoneinfo-australia-nz
84
+$(call Package/zoneinfo/Default)
85
+  TITLE:=Zone Information (Australia-NZ)
86
+endef
87
+
88
+define Package/zoneinfo-pacific
89
+$(call Package/zoneinfo/Default)
90
+  TITLE:=Zone Information (Pacific)
91
+endef
92
+
93
+define Package/zoneinfo-europe
94
+$(call Package/zoneinfo/Default)
95
+  TITLE:=Zone Information (Europe)
96
+endef
97
+
98
+define Package/zoneinfo-india
99
+$(call Package/zoneinfo/Default)
100
+  TITLE:=Zone Information (India)
101
+endef
102
+
103
+define Package/zoneinfo-middleeast
104
+$(call Package/zoneinfo/Default)
105
+  TITLE:=Zone Information (MiddleEast)
106
+endef
107
+
108
+define Build/Prepare
109
+	(cd $(PKG_BUILD_DIR) && tar -xzf $(DL_DIR)/$(PKG_SOURCE_CODE) && tar -xzf $(DL_DIR)/$(PKG_SOURCE))
110
+endef
111
+
112
+define Build/Compile
113
+	CFLAGS="$(HOST_CFLAGS)" \
114
+	$(MAKE) -C $(PKG_BUILD_DIR) -f Makefile \
115
+		$(HOST_CONFIGURE_OPTS) \
116
+		CC="$(HOSTCC)" \
117
+		LD="\$$$$(CC)" \
118
+		CPPFLAGS="$(HOST_CPPFLAGS)" \
119
+		LDFLAGS="$(HOST_LDFLAGS)" \
120
+		TOPDIR="$(PKG_INSTALL_DIR)" \
121
+		TZDIR="$(PKG_INSTALL_DIR)/zoneinfo" \
122
+		install
123
+endef
124
+
125
+
126
+define Package/zoneinfo-core/install
127
+	$(INSTALL_DIR) $(1)/usr/share/zoneinfo
128
+	for i in \
129
+		CET CST6CDT EET EST EST5EDT GB-Eire Eire \
130
+		GB    GMT   GMT+0 GMT-0 GMT0  Greenwich  \
131
+		HST   MET   MST   MST7MDT                \
132
+		PRC   PST8PDT ROC ROK     UCT   UTC      \
133
+		Universal W-SU WET Zulu Etc/* zone.tab ; do \
134
+	  $(CP) $(PKG_INSTALL_DIR)/zoneinfo/$$$$i \
135
+	      $(1)/usr/share/zoneinfo ; \
136
+	done
137
+endef
138
+
139
+define Package/zoneinfo-simple/install
140
+	$(INSTALL_DIR) $(1)/usr/share/zoneinfo
141
+	for i in Pacific/Honolulu     \
142
+		America/Anchorage   America/Los_Angeles America/Denver   \
143
+		America/Chicago     America/New_York    America/Caracas  \
144
+		America/Sao_Paulo   Europe/London       Europe/Paris     \
145
+		Africa/Cairo        Europe/Moscow       Asia/Dubai       \
146
+		Asia/Karachi        Asia/Dhaka          Asia/Bankok      \
147
+		Asia/Hong_Kong      Asia/Tokyo          Australia/Darwin \
148
+		Australia/Adelaide  Australia/Brisbane  Australia/Sydney \
149
+		Australia/Perth     Pacific/Noumea ; do \
150
+	  $(CP) $(PKG_INSTALL_DIR)/zoneinfo/$$$$i \
151
+	      $(1)/usr/share/zoneinfo ; \
152
+	done
153
+endef
154
+
155
+define Package/zoneinfo-africa/install
156
+	$(INSTALL_DIR) $(1)/usr/share/zoneinfo/Africa
157
+	$(CP) $(PKG_INSTALL_DIR)/zoneinfo/Africa/* \
158
+	      $(1)/usr/share/zoneinfo/Africa
159
+endef
160
+
161
+define Package/zoneinfo-northamerica/install
162
+	$(INSTALL_DIR) $(1)/usr/share/zoneinfo
163
+	for i in US America Canada Mexico Cuba Jamaica Navajo ; do \
164
+	  $(CP) $(PKG_INSTALL_DIR)/zoneinfo/$$$$i \
165
+	      $(1)/usr/share/zoneinfo ; \
166
+	done
167
+	rm  -rf $(1)/usr/share/zoneinfo/America/Argentina
168
+endef
169
+
170
+define Package/zoneinfo-southamerica/install
171
+	$(INSTALL_DIR) $(1)/usr/share/zoneinfo
172
+	for i in Brazil Chile ; do \
173
+	  $(CP) $(PKG_INSTALL_DIR)/zoneinfo/$$$$i \
174
+	      $(1)/usr/share/zoneinfo ; \
175
+	done
176
+	$(INSTALL_DIR) $(1)/usr/share/zoneinfo/America/Argentina
177
+	$(CP) $(PKG_INSTALL_DIR)/zoneinfo/America/Argentina/* \
178
+	      $(1)/usr/share/zoneinfo/America/Argentina
179
+endef
180
+
181
+define Package/zoneinfo-poles/install
182
+	$(INSTALL_DIR) $(1)/usr/share/zoneinfo
183
+	for i in Antarctica Arctic ; do \
184
+	  $(CP) $(PKG_INSTALL_DIR)/zoneinfo/$$$$i \
185
+	      $(1)/usr/share/zoneinfo ; \
186
+	done
187
+endef
188
+
189
+define Package/zoneinfo-asia/install
190
+	$(INSTALL_DIR) $(1)/usr/share/zoneinfo
191
+	for i in Asia Japan Singapore Hongkong ; do \
192
+	  $(CP) $(PKG_INSTALL_DIR)/zoneinfo/$$$$i \
193
+	      $(1)/usr/share/zoneinfo ; \
194
+	done
195
+endef
196
+
197
+define Package/zoneinfo-atlantic/install
198
+	$(INSTALL_DIR) $(1)/usr/share/zoneinfo
199
+	for i in Atlantic Iceland ; do \
200
+	  $(CP) $(PKG_INSTALL_DIR)/zoneinfo/$$$$i \
201
+	      $(1)/usr/share/zoneinfo ; \
202
+	done
203
+endef
204
+
205
+define Package/zoneinfo-australia-nz/install
206
+	$(INSTALL_DIR) $(1)/usr/share/zoneinfo
207
+	for i in NZ NZ-CHAT Australia ; do \
208
+	  $(CP) $(PKG_INSTALL_DIR)/zoneinfo/$$$$i \
209
+	      $(1)/usr/share/zoneinfo ; \
210
+	done
211
+endef
212
+
213
+define Package/zoneinfo-pacific/install
214
+	$(INSTALL_DIR) $(1)/usr/share/zoneinfo
215
+	for i in Pacific Kwajalein ; do \
216
+	  $(CP) $(PKG_INSTALL_DIR)/zoneinfo/$$$$i \
217
+	      $(1)/usr/share/zoneinfo ; \
218
+	done
219
+endef
220
+
221
+define Package/zoneinfo-europe/install
222
+	$(INSTALL_DIR) $(1)/usr/share/zoneinfo
223
+	for i in Europe Portugal Poland ; do \
224
+	  $(CP) $(PKG_INSTALL_DIR)/zoneinfo/$$$$i \
225
+	      $(1)/usr/share/zoneinfo ; \
226
+	done
227
+endef
228
+
229
+
230
+define Package/zoneinfo-india/install
231
+	$(INSTALL_DIR) $(1)/usr/share/zoneinfo
232
+	for i in Indian ; do \
233
+	  $(CP) $(PKG_INSTALL_DIR)/zoneinfo/$$$$i \
234
+	      $(1)/usr/share/zoneinfo ; \
235
+	done
236
+endef
237
+
238
+define Package/zoneinfo-middleeast/install
239
+	$(INSTALL_DIR) $(1)/usr/share/zoneinfo
240
+	for i in Egypt Libya Iran Israel Turkey Mideast ; do \
241
+	  $(CP) $(PKG_INSTALL_DIR)/zoneinfo/$$$$i \
242
+	      $(1)/usr/share/zoneinfo ; \
243
+	done
244
+endef
245
+
246
+$(eval $(call BuildPackage,zoneinfo-simple))
247
+$(eval $(call BuildPackage,zoneinfo-core))
248
+$(eval $(call BuildPackage,zoneinfo-africa))
249
+$(eval $(call BuildPackage,zoneinfo-northamerica))
250
+$(eval $(call BuildPackage,zoneinfo-southamerica))
251
+$(eval $(call BuildPackage,zoneinfo-poles))
252
+$(eval $(call BuildPackage,zoneinfo-asia))
253
+$(eval $(call BuildPackage,zoneinfo-atlantic))
254
+$(eval $(call BuildPackage,zoneinfo-australia-nz))
255
+$(eval $(call BuildPackage,zoneinfo-pacific))
256
+$(eval $(call BuildPackage,zoneinfo-europe))
257
+$(eval $(call BuildPackage,zoneinfo-india))
258
+$(eval $(call BuildPackage,zoneinfo-middleeast))
259
+