Browse Source

Merge pull request #57 from champtar/format

PKG_CHECK_FORMAT_SECURITY: disable it for the failing packages (for now)
Merged before the changes to OpenWrt trunk in order to avoid regressions.
nbd168 10 years ago
parent
commit
1ac000b0d0
5 changed files with 5 additions and 0 deletions
  1. 1
    0
      libs/gnutls/Makefile
  2. 1
    0
      net/ctorrent-svn/Makefile
  3. 1
    0
      net/ntpd/Makefile
  4. 1
    0
      utils/unzip/Makefile
  5. 1
    0
      utils/zip/Makefile

+ 1
- 0
libs/gnutls/Makefile View File

@@ -18,6 +18,7 @@ PKG_MAINTAINER:=Nikos Mavrogiannopoulos <nmav@gnutls.org>
18 18
 
19 19
 PKG_INSTALL:=1
20 20
 PKG_LIBTOOL_PATHS:=. lib
21
+PKG_CHECK_FORMAT_SECURITY:=0
21 22
 
22 23
 include $(INCLUDE_DIR)/package.mk
23 24
 

+ 1
- 0
net/ctorrent-svn/Makefile View File

@@ -19,6 +19,7 @@ PKG_SOURCE_VERSION:=$(PKG_REV)
19 19
 PKG_SOURCE_PROTO:=svn
20 20
 
21 21
 PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(BUILD_VARIANT)/$(PKG_NAME)-$(PKG_VERSION)
22
+PKG_CHECK_FORMAT_SECURITY:=0
22 23
 
23 24
 include $(INCLUDE_DIR)/package.mk
24 25
 

+ 1
- 0
net/ntpd/Makefile View File

@@ -20,6 +20,7 @@ PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(BUILD_VARIANT)/$(PKG_NAME)-$(PKG_VERSI
20 20
 PKG_BUILD_DEPENDS:=libelf1
21 21
 PKG_FIXUP:=autoreconf
22 22
 PKG_LIBTOOL_PATHS:=. sntp
23
+PKG_CHECK_FORMAT_SECURITY:=0
23 24
 
24 25
 include $(INCLUDE_DIR)/package.mk
25 26
 

+ 1
- 0
utils/unzip/Makefile View File

@@ -21,6 +21,7 @@ PKG_LICENSE:=BSD-4-Clause
21 21
 PKG_LICENSE_FILES:=LICENSE
22 22
 
23 23
 PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(PKG_VERSION)/unzip$(PKG_REV)
24
+PKG_CHECK_FORMAT_SECURITY:=0
24 25
 
25 26
 include $(INCLUDE_DIR)/package.mk
26 27
 

+ 1
- 0
utils/zip/Makefile View File

@@ -21,6 +21,7 @@ PKG_LICENSE:=BSD-4-Clause
21 21
 PKG_LICENSE_FILES:=LICENSE
22 22
 
23 23
 PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(PKG_VERSION)/zip$(PKG_REV)
24
+PKG_CHECK_FORMAT_SECURITY:=0
24 25
 
25 26
 include $(INCLUDE_DIR)/package.mk
26 27