浏览代码

lksctp-tools: import sctp from old packages feed

 - update to latest version (v1.0.16)
 - add license info
 - add myself as maintainer
 - install dev files the proper way in Build/InstallDev
 - rename sctp package to libsctp
 - add an sctp-tools package and an sctp transitional meta package

Signed-off-by: Nicolas Thill <nico@openwrt.org>
Nicolas Thill 9 年前
父节点
当前提交
1c0f9ee522
共有 1 个文件被更改,包括 92 次插入0 次删除
  1. 92
    0
      net/lksctp-tools/Makefile

+ 92
- 0
net/lksctp-tools/Makefile 查看文件

@@ -0,0 +1,92 @@
1
+#
2
+# Copyright (C) 2010-2015 OpenWrt.org
3
+#
4
+# This is free software, licensed under the GNU General Public License v2.
5
+# See /LICENSE for more information.
6
+#
7
+
8
+include $(TOPDIR)/rules.mk
9
+
10
+PKG_NAME:=lksctp-tools
11
+PKG_VERSION:=1.0.16
12
+PKG_RELEASE:=1
13
+
14
+PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
15
+PKG_SOURCE_URL:=@SF/lksctp
16
+PKG_MD5SUM:=708bb0b5a6806ad6e8d13c55b067518e
17
+
18
+PKG_LICENSE:=GPL-2.0
19
+PKG_LICENSE_FILES:=COPYING
20
+PKG_MAINTAINER:=Nicolas Thill <nico@openwrt.org>
21
+
22
+PKG_FIXUP:=autoreconf
23
+PKG_INSTALL:=1
24
+
25
+include $(INCLUDE_DIR)/package.mk
26
+
27
+define Package/lksctp-tools/Default
28
+  SECTION:=net
29
+  CATEGORY:=Network
30
+  TITLE:=SCTP user-land
31
+  URL:=http://lksctp.sourceforge.net
32
+endef
33
+
34
+define Package/libsctp
35
+$(call Package/lksctp-tools/Default)
36
+  SUBMENU:=Networking
37
+  SECTION:=libs
38
+  CATEGORY:=Libraries
39
+  TITLE+= library
40
+  URL:=http://lksctp.sourceforge.net
41
+  DEPENDS:=+kmod-sctp
42
+endef
43
+
44
+define Package/sctp
45
+$(call Package/lksctp-tools/Default)
46
+  TITLE+= (meta)
47
+  URL:=http://lksctp.sourceforge.net
48
+  DEPENDS:=+libsctp +sctp-tools
49
+endef
50
+
51
+define Package/sctp-tools
52
+$(call Package/lksctp-tools/Default)
53
+  TITLE+= tools
54
+  URL:=http://lksctp.sourceforge.net
55
+  DEPENDS:=+libsctp
56
+endef
57
+
58
+define Build/InstallDev
59
+	$(INSTALL_DIR) $(1)/usr/include
60
+	$(CP) \
61
+		$(PKG_INSTALL_DIR)/usr/include/netinet \
62
+		$(STAGING_DIR)/usr/include/
63
+	$(INSTALL_DIR) $(1)/usr/lib
64
+	$(CP) \
65
+		$(PKG_INSTALL_DIR)/usr/lib/libsctp.{a,so*} \
66
+		$(1)/usr/lib/
67
+endef
68
+
69
+define Package/libsctp/install
70
+	$(INSTALL_DIR) $(1)/usr/lib
71
+	$(CP) \
72
+		$(PKG_INSTALL_DIR)/usr/lib/libsctp.so.* \
73
+		$(1)/usr/lib/
74
+endef
75
+
76
+define Package/sctp/install
77
+	:
78
+endef
79
+
80
+define Package/sctp-tools/install
81
+	$(INSTALL_DIR) $(1)/usr/bin
82
+	$(CP) \
83
+		$(PKG_INSTALL_DIR)/usr/bin/checksctp \
84
+		$(1)/usr/bin/
85
+	$(CP) \
86
+		$(PKG_INSTALL_DIR)/usr/bin/sctp_{darn,status,test} \
87
+		$(1)/usr/bin/
88
+endef
89
+
90
+$(eval $(call BuildPackage,libsctp))
91
+$(eval $(call BuildPackage,sctp))
92
+$(eval $(call BuildPackage,sctp-tools))