Browse Source

python-pyptlib: new package

From the setup description:

A python implementation of the Pluggable Transports for Circumvention
specification for Tor

Signed-off-by: Jeffery To <jeffery.to@gmail.com>
Jeffery To 9 years ago
parent
commit
1cc4a5abeb
1 changed files with 46 additions and 0 deletions
  1. 46
    0
      lang/python-pyptlib/Makefile

+ 46
- 0
lang/python-pyptlib/Makefile View File

@@ -0,0 +1,46 @@
1
+#
2
+# Copyright (C) 2015 OpenWrt.org
3
+#
4
+# This is free software, licensed under the GNU General Public License v2.
5
+# See /LICENSE for more information.
6
+#
7
+
8
+include $(TOPDIR)/rules.mk
9
+
10
+PKG_NAME:=pyptlib
11
+PKG_VERSION:=0.0.6
12
+PKG_RELEASE:=1
13
+
14
+PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
15
+PKG_SOURCE_URL:=https://pypi.python.org/packages/source/p/pyptlib
16
+PKG_MD5SUM:=2fc7b8803777451c1fad3d5e25f1b99c
17
+
18
+PKG_BUILD_DEPENDS:=python python-setuptools
19
+
20
+PKG_LICENSE:=BSD-3-Clause
21
+PKG_LICENSE_FILES:=LICENSE
22
+PKG_MAINTAINER:=Jeffery To <jeffery.to@gmail.com>
23
+
24
+include $(INCLUDE_DIR)/package.mk
25
+$(call include_mk, python-package.mk)
26
+
27
+define Package/python-pyptlib
28
+	SECTION:=lang
29
+	CATEGORY:=Languages
30
+	SUBMENU:=Python
31
+	TITLE:=python-pyptlib
32
+	URL:=https://pypi.python.org/pypi/pyptlib
33
+	DEPENDS:=+python-light
34
+endef
35
+
36
+define Package/python-pyptlib/description
37
+A python implementation of the Pluggable Transports for Circumvention
38
+specification for Tor
39
+endef
40
+
41
+define Build/Compile
42
+	$(call Build/Compile/PyMod,,install --prefix="/usr" --root="$(PKG_INSTALL_DIR)")
43
+endef
44
+
45
+$(eval $(call PyPackage,python-pyptlib))
46
+$(eval $(call BuildPackage,python-pyptlib))