Sfoglia il codice sorgente

pcre: upgrade to 0.8.38

fixes:
  * CVE 2015-2327 CVE 2015-2328 CVE 2015-8380 CVE 2015-8381 CVE
  * 2015-8382
  * CVE 2015-8383 CVE 2015-8384 CVE 2015-8385 CVE 2015-8386 CVE
  * 2015-8387
  * CVE 2015-8388 CVE 2015-8389 CVE 2015-8390 CVE 2015-8391 CVE
  * 2015-8392
  * CVE 2015-8393 CVE 2015-8394 CVE 2015-8395

Signed-off-by: heil <heil@terminal-consulting.de>
heil 9 anni fa
parent
commit
1d3a098bb9
2 ha cambiato i file con 4 aggiunte e 36 eliminazioni
  1. 4
    4
      libs/pcre/Makefile
  2. 0
    32
      libs/pcre/patches/100-pcre-cve-2015-3210.patch

+ 4
- 4
libs/pcre/Makefile Vedi File

@@ -8,12 +8,12 @@
8 8
 include $(TOPDIR)/rules.mk
9 9
 
10 10
 PKG_NAME:=pcre
11
-PKG_VERSION:=8.37
12
-PKG_RELEASE:=2
11
+PKG_VERSION:=8.38
12
+PKG_RELEASE:=1
13 13
 
14 14
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
15
-PKG_SOURCE_URL:=@SF/pcre
16
-PKG_MD5SUM:=ed91be292cb01d21bc7e526816c26981
15
+PKG_SOURCE_URL:=ftp://ftp.csx.cam.ac.uk/pub/software/programming/pcre/
16
+PKG_MD5SUM:=00aabbfe56d5a48b270f999b508c5ad2
17 17
 PKG_MAINTAINER:=Thomas Heil <heil@terminal-consulting.de>
18 18
 
19 19
 PKG_LICENSE:=BSD-3-Clause

+ 0
- 32
libs/pcre/patches/100-pcre-cve-2015-3210.patch Vedi File

@@ -1,32 +0,0 @@
1
-Index: pcre-8.37/pcre_compile.c
2
-===================================================================
3
---- a/pcre_compile.c
4
-+++ b/pcre_compile.c
5
-@@ -7177,14 +7177,26 @@
6
-           number. If the name is not found, set the value to 0 for a forward
7
-           reference. */
8
- 
9
-+          recno = 0;
10
-           ng = cd->named_groups;
11
-           for (i = 0; i < cd->names_found; i++, ng++)
12
-             {
13
-             if (namelen == ng->length &&
14
-                 STRNCMP_UC_UC(name, ng->name, namelen) == 0)
15
--              break;
16
-+              {
17
-+              open_capitem *oc;
18
-+              recno = ng->number;
19
-+              if (is_recurse) break;
20
-+              for (oc = cd->open_caps; oc != NULL; oc = oc->next)         
21
-+                {          
22
-+                if (oc->number == recno)                                     
23
-+                  {               
24
-+                  oc->flag = TRUE;                                      
25
-+                  break;
26
-+                  }                                                         
27
-+                }                          
28
-+              }    
29
-             }
30
--          recno = (i < cd->names_found)? ng->number : 0;
31
- 
32
-           /* Count named back references. */